From: Keith Packard <keithp@keithp.com>
To: Alan Stern <stern@rowland.harvard.edu>, Greg KH <greg@kroah.com>
Cc: Pavel Machek <pavel@ucw.cz>, "Rafael J. Wysocki" <rjw@sisk.pl>,
Kernel development list <linux-kernel@vger.kernel.org>,
USB list <linux-usb@vger.kernel.org>
Subject: Re: [PATCH] USB: debugging code shouldn't alter control flow
Date: Sat, 04 Feb 2012 16:49:06 +0100 [thread overview]
Message-ID: <86r4yatx8t.fsf@sumi.keithp.com> (raw)
In-Reply-To: <Pine.LNX.4.44L0.1202021536080.1389-100000@iolanthe.rowland.org>
[-- Attachment #1: Type: text/plain, Size: 518 bytes --]
On Thu, 2 Feb 2012 15:38:14 -0500 (EST), Alan Stern <stern@rowland.harvard.edu> wrote:
> - urb->transfer_flags &= allowed;
> + allowed &= urb->transfer_flags;
Minor bikeshed here, but 'allowed' is not the right name for the value
at this point; perhaps just
/* warn if submitter gave bogus flags */
if ((urb->transfer_flags & allowed) != urb->transfer_flags)
might be better?
Otherwise, this looks nice to me.
Acked-by: Keith Packard <keithp@keithp.com>
--
keith.packard@intel.com
[-- Attachment #2: Type: application/pgp-signature, Size: 827 bytes --]
prev parent reply other threads:[~2012-02-04 15:49 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-01-23 5:58 [PATCH] Regression: Revert "Bluetooth: use buffer priority to mark URB_ISO_ASAP flag" Keith Packard
2012-01-23 9:03 ` Marcel Holtmann
2012-01-23 9:18 ` Johan Hedberg
2012-01-23 15:23 ` Alan Stern
2012-01-23 17:16 ` Keith Packard
2012-02-02 10:50 ` Pavel Machek
2012-02-02 20:38 ` [PATCH] USB: debugging code shouldn't alter control flow Alan Stern
2012-02-04 15:49 ` Keith Packard [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=86r4yatx8t.fsf@sumi.keithp.com \
--to=keithp@keithp.com \
--cc=greg@kroah.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=pavel@ucw.cz \
--cc=rjw@sisk.pl \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome