From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-43172.protonmail.ch (mail-43172.protonmail.ch [185.70.43.172]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 3ABD646EC76 for ; Wed, 5 Aug 2026 12:57:02 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=185.70.43.172 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1785934627; cv=none; b=LWhTQpPbnnGcDpmX3EzOiQ8mWbfwt/Oi4OeBx3YyLensD0heYeDoXklpChWFCQFtCcg1Pqy6t91Jcy3OB1QHtIrwkRAJzn+mj2SM2jebM+WdhDeWb/tNu0BFp4pX7foe8vDCBHjtldpOZE429hHGWRGg2duo2q4UI4FhelJieag= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1785934627; c=relaxed/simple; bh=mSD/+vVBnZINScPkXr8k1t+7gGRZGogc57BTA2J4LEE=; h=From:To:Cc:Subject:In-Reply-To:References:Date:Message-ID: MIME-Version:Content-Type; b=hv75lYfnDQi0Jhi1D1C3oRbTwaNKmCG0xpRTmaVQG5t0DH8dOhE59OD4g2EkE4nHUi2BUWO3Ydu7Bt7luWFx66GQT/y96aGbu9NXdO0tyJb1cscYguk5ISrfFOHtnOMoT0sYOgayptG7yehOV9bowGXoUcEQWAo4dzRLTj51DxU= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=quarantine dis=none) header.from=geanix.com; spf=pass smtp.mailfrom=geanix.com; dkim=pass (2048-bit key) header.d=geanix.com header.i=@geanix.com header.b=Yv5qsfpz; arc=none smtp.client-ip=185.70.43.172 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=quarantine dis=none) header.from=geanix.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=geanix.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=geanix.com header.i=@geanix.com header.b="Yv5qsfpz" DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=geanix.com; s=protonmail3; t=1785934619; x=1786193819; bh=YzaFEyDD8H+zTknUcCTt8BeOjFG68msT6YLRjbHU41w=; h=From:To:Cc:Subject:In-Reply-To:References:Date:Message-ID:From:To: Cc:Date:Subject:Reply-To:Feedback-ID:Message-ID:BIMI-Selector; b=Yv5qsfpzIte4EVCdvFHk3NmcpU547ZmHh3lBm9pqFWdEN1TeUTNuuS4MWB4U90mHA CzmBS5wXgBrTBhLNMaQ5ptISejwUXnCthshFSv/FX6fOoHOLF+07HS283oBqWZUUHK lXCWKd4d1mPTlTdOOLb9r2VrPMDGsZhO33ypDd1XPM1iAR6FpOc89rhRigYa1icx1V iqozGyHAeaJacU4cULJbSnPIdhK45X0mWOCjsTtnmsOh4jplDQmr7vdFiCnQFfG2AT Phn2eJzJcfhJ5rhxi7eyNeRK38ftrsnUGU38IPiWMzl4kraho4eJ1NoqaXwdwCwB7R cEYmC90gmc+kQ== X-Pm-Submission-Id: 4hFVmS65q8z1DDWb From: Esben Haabendal To: "Luca Ceresoli" Cc: "Andrzej Hajda" , "Neil Armstrong" , "Robert Foss" , "Laurent Pinchart" , "Jonas Karlman" , "Jernej Skrabec" , "Maarten Lankhorst" , "Maxime Ripard" , "Thomas Zimmermann" , "David Airlie" , "Simona Vetter" , , Subject: Re: [PATCH v2 1/4] drm/bridge: nwl-dsi: Limit LCDIF specific sync override In-Reply-To: <178591896149.480618.5962943390958440515.b4-review@b4> (Luca Ceresoli's message of "Wed, 05 Aug 2026 10:36:01 +0200") References: <20260803-nwl-dsi-fixes-v2-0-1809a0ac453f@geanix.com> <20260803-nwl-dsi-fixes-v2-1-1809a0ac453f@geanix.com> <178591896149.480618.5962943390958440515.b4-review@b4> Date: Wed, 05 Aug 2026 14:56:55 +0200 Message-ID: <871pccbu94.fsf@geanix.com> User-Agent: Gnus/5.13 (Gnus v5.13) Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain "Luca Ceresoli" writes: > On Mon, 03 Aug 2026 16:56:19 +0200, Esben Haabendal wrote: > > Hi Esben, > >> When using DCSS with NWL, overriding the mode flags to enforce active high >> sync is preventing the use of active low with downstream bridges, such as >> ti-sn65dsi83, which will not see such mode flags set by the panel. >> >> Signed-off-by: Esben Haabendal > > Is this a fix? If so, it should have Fixes: + Cc: stable. Yes. I will add tags. >> diff --git a/drivers/gpu/drm/bridge/nwl-dsi.c b/drivers/gpu/drm/bridge/nwl-dsi.c >> index 09992529f3d8..0fb10b686d1f 100644 >> --- a/drivers/gpu/drm/bridge/nwl-dsi.c >> +++ b/drivers/gpu/drm/bridge/nwl-dsi.c >> @@ -821,10 +823,13 @@ static int nwl_dsi_bridge_atomic_check(struct drm_bridge *bridge, >> struct drm_connector_state *conn_state) >> { >> struct drm_display_mode *adjusted_mode = &crtc_state->adjusted_mode; >> + struct nwl_dsi *dsi = bridge_to_dsi(bridge); >> >> /* At least LCDIF + NWL needs active high sync */ >> - adjusted_mode->flags |= (DRM_MODE_FLAG_PHSYNC | DRM_MODE_FLAG_PVSYNC); >> - adjusted_mode->flags &= ~(DRM_MODE_FLAG_NHSYNC | DRM_MODE_FLAG_NVSYNC); >> + if (dsi->endpoint == NWL_DSI_ENDPOINT_LCDIF) { >> + adjusted_mode->flags |= (DRM_MODE_FLAG_PHSYNC | DRM_MODE_FLAG_PVSYNC); >> + adjusted_mode->flags &= ~(DRM_MODE_FLAG_NHSYNC | DRM_MODE_FLAG_NVSYNC); >> + } > > In some sense, this patch is doing two things. One is the hunk above, doing > what the commit message says... > >> @@ -1103,11 +1107,12 @@ static int nwl_dsi_select_input(struct nwl_dsi *dsi) >> "No valid input endpoint found\n"); >> return -EINVAL; >> } >> + dsi->endpoint = NWL_DSI_ENDPOINT_DCSS; >> } > > ...and this is a somewhat orthogonal change, changing the way the endpoint > selection is stored: either as a bool (false = LCDIF, true = DCSS) or as an > index (0 = LCDIF, 1 = DCSS). No problem with this change, I think it makes > code more readable. Just I'd rather keep it as a separate cleanup > patch. I will split it into two patches. >> DRM_DEV_INFO(dsi->dev, "Using %s as input source\n", >> - (use_dcss) ? "DCSS" : "LCDIF"); >> - ret = mux_control_try_select(dsi->mux, use_dcss); >> + (dsi->endpoint == NWL_DSI_ENDPOINT_DCSS) ? "DCSS" : "LCDIF"); >> + ret = mux_control_try_select(dsi->mux, dsi->endpoint == NWL_DSI_ENDPOINT_DCSS); > > The code here is not formally correct. mux_control_try_select() takes a > state argument, which is an integer, but you are passing a bool. It would > still work just because bools are mapped to 0/1. Looks like should simply > become: > > ret = mux_control_try_select(dsi->mux, dsi->endpoint); Fixing, thanks. /Esben