From: SF Markus Elfring <elfring@users.sourceforge.net>
To: linux-input@vger.kernel.org,
"Benjamin Tissoires" <benjamin.tissoires@redhat.com>,
"Bruno Prémont" <bonbons@linux-vserver.org>,
"Jiri Kosina" <jikos@kernel.org>
Cc: LKML <linux-kernel@vger.kernel.org>, kernel-janitors@vger.kernel.org
Subject: [PATCH 17/18] HID-debug: Delete an unnecessary variable initialisation in hid_resolv_usage()
Date: Tue, 7 Feb 2017 21:00:08 +0100 [thread overview]
Message-ID: <87289011-09d8-d544-f4f7-46ca739ccbf5@users.sourceforge.net> (raw)
In-Reply-To: <edd25fcd-8625-2469-fa28-2315f81b6b8e@users.sourceforge.net>
From: Markus Elfring <elfring@users.sourceforge.net>
Date: Tue, 7 Feb 2017 20:12:09 +0100
The local variable "buf" will be set to an appropriate pointer
by the following statement. Thus omit the explicit initialisation
at the beginning.
Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
drivers/hid/hid-debug.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/hid/hid-debug.c b/drivers/hid/hid-debug.c
index 044b12e32240..0d33bf0d47d1 100644
--- a/drivers/hid/hid-debug.c
+++ b/drivers/hid/hid-debug.c
@@ -481,7 +481,7 @@ static char *resolv_usage_page(unsigned page, struct seq_file *f) {
char *hid_resolv_usage(unsigned usage, struct seq_file *f) {
const struct hid_usage_entry *p;
- char *buf = NULL;
+ char *buf;
int len = 0;
buf = resolv_usage_page(usage >> 16, f);
--
2.11.1
next prev parent reply other threads:[~2017-02-07 20:00 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-02-07 19:36 [PATCH 00/18] HID: Fine-tuning for several function implementations SF Markus Elfring
2017-02-07 19:39 ` [PATCH 01/18] HID: Use kmalloc_array() in hid_input_field() SF Markus Elfring
2017-02-07 19:40 ` [PATCH 02/18] HID: Delete an error message for a failed memory allocation in open_collection() SF Markus Elfring
2017-02-07 19:42 ` [PATCH 03/18] HID: Use kmalloc_array() " SF Markus Elfring
2017-02-07 19:43 ` [PATCH 04/18] HID: Improve another size determination " SF Markus Elfring
2017-02-07 19:46 ` [PATCH 05/18] HID: Improve two size determinations in hid_open_report() SF Markus Elfring
2017-02-07 19:48 ` [PATCH 06/18] HID: Improve another size determination in hid_scan_report() SF Markus Elfring
2017-02-07 19:49 ` [PATCH 07/18] HID: Improve another size determination in hid_register_report() SF Markus Elfring
2017-02-07 19:50 ` [PATCH 08/18] HID: Adjust five checks for null pointers SF Markus Elfring
2017-02-07 19:51 ` [PATCH 09/18] HID: Return an error code only as a constant in hid_allocate_device() SF Markus Elfring
2017-02-07 19:52 ` [PATCH 10/18] HID-debug: Replace five seq_printf() calls by seq_putc() SF Markus Elfring
2017-02-07 19:54 ` [PATCH 11/18] HID-debug: Delete an unnecessary seq_printf() call in hid_dump_device() SF Markus Elfring
2017-02-07 19:55 ` [PATCH 12/18] HID-debug: Replace 12 seq_printf() calls by seq_puts() SF Markus Elfring
2017-02-07 19:56 ` [PATCH 13/18] HID-debug: Combine 11 seq_printf() calls into one call in hid_dump_field() SF Markus Elfring
2017-02-07 22:52 ` Joe Perches
2017-02-07 19:57 ` [PATCH 14/18] HID-debug: Adjust two function calls together with a variable assignment SF Markus Elfring
2017-02-07 19:58 ` [PATCH 15/18] HID-debug: Return an error code only as a constant in hid_debug_events_open() SF Markus Elfring
2017-02-07 19:59 ` [PATCH 16/18] HID-debug: Add some spaces for better code readability SF Markus Elfring
2017-02-07 20:00 ` SF Markus Elfring [this message]
2017-02-07 20:01 ` [PATCH 18/18] HID-picoLCD: Use seq_puts() in picolcd_debug_reset_show() SF Markus Elfring
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87289011-09d8-d544-f4f7-46ca739ccbf5@users.sourceforge.net \
--to=elfring@users.sourceforge.net \
--cc=benjamin.tissoires@redhat.com \
--cc=bonbons@linux-vserver.org \
--cc=jikos@kernel.org \
--cc=kernel-janitors@vger.kernel.org \
--cc=linux-input@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®