mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: OGAWA Hirofumi <hirofumi@mail.parknet.co.jp>
To: Carmeli Tamir <carmeli.tamir@gmail.com>
Cc: linux-kernel@vger.kernel.org, jthumshirn@suse.de,
	sergey.senozhatsky@gmail.com, akpm@linux-foundation.org,
	bvanassche@acm.org, axboe@kernel.dk, martin.petersen@oracle.com,
	sfr@canb.auug.org.au
Subject: Re: [PATCH v3 0/3] fat: Added functions to determine the FAT variant (12/16/32bit)
Date: Mon, 24 Dec 2018 21:04:12 +0900	[thread overview]
Message-ID: <874lb3jflv.fsf@mail.parknet.co.jp> (raw)
In-Reply-To: <1544990640-11604-1-git-send-email-carmeli.tamir@gmail.com> (Carmeli Tamir's message of "Sun, 16 Dec 2018 15:03:57 -0500")

Carmeli Tamir <carmeli.tamir@gmail.com> writes:

> Along the FAT FS code, the FAT variant (whether this is FAT12, FAT16 or FAT32) is
> determined by checking the fat_bits field of struct msdos_sb_info.
> This is somewhat error prone as it forces the usage of magics (12, 16, 32)
> multiple times in the code.
>
> This series replaces the places in which the variant is checked with three
> inline functions - IS_FAT12, IS_FAT16 and IS_FAT16.
>
> The introduction of these simple inline functions makes a clearer API for determining the variant,
> rather than searching the code for some field in a struct, and therefore
> increases the code's maintainability and readability.
>
> In addition, minor cleanups around code that checks for the FAT variant,
> and fixed comments from v1 and v2.
>
> Carmeli Tamir (3):
>   Removed fat_first_ent
>   Moved and inlined MAX_FAT
>   IS_FAT functions
>
>  fs/fat/cache.c                |  2 +-
>  fs/fat/dir.c                  |  4 ++--
>  fs/fat/fat.h                  | 30 +++++++++++++++++++++++++++++-
>  fs/fat/fatent.c               | 16 +++++++---------
>  fs/fat/inode.c                | 26 +++++++++++++++-----------
>  fs/fat/misc.c                 |  2 +-
>  include/uapi/linux/msdos_fs.h |  5 -----
>  7 files changed, 55 insertions(+), 30 deletions(-)

FWIW,

Acked-by: OGAWA Hirofumi <hirofumi@mail.parknet.co.jp>

for all of this patchset.

Thanks.
-- 
OGAWA Hirofumi <hirofumi@mail.parknet.co.jp>

  parent reply	other threads:[~2018-12-24 12:04 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-12-16 20:03 Carmeli Tamir
2018-12-16 20:03 ` [PATCH v3 1/3] fat: Removed FAT_FIRST_ENT macro Carmeli Tamir
2018-12-16 20:03 ` [PATCH v3 2/3] fat: Moved MAX_FAT to fat.h and changed it to inline function Carmeli Tamir
2018-12-16 20:04 ` [PATCH v3 3/3] fat: New inline functions to determine the FAT variant (32, 16 or 12) Carmeli Tamir
2018-12-24 12:04 ` OGAWA Hirofumi [this message]
2018-12-25  9:48   ` [PATCH v3 0/3] fat: Added functions to determine the FAT variant (12/16/32bit) Sergey Senozhatsky

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=874lb3jflv.fsf@mail.parknet.co.jp \
    --to=hirofumi@mail.parknet.co.jp \
    --cc=akpm@linux-foundation.org \
    --cc=axboe@kernel.dk \
    --cc=bvanassche@acm.org \
    --cc=carmeli.tamir@gmail.com \
    --cc=jthumshirn@suse.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=sergey.senozhatsky@gmail.com \
    --cc=sfr@canb.auug.org.au \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®