From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from mail-pf1-f170.google.com (mail-pf1-f170.google.com [209.85.210.170]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id EEA512C0F81 for ; Thu, 11 Dec 2025 01:31:13 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=209.85.210.170 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1765416675; cv=none; b=WRaqUsmcRgx+6FYssxqEHYaxZt/Wl6r+dRBeN7WbZbjzd2bQY2LB9+TDHBrYBZhBdJ0wyMpH1ZHaWoNJ5b6kt6gw2uUj7eNjJLEbXZkSCwTE3zJYefOF1ZRWhkdAuPG4rpPXt15x1eJGXjvOPWTQGDM//0GS6XZqJ8U+NaEwKu8= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1765416675; c=relaxed/simple; bh=WTGcFCS6w7nlAaqkBZ3n6Gv7wFcX8BfAhcm/JFIe5Lk=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=DbNO2UGTrmlk0YU7nikYmuD7QZEN5kXDk9v1ZM8QXBD2VB9VuV+5gb6BvJiEWNBeaIkbimry9Ig2CfEAGJ8YqxyPFWjT0Yxpwjyn+MeJ/n754n/uOMICURmki0pKeZyhKOS6ZwkrQhS6oJiQhjbJJXIJo6I0ESOlJ4Q+Z4y9sO4= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=gmail.com; spf=pass smtp.mailfrom=gmail.com; dkim=pass (2048-bit key) header.d=gmail.com header.i=@gmail.com header.b=IeYXdFQK; arc=none smtp.client-ip=209.85.210.170 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=gmail.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=gmail.com Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=gmail.com header.i=@gmail.com header.b="IeYXdFQK" Received: by mail-pf1-f170.google.com with SMTP id d2e1a72fcca58-7f121c00dedso552834b3a.0 for ; Wed, 10 Dec 2025 17:31:13 -0800 (PST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20230601; t=1765416673; x=1766021473; darn=vger.kernel.org; h=content-transfer-encoding:in-reply-to:from:content-language :references:cc:to:subject:user-agent:mime-version:date:message-id :from:to:cc:subject:date:message-id:reply-to; bh=fZdCO/Mv9RBE0LHZ0bjkyPo+ciEfdxSfUwGGq9Yh/c0=; b=IeYXdFQKWk7t+QfhJqDOEqv0XEjreRqj+MI3d6Je3A12CgF4LpScw8LH8F1RG7zmUO JDm06TPyDoqBHiKEZoh9TGOFeAvZ9dpQC46DDNtSEY5VqcktDvLdTtZ9dFj+UNW7Js2F TnM61m83TBAWje3XUfVC2rABiD1Zp53TavlIFhJwson7M0/WEnLdqFBcCXpjCBNos6RA tsO483vypG3w1MhDgmKNYdMsnFQAbonE3ibAxD0NwV8VoSnLVZ5C9Jang1AuMhNA92r9 2npaDjbBCEYe1fdrTg4bS5OYlCJhPTy+CoKQpuedqBpFCo5pGA94jJoXUjwUoVfoWxe+ Zqtg== X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20230601; t=1765416673; x=1766021473; h=content-transfer-encoding:in-reply-to:from:content-language :references:cc:to:subject:user-agent:mime-version:date:message-id :x-gm-gg:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to; bh=fZdCO/Mv9RBE0LHZ0bjkyPo+ciEfdxSfUwGGq9Yh/c0=; b=kY/NdC6saeT4/N4KT3ava9UhTBaDC5K9UG3ObDlGtSA0FthWeVXIB8CjyLGk2Tjz3x lRNmnFgBqhh2rICuyU2TLBdXKtzV/iE2nYHDaJCho5hhvC8nxOQmykwiM+OCdz2l/EqN ZK5JkuD2xARCVE65x3kDjydlAv31ei6Szh7DMSrvoz0FZw0JroKeVtlIIg1XcVQRC9wE ey9sc9eEFsRyef11ajbhyc2f2ZYOto+3acKUyDiR+vwwqQYMrodPtn6XVeivtk6IO3mD boWY/1miprMRWx7tZ4bkvhXLsnJNP/eSTCQxcvhupHwGE/6eSpzmn/vDy5PDzQWjenN9 TK9w== X-Forwarded-Encrypted: i=1; AJvYcCWZyyGx/xsG6LF9bBB9VnaY4tjLsIgoSNriyXpk++x9JJC/KDWNe3rZRP9FtqubahQYkIk8dAhzeJoL5BM=@vger.kernel.org X-Gm-Message-State: AOJu0YwUTzxjXGmVKBukN4/Yi/3M/of4Z0ggY5zNhUGZSzpTWEGXwdJ8 Gb7WPaFB3eWjRedqL9/+9tcENlRlMfW/rvv2Yon02h5jTj7Rhe464XU9 X-Gm-Gg: ASbGnctNEPjEiq2NQFsKMu5hq/dKYU9WvfPWS6FE3mPDEn6yav6wWMHC3mX88fX+E4U dS4pv9Qp4qJYLsN7V6qKPIwInYdIjgL5ktxy+MwV927Ump1VefmsZnj0ncY8rWU08hz4vT6DX4M bb4B5RojCi38Kv/0uZEEW4s7bbKF3Uoc/8xV7TLHqDOC6MTFZWEloSHjnj8yaw1qfp/VJwkZh60 QupOZX2S3co2qFJYJ8DsQyVzaLfDAdC5PfZTReoKoEKc1YAb9v2daTDJtP42F4+l9X6Jzkd2ZhR rz7UcvU/4lk5oaznx8foA2rpPuHBQOUqg095Ov+YfR0WYofBB3eqPrb/SquElw1cSGmjkW+WmjE J1T/oi7NXeccOMQAuk7PgrSoEsICOQzGNCTykOQxa+KP7pFypRrUacHCiTuJWL4B6YgixToYnTB AktHyfGxW9EdM3dLOWiPFxSw0oD9TtMln5d5PhDen0TNjJb/P0n8Xr6AAEjzz73BDTo026uNZqq E69hSETdK8VfnHfyqNay3EE+isP4sMFy40k1EH8sfVeEVuaFj4cV3w+vp5Q7g== X-Google-Smtp-Source: AGHT+IGVt+ykzKwUkvlI66EhGPLEJT0k2WcMqC7wbWNtFp2WzvnzQClEU8G0uA4bJZHHBv9Er2SFdw== X-Received: by 2002:a05:6a20:3d25:b0:366:14b0:1a37 with SMTP id adf61e73a8af0-366e33be8e5mr4459913637.69.1765416673027; Wed, 10 Dec 2025 17:31:13 -0800 (PST) Received: from [10.200.8.97] (fs98a57d9d.tkyc007.ap.nuro.jp. [152.165.125.157]) by smtp.gmail.com with ESMTPSA id 41be03b00d2f7-c0c2bfa0845sm618391a12.28.2025.12.10.17.31.05 (version=TLS1_3 cipher=TLS_AES_128_GCM_SHA256 bits=128/128); Wed, 10 Dec 2025 17:31:12 -0800 (PST) Message-ID: <878759ec-f630-4961-a17f-6355df26507f@gmail.com> Date: Thu, 11 Dec 2025 01:31:09 +0000 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH net-next v7 4/9] net: let pp memory provider to specify rx buf len To: Jakub Kicinski Cc: netdev@vger.kernel.org, "David S . Miller" , Eric Dumazet , Paolo Abeni , Jonathan Corbet , Michael Chan , Pavan Chebbi , Andrew Lunn , Alexei Starovoitov , Daniel Borkmann , Jesper Dangaard Brouer , John Fastabend , Ilias Apalodimas , Shuah Khan , Mina Almasry , Stanislav Fomichev , Yue Haibing , David Wei , Haiyue Wang , Jens Axboe , Joe Damato , Simon Horman , Vishwanath Seshagiri , linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org, bpf@vger.kernel.org, linux-kselftest@vger.kernel.org, io-uring@vger.kernel.org, dtatulea@nvidia.com References: <0364ec97cc65b7b7b7376b98438c2630fa2e003c.1764542851.git.asml.silence@gmail.com> <20251202110431.376dc793@kernel.org> Content-Language: en-US From: Pavel Begunkov In-Reply-To: <20251202110431.376dc793@kernel.org> Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 7bit On 12/2/25 19:04, Jakub Kicinski wrote: > On Sun, 30 Nov 2025 23:35:19 +0000 Pavel Begunkov wrote: >> +enum { >> + /* queue restart support custom rx buffer sizes */ >> + NDO_QUEUE_RX_BUF_SIZE = 0x1, > > If you have to respin -- let's drop the NDO from this define. > To suggest something specific - QCFG_ is a better prefix? > IDK why we ended up with ndo_ prefix on the queue ops.. QCFG_ sounds better indeed > Also RX_PAGE_SIZE is a better name for the fields? RX_BUF_SIZE > is easy to confuse with RX_BUF_LEN which we are no longer trying > to modify. It's not "page" because there are no struct page's, and those are just buffers. Maybe it's also some net/driver specific term? I don't get the difference here b/w "size" and "len" either, but in any case I don't really have any real opinion about the name, and it can always be changed later. -- Pavel Begunkov