From: neil.armstrong@linaro.org
To: Nitin Rawat <quic_nitirawa@quicinc.com>,
vkoul@kernel.org, kishon@kernel.org,
manivannan.sadhasivam@linaro.org,
James.Bottomley@HansenPartnership.com,
martin.petersen@oracle.com, bvanassche@acm.org,
andersson@kernel.org, dmitry.baryshkov@oss.qualcomm.com,
konrad.dybcio@oss.qualcomm.com
Cc: quic_rdwivedi@quicinc.com, quic_cang@quicinc.com,
linux-arm-msm@vger.kernel.org, linux-phy@lists.infradead.org,
linux-kernel@vger.kernel.org, linux-scsi@vger.kernel.org
Subject: Re: [PATCH V5 06/11] phy: qcom-qmp-ufs: Rename qmp_ufs_power_off
Date: Mon, 19 May 2025 15:11:46 +0200 [thread overview]
Message-ID: <87a7a21e-a2c1-40d1-bc53-c55db8380973@linaro.org> (raw)
In-Reply-To: <20250515162722.6933-7-quic_nitirawa@quicinc.com>
On 15/05/2025 18:27, Nitin Rawat wrote:
> Rename qmp_ufs_disable to qmp_ufs_power_off to better represent its
> functionality. Additionally, inline qmp_ufs_exit into qmp_ufs_power_off
> function to preserve the functionality of .power_off.
>
> There is no functional change.
>
> Signed-off-by: Nitin Rawat <quic_nitirawa@quicinc.com>
> ---
> drivers/phy/qualcomm/phy-qcom-qmp-ufs.c | 19 +------------------
> 1 file changed, 1 insertion(+), 18 deletions(-)
>
> diff --git a/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c b/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> index d3f9ee490a32..a5974a1fb5bb 100644
> --- a/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> +++ b/drivers/phy/qualcomm/phy-qcom-qmp-ufs.c
> @@ -1851,28 +1851,11 @@ static int qmp_ufs_power_off(struct phy *phy)
> qphy_clrbits(qmp->pcs, cfg->regs[QPHY_PCS_POWER_DOWN_CONTROL],
> SW_PWRDN);
>
> - return 0;
> -}
> -
> -static int qmp_ufs_exit(struct phy *phy)
> -{
> - struct qmp_ufs *qmp = phy_get_drvdata(phy);
> -
> qmp_ufs_com_exit(qmp);
>
> return 0;
> }
>
> -static int qmp_ufs_disable(struct phy *phy)
> -{
> - int ret;
> -
> - ret = qmp_ufs_power_off(phy);
> - if (ret)
> - return ret;
> - return qmp_ufs_exit(phy);
> -}
> -
> static int qmp_ufs_set_mode(struct phy *phy, enum phy_mode mode, int submode)
> {
> struct qmp_ufs *qmp = phy_get_drvdata(phy);
> @@ -1921,7 +1904,7 @@ static int qmp_ufs_phy_init(struct phy *phy)
> static const struct phy_ops qcom_qmp_ufs_phy_ops = {
> .init = qmp_ufs_phy_init,
> .power_on = qmp_ufs_power_on,
> - .power_off = qmp_ufs_disable,
> + .power_off = qmp_ufs_power_off,
> .calibrate = qmp_ufs_phy_calibrate,
> .set_mode = qmp_ufs_set_mode,
> .owner = THIS_MODULE,
> --
> 2.48.1
>
Reviewed-by: Neil Armstrong <neil.armstrong@linaro.org>
next prev parent reply other threads:[~2025-05-19 13:11 UTC|newest]
Thread overview: 41+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-15 16:27 [PATCH V5 00/11] Refactor ufs phy powerup sequence Nitin Rawat
2025-05-15 16:27 ` [PATCH V5 01/11] scsi: ufs: qcom: add a new phy calibrate API call Nitin Rawat
2025-05-18 22:50 ` Dmitry Baryshkov
2025-05-21 13:08 ` Manivannan Sadhasivam
2025-05-21 21:44 ` Nitin Rawat
2025-05-15 16:27 ` [PATCH V5 02/11] phy: qcom-qmp-ufs: Rename qmp_ufs_enable and qmp_ufs_power_on Nitin Rawat
2025-05-21 13:09 ` Manivannan Sadhasivam
2025-05-15 16:27 ` [PATCH V5 03/11] phy: qcom-qmp-ufs: Refactor phy_power_on and phy_calibrate callbacks Nitin Rawat
2025-05-21 13:13 ` Manivannan Sadhasivam
2025-05-15 16:27 ` [PATCH V5 04/11] phy: qcom-qmp-ufs: Refactor UFS PHY reset Nitin Rawat
2025-05-21 13:26 ` Manivannan Sadhasivam
2025-05-21 21:47 ` Nitin Rawat
2025-05-15 16:27 ` [PATCH V5 05/11] phy: qcom-qmp-ufs: Remove qmp_ufs_com_init() Nitin Rawat
2025-05-21 13:30 ` Manivannan Sadhasivam
2025-05-21 21:49 ` Nitin Rawat
2025-05-15 16:27 ` [PATCH V5 06/11] phy: qcom-qmp-ufs: Rename qmp_ufs_power_off Nitin Rawat
2025-05-18 22:47 ` Dmitry Baryshkov
2025-05-19 13:11 ` neil.armstrong [this message]
2025-05-15 16:27 ` [PATCH V5 07/11] phy: qcom-qmp-ufs: Remove qmp_ufs_exit() and Inline qmp_ufs_com_exit() Nitin Rawat
2025-05-21 13:49 ` Manivannan Sadhasivam
2025-05-21 22:19 ` Nitin Rawat
2025-05-22 8:53 ` Manivannan Sadhasivam
2025-05-22 9:20 ` Nitin Rawat
2025-05-15 16:27 ` [PATCH V5 08/11] phy: qcom-qmp-ufs: refactor qmp_ufs_power_off Nitin Rawat
2025-05-21 13:50 ` Manivannan Sadhasivam
2025-05-15 16:27 ` [PATCH V5 09/11] scsi: ufs: qcom : Refactor phy_power_on/off calls Nitin Rawat
2025-05-21 13:57 ` Manivannan Sadhasivam
2025-05-21 21:40 ` Nitin Rawat
2025-05-22 8:55 ` Manivannan Sadhasivam
2025-05-22 9:19 ` Nitin Rawat
2025-05-15 16:27 ` [PATCH V5 10/11] scsi: ufs: qcom : Introduce phy_power_on/off wrapper function Nitin Rawat
2025-05-21 14:01 ` Manivannan Sadhasivam
2025-05-21 22:18 ` Nitin Rawat
2025-05-22 9:31 ` Manivannan Sadhasivam
2025-05-22 10:26 ` Nitin Rawat
2025-05-15 16:27 ` [PATCH V5 11/11] scsi: ufs: qcom: Prevent calling phy_exit before phy_init Nitin Rawat
2025-05-21 14:05 ` Manivannan Sadhasivam
2025-05-21 22:21 ` Nitin Rawat
2025-05-21 1:45 ` [PATCH V5 00/11] Refactor ufs phy powerup sequence Martin K. Petersen
2025-05-21 13:10 ` Dmitry Baryshkov
2025-05-27 15:22 ` Nitin Rawat
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87a7a21e-a2c1-40d1-bc53-c55db8380973@linaro.org \
--to=neil.armstrong@linaro.org \
--cc=James.Bottomley@HansenPartnership.com \
--cc=andersson@kernel.org \
--cc=bvanassche@acm.org \
--cc=dmitry.baryshkov@oss.qualcomm.com \
--cc=kishon@kernel.org \
--cc=konrad.dybcio@oss.qualcomm.com \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-phy@lists.infradead.org \
--cc=linux-scsi@vger.kernel.org \
--cc=manivannan.sadhasivam@linaro.org \
--cc=martin.petersen@oracle.com \
--cc=quic_cang@quicinc.com \
--cc=quic_nitirawa@quicinc.com \
--cc=quic_rdwivedi@quicinc.com \
--cc=vkoul@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®