From: Rasmus Villemoes <linux@rasmusvillemoes.dk>
To: Sam Ravnborg <sam@ravnborg.org>
Cc: Rusty Russell <rusty@rustcorp.com.au>,
Paul Gortmaker <paul.gortmaker@windriver.com>,
"H. Peter Anvin" <hpa@linux.intel.com>,
Andrew Morton <akpm@linux-foundation.org>,
linux-kernel@vger.kernel.org,
Rasmus Villemoes <linux@rasmusvillemoes.dk>
Subject: [PATCH] scripts: modpost: Remove numeric suffix pattern matching
Date: Wed, 09 Jul 2014 11:41:48 +0200 [thread overview]
Message-ID: <87a98idg2r.fsf_-_@rasmusvillemoes.dk> (raw)
In-Reply-To: <20140709071319.GA30377@ravnborg.org> (Sam Ravnborg's message of "Wed, 9 Jul 2014 09:13:19 +0200")
For several years, the pattern "foo$" has effectively been treated as
equivalent to "foo" due to a bug in the (misnamed) helper
number_prefix(). This hasn't been observed to cause any problems, so
remove the broken $ functionality and change all foo$ patterns to foo.
Signed-off-by: Rasmus Villemoes <linux@rasmusvillemoes.dk>
---
Sam, was this what you meant? Otherwise, I'd be more than happy to
leave the issue to someone else.
scripts/mod/modpost.c | 49 ++++++++++---------------------------------------
1 file changed, 10 insertions(+), 39 deletions(-)
diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
index 9d9c5b9..8f5e122 100644
--- a/scripts/mod/modpost.c
+++ b/scripts/mod/modpost.c
@@ -772,32 +772,10 @@ static const char *sech_name(struct elf_info *elf, Elf_Shdr *sechdr)
sechdr->sh_name;
}
-/* if sym is empty or point to a string
- * like ".[0-9]+" then return 1.
- * This is the optional prefix added by ld to some sections
- */
-static int number_prefix(const char *sym)
-{
- if (*sym++ == '\0')
- return 1;
- if (*sym != '.')
- return 0;
- do {
- char c = *sym++;
- if (c < '0' || c > '9')
- return 0;
- } while (*sym);
- return 1;
-}
-
/* The pattern is an array of simple patterns.
* "foo" will match an exact string equal to "foo"
* "*foo" will match a string that ends with "foo"
* "foo*" will match a string that begins with "foo"
- * "foo$" will match a string equal to "foo" or "foo.1"
- * where the '1' can be any number including several digits.
- * The $ syntax is for sections where ld append a dot number
- * to make section name unique.
*/
static int match(const char *sym, const char * const pat[])
{
@@ -816,13 +794,6 @@ static int match(const char *sym, const char * const pat[])
if (strncmp(sym, p, strlen(p) - 1) == 0)
return 1;
}
- /* "foo$" */
- else if (*endp == '$') {
- if (strncmp(sym, p, strlen(p) - 1) == 0) {
- if (number_prefix(sym + strlen(p) - 1))
- return 1;
- }
- }
/* no wildcards */
else {
if (strcmp(p, sym) == 0)
@@ -880,20 +851,20 @@ static void check_section(const char *modname, struct elf_info *elf,
#define ALL_INIT_DATA_SECTIONS \
- ".init.setup$", ".init.rodata$", ".meminit.rodata$", \
- ".init.data$", ".meminit.data$"
+ ".init.setup", ".init.rodata", ".meminit.rodata", \
+ ".init.data", ".meminit.data"
#define ALL_EXIT_DATA_SECTIONS \
- ".exit.data$", ".memexit.data$"
+ ".exit.data", ".memexit.data"
#define ALL_INIT_TEXT_SECTIONS \
- ".init.text$", ".meminit.text$"
+ ".init.text", ".meminit.text"
#define ALL_EXIT_TEXT_SECTIONS \
- ".exit.text$", ".memexit.text$"
+ ".exit.text", ".memexit.text"
#define ALL_PCI_INIT_SECTIONS \
- ".pci_fixup_early$", ".pci_fixup_header$", ".pci_fixup_final$", \
- ".pci_fixup_enable$", ".pci_fixup_resume$", \
- ".pci_fixup_resume_early$", ".pci_fixup_suspend$"
+ ".pci_fixup_early", ".pci_fixup_header", ".pci_fixup_final", \
+ ".pci_fixup_enable", ".pci_fixup_resume", \
+ ".pci_fixup_resume_early", ".pci_fixup_suspend"
#define ALL_XXXINIT_SECTIONS MEM_INIT_SECTIONS
#define ALL_XXXEXIT_SECTIONS MEM_EXIT_SECTIONS
@@ -901,8 +872,8 @@ static void check_section(const char *modname, struct elf_info *elf,
#define ALL_INIT_SECTIONS INIT_SECTIONS, ALL_XXXINIT_SECTIONS
#define ALL_EXIT_SECTIONS EXIT_SECTIONS, ALL_XXXEXIT_SECTIONS
-#define DATA_SECTIONS ".data$", ".data.rel$"
-#define TEXT_SECTIONS ".text$", ".text.unlikely$"
+#define DATA_SECTIONS ".data", ".data.rel"
+#define TEXT_SECTIONS ".text", ".text.unlikely"
#define INIT_SECTIONS ".init.*"
#define MEM_INIT_SECTIONS ".meminit.*"
--
1.9.2
next prev parent reply other threads:[~2014-07-09 9:41 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-06-25 8:46 [PATCH] scripts/mod/modpost.c: Fix bug in number_prefix Rasmus Villemoes
2014-06-25 14:26 ` Paul Gortmaker
2014-06-25 22:57 ` Rasmus Villemoes
2014-07-08 23:58 ` Rusty Russell
2014-07-09 7:13 ` Sam Ravnborg
2014-07-09 9:41 ` Rasmus Villemoes [this message]
2014-07-09 20:47 ` [PATCH] scripts: modpost: Remove numeric suffix pattern matching Sam Ravnborg
2014-07-10 1:14 ` Rusty Russell
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87a98idg2r.fsf_-_@rasmusvillemoes.dk \
--to=linux@rasmusvillemoes.dk \
--cc=akpm@linux-foundation.org \
--cc=hpa@linux.intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=paul.gortmaker@windriver.com \
--cc=rusty@rustcorp.com.au \
--cc=sam@ravnborg.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®