From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751964AbdJLQzD (ORCPT ); Thu, 12 Oct 2017 12:55:03 -0400 Received: from osg.samsung.com ([64.30.133.232]:35095 "EHLO osg.samsung.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751518AbdJLQzB (ORCPT ); Thu, 12 Oct 2017 12:55:01 -0400 Subject: Re: [PATCH 4.9 000/105] 4.9.55-stable review To: Xin Long , Andreas Radke Cc: Greg Kroah-Hartman , "davem@davemloft.net" , LKML , torvalds@linux-foundation.org, akpm@linux-foundation.org, linux@roeck-us.net, patches@kernelci.org, ben.hutchings@codethink.co.uk, stable@vger.kernel.org, Shuah Khan References: <20171010192533.717049376@linuxfoundation.org> <20171011125646.GG27734@kroah.com> <10022e69-2644-cd2c-4abf-643fb53115fd@osg.samsung.com> <20171012103952.GE24647@kroah.com> <20171012115426.GA25954@kroah.com> <20171012121316.GA12343@kroah.com> <97b732a2-c7a2-e1db-407f-1158bba663a7@osg.samsung.com> <20171012171826.122420ea@workstation64.home> From: Shuah Khan Message-ID: <87b44ea3-e614-7461-3b53-2da61f40a320@osg.samsung.com> Date: Thu, 12 Oct 2017 10:54:49 -0600 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.2.1 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8 Content-Language: en-US Content-Transfer-Encoding: 8bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 10/12/2017 09:35 AM, Shuah Khan wrote: > On 10/12/2017 09:25 AM, Xin Long wrote: >> On Thu, Oct 12, 2017 at 11:18 PM, Andreas Radke >> wrote: >>> Building the 4.9.x kernel package for Arch Linux 4.9.55 gives this IPv4 error here: >>> >>> Job for dhcpd4.service failed because the control process exited with error code. >>> See "systemctl status dhcpd4.service" and "journalctl -xe" for details. >>> root@server64:/root # systemctl status dhcpd4.service >>> ● dhcpd4.service - IPv4 DHCP server >>> Loaded: loaded (/usr/lib/systemd/system/dhcpd4.service; enabled; vendor preset: disabled) >>> Active: failed (Result: exit-code) since Thu 2017-10-12 17:09:38 CEST; 8s ago >>> Process: 638 ExecStart=/usr/bin/dhcpd -4 -q -user dhcp -cf /etc/dhcpd.conf -pf /run/dhcpd4.pid (code=exited, status=1/FAILURE) >>> >>> Okt 12 17:09:38 server64 dhcpd[638]: If you think you have received this message due to a bug rather >>> Okt 12 17:09:38 server64 dhcpd[638]: than a configuration issue please read the section on submitting >>> Okt 12 17:09:38 server64 dhcpd[638]: bugs on either our web page at www.isc.org or in the README file >>> Okt 12 17:09:38 server64 dhcpd[638]: before submitting a bug. These pages explain the proper >>> Okt 12 17:09:38 server64 dhcpd[638]: process and the information we find helpful for debugging. >>> Okt 12 17:09:38 server64 dhcpd[638]: >>> Okt 12 17:09:38 server64 dhcpd[638]: exiting. >>> Okt 12 17:09:38 server64 systemd[1]: dhcpd4.service: Control process exited, code=exited status=1 >>> Okt 12 17:09:38 server64 systemd[1]: dhcpd4.service: Failed with result 'exit-code'. >>> Okt 12 17:09:38 server64 systemd[1]: Failed to start IPv4 DHCP server. >>> >>> journalctl -xe >>> Okt 12 17:09:37 server64 systemd[1]: Starting IPv4 DHCP server... >>> -- Subject: Unit dhcpd4.service has begun start-up >>> -- Defined-By: systemd >>> -- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel >>> -- >>> -- Unit dhcpd4.service has begun starting up. >>> Okt 12 17:09:38 server64 dhcpd[638]: Internet Systems Consortium DHCP Server 4.3.6 >>> Okt 12 17:09:38 server64 dhcpd[638]: Copyright 2004-2017 Internet Systems Consortium. >>> Okt 12 17:09:38 server64 dhcpd[638]: All rights reserved. >>> Okt 12 17:09:38 server64 dhcpd[638]: For info, please visit https://www.isc.org/software/dhcp/ >>> Okt 12 17:09:38 server64 dhcpd[638]: Source compiled to use binary-leases >>> Okt 12 17:09:38 server64 dhcpd[638]: Wrote 0 deleted host decls to leases file. >>> Okt 12 17:09:38 server64 dhcpd[638]: Wrote 0 new dynamic host decls to leases file. >>> Okt 12 17:09:38 server64 dhcpd[638]: Wrote 16 leases to leases file. >>> Okt 12 17:09:38 server64 dhcpd[638]: Can't install packet filter program: Cannot allocate memory >>> Okt 12 17:09:38 server64 dhcpd[638]: >>> Okt 12 17:09:38 server64 dhcpd[638]: If you think you have received this message due to a bug rather >>> Okt 12 17:09:38 server64 dhcpd[638]: than a configuration issue please read the section on submitting >>> Okt 12 17:09:38 server64 dhcpd[638]: bugs on either our web page at www.isc.org or in the README file >>> Okt 12 17:09:38 server64 dhcpd[638]: before submitting a bug. These pages explain the proper >>> Okt 12 17:09:38 server64 dhcpd[638]: process and the information we find helpful for debugging. >>> Okt 12 17:09:38 server64 dhcpd[638]: >>> Okt 12 17:09:38 server64 dhcpd[638]: exiting. >>> Okt 12 17:09:38 server64 systemd[1]: dhcpd4.service: Control process exited, code=exited status=1 >>> Okt 12 17:09:38 server64 systemd[1]: dhcpd4.service: Failed with result 'exit-code'. >>> Okt 12 17:09:38 server64 systemd[1]: Failed to start IPv4 DHCP server. >>> -- Subject: Unit dhcpd4.service has failed >> pls try revert: >> commit 02f7e4101092b88e57c73171174976c8a72a3eba > > Correction. The commit is: > > 345c66695569db83eed100723e4df72cb54df7de > > I will try the revert and let you know. okay reverting the commit 345c66695569db83eed100723e4df72cb54df7de Author: Eric Dumazet Date: Mon Oct 2 12:20:51 2017 -0700 socket, bpf: fix possible use after free [ Upstream commit eefca20eb20c66b06cf5ed09b49b1a7caaa27b7b ] Starting from linux-4.4, 3WHS no longer takes the listener lock. Since this time, we might hit a use-after-free in sk_filter_charge(), if the filter we got in the memcpy() of the listener content just happened to be replaced by a thread changing listener BPF filter. To fix this, we need to make sure the filter refcount is not already zero before incrementing it again. Fixes: e994b2f0fb92 ("tcp: do not lock listener to process SYN packets") Signed-off-by: Eric Dumazet Acked-by: Alexei Starovoitov Acked-by: Daniel Borkmann Signed-off-by: David S. Miller Signed-off-by: Greg Kroah-Hartman fixes the issue. Looks like this is a fix for another problem. Anyway - I have 4.9.55 - minus 345c66695569db83eed100723e4df72cb54df7de running now with networking operational. thanks, -- Shuah