From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751119AbdE2K45 (ORCPT ); Mon, 29 May 2017 06:56:57 -0400 Received: from mx0b-001b2d01.pphosted.com ([148.163.158.5]:39513 "EHLO mx0a-001b2d01.pphosted.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1750986AbdE2K4y (ORCPT ); Mon, 29 May 2017 06:56:54 -0400 From: Michael Ellerman To: Anshuman Khandual , Anshuman Khandual , Vlastimil Babka , Christoph Hellwig , Andrew Morton Cc: linux-mm@kvack.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH] mm: Define KB, MB, GB, TB in core VM In-Reply-To: <7f85724c-6fc1-bb51-11e4-15fc2f89372b@linux.vnet.ibm.com> References: <20170522111742.29433-1-khandual@linux.vnet.ibm.com> <20170522141149.9ef84bb0713769f4af0383f0@linux-foundation.org> <20170523070227.GA27864@infradead.org> <09a6bafa-5743-425e-8def-bd9219cd756c@suse.cz> <161638da-3b2b-7912-2ae2-3b2936ca1537@linux.vnet.ibm.com> <7f85724c-6fc1-bb51-11e4-15fc2f89372b@linux.vnet.ibm.com> User-Agent: Notmuch/0.21 (https://notmuchmail.org) Date: Mon, 29 May 2017 20:55:43 +1000 MIME-Version: 1.0 Content-Type: text/plain X-TM-AS-MML: disable x-cbid: 17052910-0008-0000-0000-00000133B179 X-IBM-AV-DETECTION: SAVI=unused REMOTE=unused XFE=unused x-cbparentid: 17052910-0009-0000-0000-00000962BD59 Message-Id: <87d1as6ifk.fsf@concordia.ellerman.id.au> X-Proofpoint-Virus-Version: vendor=fsecure engine=2.50.10432:,, definitions=2017-05-29_07:,, signatures=0 X-Proofpoint-Spam-Details: rule=outbound_notspam policy=outbound score=0 spamscore=0 suspectscore=0 malwarescore=0 phishscore=0 adultscore=0 bulkscore=0 classifier=spam adjust=0 reason=mlx scancount=1 engine=8.0.1-1703280000 definitions=main-1705290203 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Anshuman Khandual writes: > > So the question is are we willing to do all these changes across > the tree to achieve common definitions of KB, MB, GB, TB in the > kernel ? Is it worth ? No I don't think it's worth the churn. But have you looked at using the "proper" names, ie. KiB, MiB, GiB? AFAICS the only clash is: drivers/mtd/ssfdc.c:#define KiB(x) ( (x) * 1024L ) drivers/mtd/ssfdc.c:#define MiB(x) ( KiB(x) * 1024L ) Which would be easy to convert. cheers