From: Bart Van Assche <bvanassche@acm.org>
To: Luis Chamberlain <mcgrof@kernel.org>, axboe@kernel.dk
Cc: ming.lei@redhat.com, hch@infradead.org, jack@suse.cz,
linux-block@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] block: fix userspace documentation reference for del_gendisk()
Date: Fri, 23 Apr 2021 11:56:41 -0700 [thread overview]
Message-ID: <87d487f9-c81e-43e4-d03b-0e8789a9401e@acm.org> (raw)
In-Reply-To: <20201117140658.12199-1-mcgrof@kernel.org>
On 11/17/20 6:06 AM, Luis Chamberlain wrote:
> Commit b5bd357cf8b ("block: add docs for gendisk / request_queue refcount
> helpers") has a typo where it references drivers for del_gendisk() when we
> instead meant userspace, as the reference is to the userspace experience.
> This fixes this.
>
> Signed-off-by: Luis Chamberlain <mcgrof@kernel.org>
> ---
> block/genhd.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/block/genhd.c b/block/genhd.c
> index 0a273211fec2..9511620f558a 100644
> --- a/block/genhd.c
> +++ b/block/genhd.c
> @@ -880,8 +880,8 @@ static void invalidate_partition(struct gendisk *disk, int partno)
> * with put_disk(), which should be called after del_gendisk(), if
> * __device_add_disk() was used.
> *
> - * Drivers exist which depend on the release of the gendisk to be synchronous,
> - * it should not be deferred.
> + * Userspace may exist which depends on the release of the gendisk to be
> + * synchronous, it should not be deferred.
Please change "may exist which depends" into "software may depend" to
make the comment easier to understand.
Thanks,
Bart.
prev parent reply other threads:[~2021-04-23 18:56 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-11-17 14:06 Luis Chamberlain
2021-04-23 18:38 ` Luis Chamberlain
2021-04-23 18:56 ` Bart Van Assche [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87d487f9-c81e-43e4-d03b-0e8789a9401e@acm.org \
--to=bvanassche@acm.org \
--cc=axboe@kernel.dk \
--cc=hch@infradead.org \
--cc=jack@suse.cz \
--cc=linux-block@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mcgrof@kernel.org \
--cc=ming.lei@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®