From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1750787AbdAWIMJ (ORCPT ); Mon, 23 Jan 2017 03:12:09 -0500 Received: from ozlabs.org ([103.22.144.67]:45917 "EHLO ozlabs.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750724AbdAWIMJ (ORCPT ); Mon, 23 Jan 2017 03:12:09 -0500 From: Michael Ellerman To: paulmck@linux.vnet.ibm.com, Ingo Molnar Cc: boqun.feng@linux.vnet.ibm.com, bobby.prani@gmail.com, peterz@infradead.org, fweisbec@gmail.com, dvhart@linux.intel.com, jiangshanlai@gmail.com, linux-kernel@vger.kernel.org, rostedt@goodmis.org, josh@joshtriplett.org, dhowells@redhat.com, edumazet@google.com, mathieu.desnoyers@efficios.com, oleg@redhat.com, dipankar@in.ibm.com, will.deacon@arm.com, akpm@linux-foundation.org, linuxppc-dev@lists.ozlabs.org, tglx@linutronix.de Subject: Re: [PATCH tip/core/rcu 2/3] srcu: Force full grace-period ordering In-Reply-To: <20170114214159.GA7098@linux.vnet.ibm.com> References: <20170114091941.GA22961@linux.vnet.ibm.com> <1484385601-23379-2-git-send-email-paulmck@linux.vnet.ibm.com> <20170114093550.GB14970@gmail.com> <20170114195417.GW5238@linux.vnet.ibm.com> <20170114214159.GA7098@linux.vnet.ibm.com> User-Agent: Notmuch/0.21 (https://notmuchmail.org) Date: Mon, 23 Jan 2017 19:12:03 +1100 Message-ID: <87efzub3fw.fsf@concordia.ellerman.id.au> MIME-Version: 1.0 Content-Type: text/plain Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org "Paul E. McKenney" writes: > On Sat, Jan 14, 2017 at 11:54:17AM -0800, Paul E. McKenney wrote: >> On Sat, Jan 14, 2017 at 10:35:50AM +0100, Ingo Molnar wrote: >> > * Paul E. McKenney wrote: > > [ . . . ] > >> > > + */ >> > > +#ifdef CONFIG_PPC >> > > +#define smp_mb__after_unlock_lock() smp_mb() /* Full ordering for lock. */ >> > > +#else /* #ifdef CONFIG_PPC */ >> > > +#define smp_mb__after_unlock_lock() do { } while (0) >> > > +#endif /* #else #ifdef CONFIG_PPC */ >> > >> > Yeah, so I realize that this was pre-existing code, but putting CONFIG_$ARCH >> > #ifdefs into generic headers is generally frowned upon. >> > >> > The canonical approach would be either to define a helper Kconfig variable that >> > can be set by PPC (but other architectures don't need to set it), or to expose a >> > suitable macro (function) for architectures to define in their barrier.h arch >> > header file. >> >> Very well, I will add a separate commit for this. 4.11 OK? > > Does the patch below seem reasonable? > > Thanx, Paul > > ------------------------------------------------------------------------ > > commit 271c0601237c41a279f975563e13837bace0df03 > Author: Paul E. McKenney > Date: Sat Jan 14 13:32:50 2017 -0800 > > rcu: Make arch select smp_mb__after_unlock_lock() strength > > The definition of smp_mb__after_unlock_lock() is currently smp_mb() > for CONFIG_PPC and a no-op otherwise. It would be better to instead > provide an architecture-selectable Kconfig option, and select the > strength of smp_mb__after_unlock_lock() based on that option. This > commit therefore creates CONFIG_ARCH_WEAK_RELACQ, has PPC select it, > and bases the definition of smp_mb__after_unlock_lock() on this new > CONFIG_ARCH_WEAK_RELACQ Kconfig option. > > Reported-by: Ingo Molnar > Signed-off-by: Paul E. McKenney > Cc: Peter Zijlstra > Cc: Will Deacon > Cc: Boqun Feng > Cc: Benjamin Herrenschmidt > Cc: Paul Mackerras > Cc: Michael Ellerman > Cc: Personally I'd call it ARCH_WEAK_RELEASE_ACQUIRE, which is longer but clearer I think. But it's not a big deal, so which ever you prefer. Acked-by: Michael Ellerman cheers