From: Namhyung Kim <namhyung@kernel.org>
To: byungchul.park@lge.com
Cc: rostedt@goodmis.org, mingo@redhat.com, jolsa@redhat.com,
vanilla@blackduck.lge.com, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] tracing, function_graph: fix micro seconds notation in comment
Date: Fri, 24 Oct 2014 09:20:11 +0900 [thread overview]
Message-ID: <87fveee2tg.fsf@sejong.aot.lge.com> (raw)
In-Reply-To: <1414052242-9828-2-git-send-email-byungchul.park@lge.com> (byungchul park's message of "Thu, 23 Oct 2014 17:17:21 +0900")
Hi Byungchul,
On Thu, 23 Oct 2014 17:17:21 +0900, byungchul park wrote:
> From: Byungchul Park <byungchul.park@lge.com>
>
> Usually, "msecs" notation means milli-seconds, and "usecs" notation
> means micro-seconds. Since the unit used in the code is
> micro-seconds, the notation should be replaced from msecs to usecs.
> This confusing notation prevents us from understanding the code
> correctly.
>
> Signed-off-by: Byungchul Park <byungchul.park@lge.com>
> ---
> kernel/trace/trace_functions_graph.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/kernel/trace/trace_functions_graph.c b/kernel/trace/trace_functions_graph.c
> index f0a0c98..c18a1e3 100644
> --- a/kernel/trace/trace_functions_graph.c
> +++ b/kernel/trace/trace_functions_graph.c
> @@ -822,10 +822,10 @@ print_graph_duration(unsigned long long duration, struct trace_seq *s,
>
> /* Signal a overhead of time execution to the output */
> if (flags & TRACE_GRAPH_PRINT_OVERHEAD) {
> - /* Duration exceeded 100 msecs */
> + /* Duration exceeded 100 usecs */
> if (duration > 100000ULL)
> ret = trace_seq_puts(s, "! ");
> - /* Duration exceeded 10 msecs */
> + /* Duration exceeded 10 usecs */
> else if (duration > 10000ULL)
I thought the duration was in usec, but it seems not, it's in nsec, hmm.
Then this exceeding 10/100 usec is not meaningful - what about increaing
numbers in the conditional so that it can match to the comment? That
will eliminate the need of the patch 2.
Also I think msecs_str in trace_print_graph_duration() should be renamed
to usecs_str.
Thanks,
Namhyung
> ret = trace_seq_puts(s, "+ ");
> }
next prev parent reply other threads:[~2014-10-24 0:20 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-10-23 8:17 [PATCH 0/2] tracing, function_graph: signaling very large function execution time byungchul.park
2014-10-23 8:17 ` [PATCH 1/2] tracing, function_graph: fix micro seconds notation in comment byungchul.park
2014-10-24 0:20 ` Namhyung Kim [this message]
2014-10-24 1:07 ` Byungchul Park
2014-10-31 16:51 ` Steven Rostedt
2014-10-23 8:17 ` [PATCH 2/2] tracing, function_graph: add additional marks to signal very large function execution time byungchul.park
2014-10-31 17:01 ` Steven Rostedt
2014-10-31 17:04 ` Steven Rostedt
2014-11-03 0:03 ` Byungchul Park
2014-11-03 0:50 ` Byungchul Park
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87fveee2tg.fsf@sejong.aot.lge.com \
--to=namhyung@kernel.org \
--cc=byungchul.park@lge.com \
--cc=jolsa@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=rostedt@goodmis.org \
--cc=vanilla@blackduck.lge.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome