From: OGAWA Hirofumi <hirofumi@mail.parknet.co.jp>
To: Stephen Smalley <sds@tycho.nsa.gov>
Cc: Eric Paris <eparis@redhat.com>, Amerigo Wang <amwang@redhat.com>,
linux-kernel@vger.kernel.org, esandeen@redhat.com,
eteo@redhat.com, linux-fsdevel@vger.kernel.org,
akpm@linux-foundation.org, viro@zeniv.linux.org.uk,
linux-security-module@vger.kernel.org
Subject: Re: [Patch v3] vfs: allow file truncations when both suid and write permissions set
Date: Mon, 10 Aug 2009 22:10:40 +0900 [thread overview]
Message-ID: <87my6724rz.fsf@devron.myhome.or.jp> (raw)
In-Reply-To: <1249909031.2422.37.camel@moss-pluto.epoch.ncsc.mil> (Stephen Smalley's message of "Mon, 10 Aug 2009 08:57:11 -0400")
Stephen Smalley <sds@tycho.nsa.gov> writes:
>> > SELinux shouldn't apply a permission check for the clearing of the suid
>> > bit on write or truncate. It should only apply a permission check for
>> > the actual truncate or write operation, and then the clearing of the
>> > suid bit should always be forced if that check passed.
>>
>> Ok. Yes. So, to do it efficiently without problem, I'm suggesting the
>> following or something (I don't know whether LSM should do this or not).
>>
>> selinux_inode_setattr(),
>>
>> ia_valid = iattr->ia_valid;
>> if (!(ia_valid & ATTR_FORCE) && (ia_valid & ATTR_FORCE_MASK)) {
>> err = dentry_has_perm(cred, NULL, dentry, FILE__SETATTR);
>> if (err)
>> return err;
>> ia_valid &= ~ATTR_FORCE_MASK;
>> }
>> if (ia_valid & ATTR_NOT_FORCE_MASK)
>> err = dentry_has_perm(cred, NULL, dentry, FILE__WRITE);
>> return err;
>>
>> I guess ATTR_FORCE_MASK would be (ATTR_MODE | ATTR_UID | ATTR_GID |
>> ATTR_ATIME_SET | ATTR_MTIME_SET) or something,
>> and ATTR_NOT_FORCE_MASK would be ATTR_SIZE or something.
>>
>> I'm not sure this is the right code what selinux want to do though, but,
>> I hope it is clear what I want to say. (I'm assuming FILE__WRITE is for
>> check of ATTR_SIZE)
>
> The logic is supposed to map certain attribute changes (mode, owner,
> group, explicit setting of atime or mtime to a specific value rather
> than the current time) to the SELinux setattr permission, while mapping
> other attribute changes that occur naturally on a write (size, setting
> of mtime to current time) to the SELinux write permission. That doesn't
> seem clear from using ATTR_FORCE_MASK vs ATTR_NOT_FORCE_MASK above - I'd
> use different naming conventions for clarity.
I see. Yes, the naming of this code doesn't matter at all. The code was
just intended to explain what I'm suggesting.
>> With this change, the caller can pass "(ATTR_SIZE | ATTR_MODE)" or
>> "(ATTR_SIZE | ATTR_MODE | ATTR_FORCE)" etc. for truncate().
>>
>> [btw, "(ATTR_SIZE | ATTR_MODE)" is what do_truncate() does currently].
>
> That was a change in do_truncate(), commit
> 7b82dc0e64e93f430182f36b46b79fcee87d3532.
>
> It makes sense, but no one ever updated selinux_inode_setattr() to match
> that change.
I see. Yes, exactly. And for the user of non file owner case, I'm
thinking we would like to pass ATTR_FORCE too.
Thanks.
--
OGAWA Hirofumi <hirofumi@mail.parknet.co.jp>
next prev parent reply other threads:[~2009-08-10 13:10 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-08-07 10:05 Amerigo Wang
2009-08-07 19:57 ` Eric Paris
2009-08-07 20:23 ` OGAWA Hirofumi
2009-08-07 20:38 ` Eric Paris
2009-08-07 20:53 ` OGAWA Hirofumi
2009-08-10 2:30 ` Amerigo Wang
2009-08-10 4:59 ` OGAWA Hirofumi
2009-08-10 11:49 ` Stephen Smalley
2009-08-10 12:43 ` OGAWA Hirofumi
2009-08-10 12:57 ` Stephen Smalley
2009-08-10 13:10 ` OGAWA Hirofumi [this message]
2009-08-12 9:03 ` Amerigo Wang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87my6724rz.fsf@devron.myhome.or.jp \
--to=hirofumi@mail.parknet.co.jp \
--cc=akpm@linux-foundation.org \
--cc=amwang@redhat.com \
--cc=eparis@redhat.com \
--cc=esandeen@redhat.com \
--cc=eteo@redhat.com \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-security-module@vger.kernel.org \
--cc=sds@tycho.nsa.gov \
--cc=viro@zeniv.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®