From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755828AbbLDJC2 (ORCPT ); Fri, 4 Dec 2015 04:02:28 -0500 Received: from mail-lf0-f46.google.com ([209.85.215.46]:33481 "EHLO mail-lf0-f46.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755670AbbLDJCX (ORCPT ); Fri, 4 Dec 2015 04:02:23 -0500 From: Rasmus Villemoes To: Andrew Morton Cc: Andy Shevchenko , Joe Perches , Kees Cook , Martin Kletzander , Andy Shevchenko , Maurizio Lombardi , Tejun Heo , linux-kernel@vger.kernel.org Subject: Re: [PATCH v3 04/14] lib/vsprintf.c: expand field_width to 24 bits Organization: D03 References: <1449175873-1780-1-git-send-email-linux@rasmusvillemoes.dk> <1449175873-1780-5-git-send-email-linux@rasmusvillemoes.dk> <1449176047.17296.4.camel@perches.com> <1449178138.15393.161.camel@linux.intel.com> <20151203153407.85761faeab07e7c2fed84e81@linux-foundation.org> X-Hashcash: 1:20:151204:tj@kernel.org::x87qwlpH1OZzuYS2:0000045Y X-Hashcash: 1:20:151204:akpm@linux-foundation.org::hMv4LQ5VrvMb4Phu:0000000000000000000000000000000000000N3S X-Hashcash: 1:20:151204:keescook@chromium.org::GaubyLJ6uprarQPc:00000000000000000000000000000000000000000j8Z X-Hashcash: 1:20:151204:andriy.shevchenko@linux.intel.com::07PsdowTv6OT6Mtk:00000000000000000000000000000+2r X-Hashcash: 1:20:151204:joe@perches.com::iRjRkag9qjmeqjq5:001e6v X-Hashcash: 1:20:151204:linux-kernel@vger.kernel.org::9ODYWEgxFxOHaS42:0000000000000000000000000000000001Poi X-Hashcash: 1:20:151204:mlombard@redhat.com::OzwEgkVLDUhRC5Rj:0000000000000000000000000000000000000000003Nxz X-Hashcash: 1:20:151204:andy.shevchenko@gmail.com::xsIXlDRq2IYEU/Es:0000000000000000000000000000000000003sgG X-Hashcash: 1:20:151204:mkletzan@redhat.com::ZxTOd8TQwkJTR1yI:0000000000000000000000000000000000000000004t8T Date: Fri, 04 Dec 2015 10:02:20 +0100 In-Reply-To: <20151203153407.85761faeab07e7c2fed84e81@linux-foundation.org> (Andrew Morton's message of "Thu, 3 Dec 2015 15:34:07 -0800") Message-ID: <87poym60yr.fsf@rasmusvillemoes.dk> User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux) MIME-Version: 1.0 Content-Type: text/plain Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Dec 04 2015, Andrew Morton wrote: > On Thu, 03 Dec 2015 23:28:58 +0200 Andy Shevchenko wrote: > >> I like most of the stuff here, though, Joe, can we avoid open-coded >> BUILD_BUG_ON()? > > Well we could just do > [snip] > > Which is better than open-coding it, IMO. I'd really prefer to have the assertion near the type definition (which is why I did it that way), but if this is what it takes to get this patch in, fine by me. Rasmus