From: Namhyung Kim <namhyung@kernel.org>
To: Ingo Molnar <mingo@kernel.org>
Cc: Pekka Enberg <penberg@kernel.org>,
Arnaldo Carvalho de Melo <acme@ghostprotocols.net>,
Peter Zijlstra <a.p.zijlstra@chello.nl>,
Paul Mackerras <paulus@samba.org>,
Namhyung Kim <namhyung.kim@lge.com>,
LKML <linux-kernel@vger.kernel.org>,
Frederic Weisbecker <fweisbec@gmail.com>,
Stephane Eranian <eranian@google.com>,
Jiri Olsa <jolsa@redhat.com>,
Rodrigo Campos <rodrigo@sdfg.com.ar>,
Arun Sharma <asharma@fb.com>
Subject: Re: [RFC/PATCHSET 00/14] perf report: Add support to accumulate hist periods (v2)
Date: Wed, 06 Nov 2013 16:56:08 +0900 [thread overview]
Message-ID: <87ppqex8tj.fsf@sejong.aot.lge.com> (raw)
In-Reply-To: <20131105115802.GA12045@gmail.com> (Ingo Molnar's message of "Tue, 5 Nov 2013 12:58:02 +0100")
Hi Ingo,
On Tue, 5 Nov 2013 12:58:02 +0100, Ingo Molnar wrote:
> * Namhyung Kim <namhyung@kernel.org> wrote:
>> But the 'cumulative' (btw, I feel a bit hard to type this word..) is
>> different in that it *generates* entries didn't get sampled originally.
>> And as it requires callchains, total field will not work if callchains
>> are missing.
>
> Well, 'total' should disappear if it's not available.
But what if it's the only sort key user gave?
>
> We already have some 'column elimination/optimization' logic - like the
> 'dso' will disappear already if it's a single dso everywhere, IIRC?
When user explicitly gives a single name as the column filter with -c,
-d and/or -S options.
But it seems to have a same issue that I said above:
$ perf report -s comm -c perf --stdio
(...)
# Overhead
# ........
#
100.00%
And TUI even shows a noise in the output.
>
>> But as Frederic noted, it might affect the performance of perf report,
>> so it might be better to delay this behavior to make default after users
>> feel comfortable with an option?
>
> I think with call-chain speedups it should be fast enough, right?
Yeah, it should speedup things significantly.
>
> We can argue about the default separately - if it's all done correctly
> then it should be really easy to change the default layout of 'perf
> report'.
>
I just think that the perf tools are going so fast. ;-)
>> For now, there're two kind of columns:
>>
>> - one for showing entry's overhead percentage: self, sys, user,
>> guest_sys and guest_user. So the 'total' should go into this
>> category. I named it hpp (hist_entry period percentage) functions and
>> yes, I know it's an awfully bad name. :) Please see perf_hpp__format.
>>
>> There're controlled by a couple of options: --show-total-period,
>> --show-nr-samples and --showcpuutilization (I hate this!). And event
>> group also can affect its output.
>>
>> - one for grouping entries: cpu, pid, comm, dso, symbol, srcline and
>> parent. We call it "sort keys" but confusingly it doesn't affect
>> output sorting for now.
>
> Well, it's still a sort key in a sense, a string lexicographical ordering
> in essence, right?
Right. But it only affects on groupping entries when added and
collapsed not the output ordering.
>
>> > If there's demand then we could decouple sort keys from the display
>> > order, by slightly augmenting the field format:
>> >
>> > -F total,self:2,process:0,dso:1,name
>> >
>> > This would sort by 'process' field as the primary key, 'dso' the secondary
>> > key and 'self' as the tertiary key.
>> >
>> > And we could also keep the -s/--sort option:
>> >
>> > -s process,dso,self
>> >
>> > So the above -F line would be equivalent to:
>> >
>> > -F total,self,process,dso,name -s process,dso,self
>> >
>> > What do you think?
>>
>> I like the second one. It can sustain the old way but can support the
>> new way easily.
>>
>> But for compatibility we need to use 'self' sort key internally iff
>> neither the -F option nor the config option was given by user. And it
>> might warn (or notice) users to add 'self' column in the sort key for
>> future use.
>
> Mind explaining what the problem here is? I don't think I get it.
Well, normal users still use it as they used to - like
'perf report -s comm,dso' without -F option and the config.
In that case, what would the output look like? According to the above
proposal it'd look like below.
# Command Shared object
# ....... .............
aaa aaa
aaa libc.so
bbb bbb
bbb libc.so
But the user might want see this:
# Overhead (self) Command Shared object
# ............... ....... .............
30.00% bbb bbb
25.00% aaa aaa
25.00% aaa libc.so
20.00% bbb libc.so
If she really wants to see it sorted by comm and dso, the command line
should be 'perf report -F self,comm,dso -s comm,dso'
(or just 'perf report -F self -s comm,dso' could do the same).
# Overhead (self) Command Shared object
# ............... ....... .............
25.00% aaa aaa
25.00% aaa libc.so
30.00% bbb bbb
20.00% bbb libc.so
Thanks,
Namhyung
next prev parent reply other threads:[~2013-11-06 7:56 UTC|newest]
Thread overview: 64+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-10-31 6:56 Namhyung Kim
2013-10-31 6:56 ` [PATCH 01/14] perf tools: Consolidate __hists__add_*entry() Namhyung Kim
2013-11-01 11:56 ` Jiri Olsa
2013-11-06 5:43 ` [tip:perf/core] perf hists: " tip-bot for Namhyung Kim
2013-10-31 6:56 ` [PATCH 02/14] perf tools: Introduce struct add_entry_iter Namhyung Kim
2013-11-01 12:07 ` Jiri Olsa
2013-11-05 7:09 ` Namhyung Kim
2013-11-01 12:09 ` Jiri Olsa
2013-11-05 7:16 ` Namhyung Kim
2013-10-31 6:56 ` [PATCH 03/14] perf hists: Convert hist entry functions to use struct he_stat Namhyung Kim
2013-11-04 23:45 ` Arnaldo Carvalho de Melo
2013-11-05 7:17 ` Namhyung Kim
2013-10-31 6:56 ` [PATCH 04/14] perf hists: Add support for accumulated stat of hist entry Namhyung Kim
2013-10-31 6:56 ` [PATCH 05/14] perf hists: Check if accumulated when adding a " Namhyung Kim
2013-10-31 6:56 ` [PATCH 06/14] perf hists: Accumulate hist entry stat based on the callchain Namhyung Kim
2013-10-31 6:56 ` [PATCH 07/14] perf tools: Update cpumode for each cumulative entry Namhyung Kim
2013-11-01 12:55 ` Jiri Olsa
2013-11-05 7:41 ` Namhyung Kim
2013-10-31 6:56 ` [PATCH 08/14] perf report: Cache cumulative callchains Namhyung Kim
2013-10-31 11:13 ` Rodrigo Campos
2013-11-01 7:07 ` Namhyung Kim
2013-11-01 14:24 ` Rodrigo Campos
2013-11-01 15:16 ` Rodrigo Campos
2013-11-01 12:29 ` Jiri Olsa
2013-11-01 12:57 ` Jiri Olsa
2013-10-31 6:56 ` [PATCH 09/14] perf hists: Sort hist entries by accumulated period Namhyung Kim
2013-10-31 6:56 ` [PATCH 10/14] perf ui/hist: Add support to accumulated hist stat Namhyung Kim
2013-10-31 6:56 ` [PATCH 11/14] perf ui/browser: " Namhyung Kim
2013-10-31 6:56 ` [PATCH 12/14] perf ui/gtk: " Namhyung Kim
2013-10-31 6:56 ` [PATCH 13/14] perf tools: Apply percent-limit to cumulative percentage Namhyung Kim
2013-10-31 6:56 ` [PATCH 14/14] perf report: Add -g cumulative option Namhyung Kim
2013-11-01 13:17 ` Jiri Olsa
2013-11-05 7:44 ` Namhyung Kim
2013-10-31 8:09 ` [RFC/PATCHSET 00/14] perf report: Add support to accumulate hist periods (v2) Ingo Molnar
2013-11-01 6:48 ` Namhyung Kim
2013-11-01 7:55 ` Ingo Molnar
2013-11-01 9:18 ` Pekka Enberg
2013-11-01 9:22 ` Namhyung Kim
2013-11-01 9:27 ` Ingo Molnar
2013-11-05 7:31 ` Namhyung Kim
2013-11-05 7:46 ` Ingo Molnar
2013-11-05 9:05 ` Namhyung Kim
2013-11-05 11:58 ` Ingo Molnar
2013-11-06 7:56 ` Namhyung Kim [this message]
2013-11-06 8:30 ` Ingo Molnar
2013-11-06 9:17 ` Namhyung Kim
2013-11-06 11:47 ` Ingo Molnar
2013-11-06 12:14 ` Frederic Weisbecker
2013-11-11 12:13 ` Ingo Molnar
2013-11-11 13:08 ` Frederic Weisbecker
2013-11-11 13:56 ` Ingo Molnar
2013-11-11 15:45 ` Frederic Weisbecker
2013-11-06 15:33 ` David Ahern
2013-11-11 12:19 ` Ingo Molnar
2013-11-11 14:44 ` David Ahern
2013-11-12 12:08 ` Pekka Enberg
2013-11-06 16:09 ` Peter Zijlstra
2013-11-11 12:17 ` Ingo Molnar
2013-11-06 12:10 ` Frederic Weisbecker
2013-11-11 12:12 ` Ingo Molnar
2013-11-11 13:01 ` Frederic Weisbecker
2013-11-04 13:27 ` Frederic Weisbecker
2013-11-04 13:23 ` Frederic Weisbecker
2013-11-04 13:34 ` Frederic Weisbecker
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87ppqex8tj.fsf@sejong.aot.lge.com \
--to=namhyung@kernel.org \
--cc=a.p.zijlstra@chello.nl \
--cc=acme@ghostprotocols.net \
--cc=asharma@fb.com \
--cc=eranian@google.com \
--cc=fweisbec@gmail.com \
--cc=jolsa@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=namhyung.kim@lge.com \
--cc=paulus@samba.org \
--cc=penberg@kernel.org \
--cc=rodrigo@sdfg.com.ar \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox