From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1030920AbcDMKcv (ORCPT ); Wed, 13 Apr 2016 06:32:51 -0400 Received: from mga09.intel.com ([134.134.136.24]:27420 "EHLO mga09.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S965432AbcDMKcs (ORCPT ); Wed, 13 Apr 2016 06:32:48 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.24,479,1455004800"; d="scan'208";a="84290206" From: Alexander Shishkin To: Ingo Molnar Cc: Peter Zijlstra , Gleb Natapov , Paolo Bonzini , x86@kernel.org, kvm@vger.kernel.org, Ingo Molnar , linux-kernel@vger.kernel.org, tglx@linutronix.de, hpa@zytor.com, Arnaldo Carvalho de Melo , Borislav Petkov Subject: Re: [PATCH] perf/x86/intel/pt: Don't die on VMXON In-Reply-To: <20160413094951.GC6430@gmail.com> References: <1459527854-5899-1-git-send-email-alexander.shishkin@linux.intel.com> <20160406085227.GO3448@twins.programming.kicks-ass.net> <87vb3v56x2.fsf@ashishki-desk.ger.corp.intel.com> <20160406115215.GK2906@worktop> <871t6izv9z.fsf@ashishki-desk.ger.corp.intel.com> <20160413094951.GC6430@gmail.com> User-Agent: Notmuch/0.21 (http://notmuchmail.org) Emacs/24.5.1 (x86_64-pc-linux-gnu) Date: Wed, 13 Apr 2016 13:32:41 +0300 Message-ID: <87r3e9x0hi.fsf@ashishki-desk.ger.corp.intel.com> MIME-Version: 1.0 Content-Type: text/plain Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Ingo Molnar writes: >> @@ -3144,6 +3146,8 @@ static void vmclear_local_loaded_vmcss(void) >> static void kvm_cpu_vmxoff(void) >> { >> asm volatile (__ex(ASM_VMX_VMXOFF) : : : "cc"); >> + >> + intel_pt_vmx(0); >> } > > Yeah so the name intel_pt_vmx() is pretty information-free because it has no verb, > only nouns - please name new functions descriptively to after what they do! I do agree that it can use a better name (and this is a second attempt already). > Something like intel_pt_set_vmx_state() or so? Hmm how about intel_pt_handle_vmx()? Ideally, akin to the VMXON/VMXOFF insns, this could be two functions (intel_pt_handle_vmx{on,off}()) if the global namespace can take it. Regards, -- Alex