From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751629AbbG3Twh (ORCPT ); Thu, 30 Jul 2015 15:52:37 -0400 Received: from mail-lb0-f175.google.com ([209.85.217.175]:36032 "EHLO mail-lb0-f175.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750734AbbG3Twg (ORCPT ); Thu, 30 Jul 2015 15:52:36 -0400 From: Rasmus Villemoes To: Kees Cook Cc: linux-kernel@vger.kernel.org, Andrew Morton , Andy Shevchenko , Mathias Krause , James Bottomley Subject: Re: [PATCH] lib/string_helpers: clarify esc arg in string_escape_mem Organization: D03 References: <20150723231448.GA19989@www.outflux.net> X-Hashcash: 1:20:150730:andriy.shevchenko@linux.intel.com::NA6jC3ckVpIC6JgI:00000000000000000000000000000avV X-Hashcash: 1:20:150730:keescook@chromium.org::RwR8/cm7fQCLENxF:00000000000000000000000000000000000000001NiD X-Hashcash: 1:20:150730:akpm@linux-foundation.org::UwPxxI+QEVH8HrCH:0000000000000000000000000000000000001KTF X-Hashcash: 1:20:150730:jbottomley@odin.com::WyyVn6HuzeQrewqk:0000000000000000000000000000000000000000003Bkj X-Hashcash: 1:20:150730:minipli@googlemail.com::Cl4UbzWKECAujWEr:0000000000000000000000000000000000000003VcN X-Hashcash: 1:20:150730:linux-kernel@vger.kernel.org::urdY8q4w9KOMfaAe:0000000000000000000000000000000005nx7 Date: Thu, 30 Jul 2015 21:52:31 +0200 In-Reply-To: <20150723231448.GA19989@www.outflux.net> (Kees Cook's message of "Thu, 23 Jul 2015 16:14:48 -0700") Message-ID: <87r3npbeyo.fsf@rasmusvillemoes.dk> User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3 (gnu/linux) MIME-Version: 1.0 Content-Type: text/plain Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Jul 24 2015, Kees Cook wrote: > The esc argument is used to reduce which characters will be escaped. > For example, using " " with ESCAPE_SPACE will not produce any escaped > spaces. > Yeah, I've been confused by this more than once - the old description and the parameter name suggest that the esc string contains additional characters to escape, not the other way around. Could we also rename the parameter 'only' or something like that? In any case, Acked-by: Rasmus Villemoes