From: Kevin Hilman <khilman@linaro.org>
To: Viresh Kumar <viresh.kumar@linaro.org>
Cc: rjw@sisk.pl, daniel.lezcano@linaro.org,
linaro-kernel@lists.linaro.org, patches@linaro.org,
linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH V2 00/16] CPUIdle: Minor cleanups for 3.13
Date: Thu, 03 Oct 2013 14:07:31 -0700 [thread overview]
Message-ID: <87vc1et65o.fsf@linaro.org> (raw)
In-Reply-To: <cover.1380815504.git.viresh.kumar@linaro.org> (Viresh Kumar's message of "Thu, 3 Oct 2013 21:26:39 +0530")
Viresh Kumar <viresh.kumar@linaro.org> writes:
> Hi Rafael,
>
> These are V2 of my CPUIdle cleanup series.. Few patches are dropped as they
> required further modifications. Last one is rewritten as suggested by Daniel.
> Most of them are already Acked by Daniel.
I gave these a spin on OMAP3 and both full-chip retention and off-mode
during idle are still working fine.
Tested-by: Kevin Hilman <khilman@linaro.org>
Kevin
> Viresh Kumar (16):
> cpuidle: fix indentation of cpumask
> cpuidle: Fix comments in cpuidle core
> cpuidle: make __cpuidle_get_cpu_driver() inline
> cpuidle: make __cpuidle_device_init() return void
> cpuidle: make __cpuidle_driver_init() return void
> cpuidle: rearrange code in __cpuidle_driver_init()
> cpuidle: rearrange __cpuidle_register_device() to keep minimal exit
> points
> cpuidle: merge two if() statements for checking error cases
> cpuidle: reduce code duplication inside cpuidle_idle_call()
> cpuidle: replace multiline statements with single line in
> cpuidle_idle_call()
> cpuidle: call cpuidle_get_driver() from after taking
> cpuidle_driver_lock
> cpuidle: use drv instead of cpuidle_driver in show_current_driver()
> cpuidle: free all state kobjects from cpuidle_free_state_kobj()
> cpuidle: don't calculate time-diff if entered_state < 0
> cpuidle: don't call poll_idle_init() for every cpu
> cpuidle: remove cpuidle_unregister_governor()
>
> Documentation/cpuidle/governor.txt | 1 -
> drivers/cpuidle/coupled.c | 2 +-
> drivers/cpuidle/cpuidle.c | 95 ++++++++++----------------------------
> drivers/cpuidle/driver.c | 69 ++++++++++++++++++++-------
> drivers/cpuidle/governor.c | 43 -----------------
> drivers/cpuidle/sysfs.c | 30 ++++++------
> include/linux/cpuidle.h | 8 +---
> 7 files changed, 94 insertions(+), 154 deletions(-)
next prev parent reply other threads:[~2013-10-03 21:07 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-10-03 15:56 Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 01/16] cpuidle: fix indentation of cpumask Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 02/16] cpuidle: Fix comments in cpuidle core Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 03/16] cpuidle: make __cpuidle_get_cpu_driver() inline Viresh Kumar
2013-10-03 20:14 ` Paul Walmsley
2013-10-03 15:56 ` [PATCH V2 04/16] cpuidle: make __cpuidle_device_init() return void Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 05/16] cpuidle: make __cpuidle_driver_init() " Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 06/16] cpuidle: rearrange code in __cpuidle_driver_init() Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 07/16] cpuidle: rearrange __cpuidle_register_device() to keep minimal exit points Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 08/16] cpuidle: merge two if() statements for checking error cases Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 09/16] cpuidle: reduce code duplication inside cpuidle_idle_call() Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 10/16] cpuidle: replace multiline statements with single line in cpuidle_idle_call() Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 11/16] cpuidle: call cpuidle_get_driver() from after taking cpuidle_driver_lock Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 12/16] cpuidle: use drv instead of cpuidle_driver in show_current_driver() Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 13/16] cpuidle: free all state kobjects from cpuidle_free_state_kobj() Viresh Kumar
2013-11-20 8:03 ` Viresh Kumar
2013-11-20 8:03 ` Viresh Kumar
2013-11-21 1:05 ` Rafael J. Wysocki
2013-11-21 3:24 ` Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 14/16] cpuidle: don't calculate time-diff if entered_state < 0 Viresh Kumar
2013-11-20 8:04 ` Viresh Kumar
2013-11-21 1:06 ` Rafael J. Wysocki
2013-10-03 15:56 ` [PATCH V2 15/16] cpuidle: don't call poll_idle_init() for every cpu Viresh Kumar
2013-10-03 15:56 ` [PATCH V2 16/16] cpuidle: remove cpuidle_unregister_governor() Viresh Kumar
2013-10-03 21:07 ` Kevin Hilman [this message]
2013-10-04 5:23 ` [PATCH V2 00/16] CPUIdle: Minor cleanups for 3.13 Viresh Kumar
2013-10-23 5:41 ` Viresh Kumar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87vc1et65o.fsf@linaro.org \
--to=khilman@linaro.org \
--cc=daniel.lezcano@linaro.org \
--cc=linaro-kernel@lists.linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=patches@linaro.org \
--cc=rjw@sisk.pl \
--cc=viresh.kumar@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®