From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757489AbcAaVgK (ORCPT ); Sun, 31 Jan 2016 16:36:10 -0500 Received: from canardo.mork.no ([148.122.252.1]:57941 "EHLO canardo.mork.no" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751198AbcAaVgI convert rfc822-to-8bit (ORCPT ); Sun, 31 Jan 2016 16:36:08 -0500 From: =?utf-8?Q?Bj=C3=B8rn_Mork?= To: Mathieu OTHACEHE Cc: johan@kernel.org, gregkh@linuxfoundation.org, linux-kernel@vger.kernel.org, linux-usb@vger.kernel.org Subject: Re: [PATCH 11/14] USB: serial: mos7840: move constants to right Organization: m References: <1454175887-16158-1-git-send-email-m.othacehe@gmail.com> <1454175887-16158-12-git-send-email-m.othacehe@gmail.com> Date: Sun, 31 Jan 2016 22:33:54 +0100 In-Reply-To: <1454175887-16158-12-git-send-email-m.othacehe@gmail.com> (Mathieu OTHACEHE's message of "Sat, 30 Jan 2016 18:44:44 +0100") Message-ID: <87zivltovx.fsf@nemi.mork.no> User-Agent: Gnus/5.130013 (Ma Gnus v0.13) Emacs/24.5 (gnu/linux) MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 8BIT Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Mathieu OTHACEHE writes: > This patch fixes the following coccinelle warnings: > > drivers/usb/serial/mos7840.c:2042:4-10: Move constant to right. > drivers/usb/serial/mos7840.c:2062:16-22: Move constant to right. > > Signed-off-by: Mathieu OTHACEHE > --- > drivers/usb/serial/mos7840.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/usb/serial/mos7840.c b/drivers/usb/serial/mos7840.c > index 8ddc313..982a3fb 100644 > --- a/drivers/usb/serial/mos7840.c > +++ b/drivers/usb/serial/mos7840.c > @@ -2039,7 +2039,7 @@ static int mos7810_check(struct usb_serial *serial) > /* Send the 1-bit test pattern out to MCS7810 test pin */ > usb_control_msg(serial->dev, usb_sndctrlpipe(serial->dev, 0), > MCS_WRREQ, MCS_WR_RTYPE, > - (0x0300 | (((test_pattern >> i) & 0x0001) << 1)), > + ((((test_pattern >> i) & 0x0001) << 1) | 0x0300), > MODEM_CONTROL_REGISTER, NULL, 0, MOS_WDR_TIMEOUT); > > /* Read the test pattern back */ > @@ -2059,7 +2059,7 @@ static int mos7810_check(struct usb_serial *serial) > > /* Restore MCR setting */ > usb_control_msg(serial->dev, usb_sndctrlpipe(serial->dev, 0), MCS_WRREQ, > - MCS_WR_RTYPE, 0x0300 | mcr_data, MODEM_CONTROL_REGISTER, NULL, > + MCS_WR_RTYPE, mcr_data | 0x0300, MODEM_CONTROL_REGISTER, NULL, > 0, MOS_WDR_TIMEOUT); > > kfree(buf); I feel I'm missing something here, so I have to ask the stupid question: What could possibly be the benefit here? Is it faster? Safer? Easier to read? Bjørn