mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rjw@rjwysocki.net>
To: Jiang Liu <jiang.liu@linux.intel.com>
Cc: "Rafael J . Wysocki" <rafael.j.wysocki@intel.com>,
	Lv Zheng <lv.zheng@intel.com>, Len Brown <lenb@kernel.org>,
	Tony Luck <tony.luck@intel.com>,
	linux-acpi@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [RFC Patch v1 1/6] acpi_pad: simplify notify handler by using acpi_drv_ops->notify
Date: Tue, 18 Feb 2014 02:06:03 +0100	[thread overview]
Message-ID: <8893595.ITmXn6Kgg5@vostro.rjw.lan> (raw)
In-Reply-To: <1392613373-11003-1-git-send-email-jiang.liu@linux.intel.com>

On Monday, February 17, 2014 01:02:48 PM Jiang Liu wrote:
> Use callback acpi_drv_ops->notify to simplify acpi_pad driver's
> notification handling code.
> 
> Signed-off-by: Jiang Liu <jiang.liu@linux.intel.com>

There is a plan to move away from using struct acpi_driver objects and
this change will need to be reverted then.  I'm not sure if that's really
useful?

> ---
>  drivers/acpi/acpi_pad.c |   25 +++++--------------------
>  1 file changed, 5 insertions(+), 20 deletions(-)
> 
> diff --git a/drivers/acpi/acpi_pad.c b/drivers/acpi/acpi_pad.c
> index df96a0f..1e3ce76 100644
> --- a/drivers/acpi/acpi_pad.c
> +++ b/drivers/acpi/acpi_pad.c
> @@ -443,14 +443,11 @@ static void acpi_pad_handle_notify(acpi_handle handle)
>  	mutex_unlock(&isolated_cpus_lock);
>  }
>  
> -static void acpi_pad_notify(acpi_handle handle, u32 event,
> -	void *data)
> +static void acpi_pad_notify(struct acpi_device *device, u32 event)
>  {
> -	struct acpi_device *device = data;
> -
>  	switch (event) {
>  	case ACPI_PROCESSOR_AGGREGATOR_NOTIFY:
> -		acpi_pad_handle_notify(handle);
> +		acpi_pad_handle_notify(device->handle);
>  		acpi_bus_generate_netlink_event(device->pnp.device_class,
>  			dev_name(&device->dev), event, 0);
>  		break;
> @@ -462,22 +459,10 @@ static void acpi_pad_notify(acpi_handle handle, u32 event,
>  
>  static int acpi_pad_add(struct acpi_device *device)
>  {
> -	acpi_status status;
> -
>  	strcpy(acpi_device_name(device), ACPI_PROCESSOR_AGGREGATOR_DEVICE_NAME);
>  	strcpy(acpi_device_class(device), ACPI_PROCESSOR_AGGREGATOR_CLASS);
>  
> -	if (acpi_pad_add_sysfs(device))
> -		return -ENODEV;
> -
> -	status = acpi_install_notify_handler(device->handle,
> -		ACPI_DEVICE_NOTIFY, acpi_pad_notify, device);
> -	if (ACPI_FAILURE(status)) {
> -		acpi_pad_remove_sysfs(device);
> -		return -ENODEV;
> -	}
> -
> -	return 0;
> +	return acpi_pad_add_sysfs(device);
>  }
>  
>  static int acpi_pad_remove(struct acpi_device *device)
> @@ -486,9 +471,8 @@ static int acpi_pad_remove(struct acpi_device *device)
>  	acpi_pad_idle_cpus(0);
>  	mutex_unlock(&isolated_cpus_lock);
>  
> -	acpi_remove_notify_handler(device->handle,
> -		ACPI_DEVICE_NOTIFY, acpi_pad_notify);
>  	acpi_pad_remove_sysfs(device);
> +
>  	return 0;
>  }
>  
> @@ -505,6 +489,7 @@ static struct acpi_driver acpi_pad_driver = {
>  	.ops = {
>  		.add = acpi_pad_add,
>  		.remove = acpi_pad_remove,
> +		.notify = acpi_pad_notify,
>  	},
>  };
>  
> 

-- 
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.

  parent reply	other threads:[~2014-02-18  0:51 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-02-17  5:01 [RFC Patch v1 0/6] Miscellaneous improvements for ACPI Jiang Liu
2014-02-17  5:02 ` [RFC Patch v1 1/6] acpi_pad: simplify notify handler by using acpi_drv_ops->notify Jiang Liu
2014-02-17  5:02   ` [RFC Patch v1 2/6] ACPI: rename acpi_evaluate_hotplug_ost to acpi_evaluate_ost for reuse Jiang Liu
2014-02-18  1:06     ` Rafael J. Wysocki
2014-02-19  5:46       ` Jiang Liu
2014-02-19 15:53         ` Rafael J. Wysocki
2014-02-17  5:02   ` [RFC Patch v1 3/6] acpi_pad: use acpi_evaluate_pad() to replace open-coded version Jiang Liu
2014-02-18  1:07     ` Rafael J. Wysocki
2014-02-19  5:57       ` Jiang Liu
2014-02-17  5:02   ` [RFC Patch v1 4/6] xen, " Jiang Liu
2014-02-17  5:02   ` [RFC Patch v1 5/6] acpi_processor: " Jiang Liu
2014-02-17  5:02   ` [RFC Patch v1 6/6] ACPI: use device name LNXSYBUS.xx for ACPI \_SB and \_TZ objects Jiang Liu
2014-02-18  1:06   ` Rafael J. Wysocki [this message]
2014-02-19  5:45     ` [RFC Patch v1 1/6] acpi_pad: simplify notify handler by using acpi_drv_ops->notify Jiang Liu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8893595.ITmXn6Kgg5@vostro.rjw.lan \
    --to=rjw@rjwysocki.net \
    --cc=jiang.liu@linux.intel.com \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lv.zheng@intel.com \
    --cc=rafael.j.wysocki@intel.com \
    --cc=tony.luck@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®