From: "H. Peter Anvin" <hpa@zytor.com>
To: David Desobry <david.desobry@formalgen.com>,
David Laight <david.laight.linux@gmail.com>
Cc: tglx@kernel.org, mingo@redhat.com, bp@alien8.de,
dave.hansen@linux.intel.com, x86@kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2] x86/lib: Optimize num_digits() and fix INT_MIN overflow
Date: Tue, 20 Jan 2026 15:49:01 -0800 [thread overview]
Message-ID: <8923623d-1a23-483d-add7-2fd03a3a2c3d@zytor.com> (raw)
In-Reply-To: <ee26a04e-7b08-4400-abda-7bf81a67d560@formalgen.com>
On 2026-01-20 15:32, David Desobry wrote:
>
> Good catch. I have replaced the switch statement with a linear if-chain in v3
> to ensure better code generation for both GCC and Clang.
>
I think a bigger deal is just to change it to unsigned.
Now, for really silly optimization:
int num_digits(unsigned int x)
{
int n = 0;
asm("cmp %2,%1; sbb $-2,%0" : "+r" (n) : "r" (x), "g" (10));
asm("cmp %2,%1; sbb $-1,%0" : "+r" (n) : "r" (x), "g" (100));
asm("cmp %2,%1; sbb $-1,%0" : "+r" (n) : "r" (x), "g" (1000));
asm("cmp %2,%1; sbb $-1,%0" : "+r" (n) : "r" (x), "g" (10000));
asm("cmp %2,%1; sbb $-1,%0" : "+r" (n) : "r" (x), "g" (100000));
asm("cmp %2,%1; sbb $-1,%0" : "+r" (n) : "r" (x), "g" (1000000));
asm("cmp %2,%1; sbb $-1,%0" : "+r" (n) : "r" (x), "g" (10000000));
asm("cmp %2,%1; sbb $-1,%0" : "+r" (n) : "r" (x), "g" (100000000));
asm("cmp %2,%1; sbb $-1,%0" : "+r" (n) : "r" (x), "g" (1000000000));
return n;
}
No branches at all!
-hpa
next prev parent reply other threads:[~2026-01-20 23:49 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-01-20 17:47 David Desobry
2026-01-20 18:03 ` H. Peter Anvin
2026-01-20 21:46 ` David Laight
2026-01-20 23:19 ` [PATCH v3] " David Desobry
2026-01-20 23:32 ` [PATCH v2] " David Desobry
2026-01-20 23:49 ` H. Peter Anvin [this message]
2026-01-21 0:04 ` David Desobry
2026-01-21 0:17 ` H. Peter Anvin
2026-01-21 9:39 ` [PATCH v4] " David Desobry
2026-01-21 11:36 ` David Laight
2026-01-21 15:46 ` H. Peter Anvin
2026-01-21 9:54 ` [PATCH v2] " David Laight
2026-01-21 10:32 ` [PATCH v5] x86/lib: Rename num_digits() to num_digits_u32() and optimize David Desobry
2026-01-21 10:40 ` [PATCH v2] x86/lib: Optimize num_digits() and fix INT_MIN overflow David Desobry
2026-01-21 11:51 ` Maciej W. Rozycki
2026-01-23 7:06 ` H. Peter Anvin
2026-01-23 10:55 ` Maciej W. Rozycki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=8923623d-1a23-483d-add7-2fd03a3a2c3d@zytor.com \
--to=hpa@zytor.com \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=david.desobry@formalgen.com \
--cc=david.laight.linux@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=tglx@kernel.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®