From: Daniel Almeida <daniel.almeida@collabora.com>
To: Michal Wilczynski <m.wilczynski@samsung.com>
Cc: "Uwe Kleine-König" <ukleinek@kernel.org>,
"Miguel Ojeda" <ojeda@kernel.org>,
"Alex Gaynor" <alex.gaynor@gmail.com>,
"Boqun Feng" <boqun.feng@gmail.com>,
"Gary Guo" <gary@garyguo.net>,
"Björn Roy Baron" <bjorn3_gh@protonmail.com>,
"Andreas Hindborg" <a.hindborg@kernel.org>,
"Alice Ryhl" <aliceryhl@google.com>,
"Trevor Gross" <tmgross@umich.edu>,
"Danilo Krummrich" <dakr@kernel.org>,
"Drew Fustini" <drew@pdp7.com>, "Guo Ren" <guoren@kernel.org>,
"Fu Wei" <wefu@redhat.com>, "Rob Herring" <robh@kernel.org>,
"Krzysztof Kozlowski" <krzk+dt@kernel.org>,
"Conor Dooley" <conor+dt@kernel.org>,
"Paul Walmsley" <paul.walmsley@sifive.com>,
"Palmer Dabbelt" <palmer@dabbelt.com>,
"Albert Ou" <aou@eecs.berkeley.edu>,
"Alexandre Ghiti" <alex@ghiti.fr>,
"Marek Szyprowski" <m.szyprowski@samsung.com>,
"Benno Lossin" <lossin@kernel.org>,
"Michael Turquette" <mturquette@baylibre.com>,
"Drew Fustini" <fustini@kernel.org>,
linux-kernel@vger.kernel.org, linux-pwm@vger.kernel.org,
rust-for-linux@vger.kernel.org, linux-riscv@lists.infradead.org,
devicetree@vger.kernel.org
Subject: Re: [PATCH v12 3/3] rust: pwm: Add complete abstraction layer
Date: Wed, 6 Aug 2025 09:49:21 -0300 [thread overview]
Message-ID: <8C20C615-DBF2-4DF9-9AB3-E78C4B1E7493@collabora.com> (raw)
In-Reply-To: <8ad10cc3-6e7d-4a8b-b6f6-9568403ee2b3@samsung.com>
Hi Michal,
> On 4 Aug 2025, at 19:29, Michal Wilczynski <m.wilczynski@samsung.com> wrote:
>
>
> On 7/25/25 17:56, Daniel Almeida wrote:
>>> +
>>> + /// Gets the label for this PWM device, if any.
>>> + pub fn label(&self) -> Option<&CStr> {
>>> + // SAFETY: self.as_raw() provides a valid pointer.
>>> + let label_ptr = unsafe { (*self.as_raw()).label };
>>> + if label_ptr.is_null() {
>>> + None
>>> + } else {
>>> + // SAFETY: label_ptr is non-null and points to a C string
>>> + // managed by the kernel, valid for the lifetime of the PWM device.
>>> + Some(unsafe { CStr::from_char_ptr(label_ptr) })
>>> + }
>>> + }
>>
>> nit: this can be written more concisely, but I personally don’t mind.
>
> Do you have something specific in mind ? I think the alternative way of
> expressing this would use NonNull, but somehow this feels less readable
> for me.
Yes, an early return, i.e.:
if label_ptr.is_null() {
return None
}
It saves you one level of indentation by removing the else branch.
>
>
>>> +
>>> +/// Trait defining the operations for a PWM driver.
>>> +pub trait PwmOps: 'static + Sized {
>>> + /// The driver-specific hardware representation of a waveform.
>>> + ///
>>> + /// This type must be [`Copy`], [`Default`], and fit within `PWM_WFHWSIZE`.
>>> + type WfHw: Copy + Default;
>>
>> Can’t you use a build_assert!() here? i.e.:
>>
>> #[doc(hidden)]
>> const _CHECK_SZ: () = {
>> build_assert!(core::mem::size_of::<Self::WfHw>() <= bindings::PWM_WFHWSIZE as usize);
>> };
>
> This doesn't work i.e the driver using oversized WfHw compiles
> correctly, but putting the assert inside the serialize did work, please
> see below.
Can you show how it looks like with the build_assert included? Just as a sanity check.
>
>
>>
>>> + Err(ENOTSUPP)
>>> + }
>>> +
>>> + /// Convert a hardware-specific representation back to a generic waveform.
>>> + /// This is typically a pure calculation and does not perform I/O.
>>> + fn round_waveform_fromhw(
>>> + _chip: &Chip<Self>,
>>> + _pwm: &Device,
>>> + _wfhw: &Self::WfHw,
>>> + _wf: &mut Waveform,
>>> + ) -> Result<c_int> {
>>> + Err(ENOTSUPP)
>>> + }
>>
>> Please include at least a description of what this returns.
>
> Instead I think it should just return Result, reviewed the code and it's
> fine.
>
Ack.
>>
>>> +/// Bridges Rust `PwmOps` to the C `pwm_ops` vtable.
>>> +struct Adapter<T: PwmOps> {
>>> + _p: PhantomData<T>,
>>> +}
>>> +
>>> +impl<T: PwmOps> Adapter<T> {
>>> + const VTABLE: PwmOpsVTable = create_pwm_ops::<T>();
>>> +
>>> + /// # Safety
>>> + ///
>>> + /// `wfhw_ptr` must be valid for writes of `size_of::<T::WfHw>()` bytes.
>>> + unsafe fn serialize_wfhw(wfhw: &T::WfHw, wfhw_ptr: *mut c_void) -> Result {
>>> + let size = core::mem::size_of::<T::WfHw>();
>>> + if size > bindings::PWM_WFHWSIZE as usize {
>>> + return Err(EINVAL);
>>> + }
>>
>> See my previous comment on using build_assert if possible.
>
> So I did try this and it does work, however it results in a cryptic
> linker error:
> ld.lld: error: undefined symbol: rust_build_error
>>>> referenced by pwm_th1520.2c2c3938312114c-cgu.0
>>>> drivers/pwm/pwm_th1520.o:(<kernel::pwm::Adapter<pwm_th1520::Th1520PwmDriverData>>::read_waveform_callback) in archive vmlinux.a
>>>> referenced by pwm_th1520.2c2c3938312114c-cgu.0
>>>> drivers/pwm/pwm_th1520.o:(<kernel::pwm::Adapter<pwm_th1520::Th1520PwmDriverData>>::round_waveform_tohw_callback) in archive vmlinux.a
> make[2]: *** [scripts/Makefile.vmlinux:91: vmlinux] Error 1
>
> I assume this could be fixed at some point to better explain what
> failed? I think putting the assert in serialize functions is fine and
> the proposed _CHECK_SZ isn't really required.
>
> I would love to do some debugging and find out why that is myself if
> time allows :-)
There is nothing wrong here. A canonical Rust-for-Linux experience is stumbling
upon the error generated by build_assert and being rightly confused. People ask
about this every few months :)
This just means that the build_assert triggered and the build failed as a
result. IOW, it means that your build_assert is working properly to catch
errors.
— Daniel
next prev parent reply other threads:[~2025-08-06 12:50 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <CGME20250717090829eucas1p2b87fb2b5115e17e740321344a116b206@eucas1p2.samsung.com>
2025-07-17 9:08 ` [PATCH v12 0/3] Rust Abstractions for PWM subsystem with TH1520 PWM driver Michal Wilczynski
[not found] ` <CGME20250717090830eucas1p191fbd4e0baa40468884307a1b6277be3@eucas1p1.samsung.com>
2025-07-17 9:08 ` [PATCH v12 1/3] pwm: Export `pwmchip_release` for external use Michal Wilczynski
[not found] ` <CGME20250717090831eucas1p282ac3df2e2f1fc2a46e12c440abfbba1@eucas1p2.samsung.com>
2025-07-17 9:08 ` [PATCH v12 2/3] rust: pwm: Add Kconfig and basic data structures Michal Wilczynski
2025-07-25 15:08 ` Daniel Almeida
2025-08-02 21:19 ` Michal Wilczynski
[not found] ` <CGME20250717090833eucas1p16c916450b59a77d81bd013527755cb21@eucas1p1.samsung.com>
2025-07-17 9:08 ` [PATCH v12 3/3] rust: pwm: Add complete abstraction layer Michal Wilczynski
2025-07-25 15:56 ` Daniel Almeida
2025-08-04 22:29 ` Michal Wilczynski
2025-08-04 23:09 ` Miguel Ojeda
2025-08-06 12:49 ` Daniel Almeida [this message]
2025-08-12 9:27 ` Michal Wilczynski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=8C20C615-DBF2-4DF9-9AB3-E78C4B1E7493@collabora.com \
--to=daniel.almeida@collabora.com \
--cc=a.hindborg@kernel.org \
--cc=alex.gaynor@gmail.com \
--cc=alex@ghiti.fr \
--cc=aliceryhl@google.com \
--cc=aou@eecs.berkeley.edu \
--cc=bjorn3_gh@protonmail.com \
--cc=boqun.feng@gmail.com \
--cc=conor+dt@kernel.org \
--cc=dakr@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=drew@pdp7.com \
--cc=fustini@kernel.org \
--cc=gary@garyguo.net \
--cc=guoren@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pwm@vger.kernel.org \
--cc=linux-riscv@lists.infradead.org \
--cc=lossin@kernel.org \
--cc=m.szyprowski@samsung.com \
--cc=m.wilczynski@samsung.com \
--cc=mturquette@baylibre.com \
--cc=ojeda@kernel.org \
--cc=palmer@dabbelt.com \
--cc=paul.walmsley@sifive.com \
--cc=robh@kernel.org \
--cc=rust-for-linux@vger.kernel.org \
--cc=tmgross@umich.edu \
--cc=ukleinek@kernel.org \
--cc=wefu@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®