mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Neil Armstrong <neil.armstrong@linaro.org>
To: Bjorn Andersson <andersson@kernel.org>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Rob Herring <robh@kernel.org>,
	Krzysztof Kozlowski <krzk+dt@kernel.org>,
	Conor Dooley <conor+dt@kernel.org>,
	Geert Uytterhoeven <geert+renesas@glider.be>,
	Magnus Damm <magnus.damm@gmail.com>,
	Bartosz Golaszewski <brgl@kernel.org>,
	Manivannan Sadhasivam <mani@kernel.org>,
	Bjorn Helgaas <bhelgaas@google.com>,
	Konrad Dybcio <konradybcio@kernel.org>,
	linux-usb@vger.kernel.org, devicetree@vger.kernel.org,
	linux-kernel@vger.kernel.org, linux-renesas-soc@vger.kernel.org,
	linux-pci@vger.kernel.org, linux-arm-msm@vger.kernel.org
Subject: Re: [PATCH v3 1/9] dt-bindings: usb: document the Renesas UPD720201/UPD720202 USB 3.0 xHCI Host Controller
Date: Fri, 13 Feb 2026 09:25:53 +0100	[thread overview]
Message-ID: <8da06d06-db9f-446b-b1de-c5727d354db1@linaro.org> (raw)
In-Reply-To: <7kkwkjnucx3cpvegilske2qd4u24vvjkykrljosi2uyknte4bz@3xvh57q5lpcv>

On 2/12/26 16:17, Bjorn Andersson wrote:
> On Fri, Feb 06, 2026 at 03:50:29PM +0100, Neil Armstrong wrote:
>> Document the Renesas UPD720201/UPD720202 USB 3.0 xHCI Host Controller,
>> which connects over PCIe and requires specific power supplies to
>> start up.
>>
>> Signed-off-by: Neil Armstrong <neil.armstrong@linaro.org>
>> ---
>>   .../bindings/usb/renesas,upd720201-pci.yaml        | 61 ++++++++++++++++++++++
>>   1 file changed, 61 insertions(+)
>>
>> diff --git a/Documentation/devicetree/bindings/usb/renesas,upd720201-pci.yaml b/Documentation/devicetree/bindings/usb/renesas,upd720201-pci.yaml
>> new file mode 100644
>> index 000000000000..34acee62cdd2
>> --- /dev/null
>> +++ b/Documentation/devicetree/bindings/usb/renesas,upd720201-pci.yaml
>> @@ -0,0 +1,61 @@
>> +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause)
>> +%YAML 1.2
>> +---
>> +$id: http://devicetree.org/schemas/usb/renesas,upd720201-pci.yaml#
>> +$schema: http://devicetree.org/meta-schemas/core.yaml#
>> +
>> +title: UPD720201/UPD720202 USB 3.0 xHCI Host Controller (PCIe)
>> +
>> +maintainers:
>> +  - Neil Armstrong <neil.armstrong@linaro.org>
>> +
>> +description:
>> +  UPD720201 USB 3.0 xHCI Host Controller via PCIe x1 Gen2 interface.
>> +  The UPD720202 supports up to two downstream ports, while UPD720201
>> +  supports up to four downstream USB 3.0 rev1.0 ports.
>> +
>> +properties:
>> +  compatible:
>> +    const: pci1912,0014
>> +
>> +  reg:
>> +    maxItems: 1
>> +
>> +  avdd33-supply:
>> +    description: +3.3 V power supply for analog circuit
>> +
>> +  vdd10-supply:
>> +    description: +1.05 V power supply
>> +
>> +  vdd33-supply:
>> +    description: +3.3 V power supply
>> +
>> +required:
>> +  - compatible
>> +  - reg
>> +  - avdd33-supply
>> +  - vdd10-supply
>> +  - vdd33-supply
>> +
>> +allOf:
>> +  - $ref: usb-xhci.yaml
>> +
>> +additionalProperties: false
> 
> I'm trying to hang a onboard_hub off this controller and #address-cells,
> #size-cells, and hub@ comes back as invalid children.
> 
> I think this should be unevaluatedProperties instead.

Ack will update

Thanks,
Neil

> 
> Regards,
> Bjorn
> 
>> +
>> +examples:
>> +  - |
>> +    pcie@0 {
>> +        reg = <0x0 0x1000>;
>> +        ranges = <0x02000000 0x0 0x100000 0x10000000 0x0 0x0>;
>> +        #address-cells = <3>;
>> +        #size-cells = <2>;
>> +        device_type = "pci";
>> +
>> +        usb-controller@0 {
>> +            compatible = "pci1912,0014";
>> +            reg = <0x0 0x0 0x0 0x0 0x0>;
>> +            avdd33-supply = <&avdd33_reg>;
>> +            vdd10-supply = <&vdd10_reg>;
>> +            vdd33-supply = <&vdd33_reg>;
>> +        };
>> +    };
>>
>> -- 
>> 2.34.1
>>


  reply	other threads:[~2026-02-13  8:25 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-02-06 14:50 [PATCH v3 0/9] arm64: dts: qcom: Add support for the Ayaneo Pocket S2 Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 1/9] dt-bindings: usb: document the Renesas UPD720201/UPD720202 USB 3.0 xHCI Host Controller Neil Armstrong
2026-02-10  2:37   ` Rob Herring (Arm)
2026-02-12 15:17   ` Bjorn Andersson
2026-02-13  8:25     ` Neil Armstrong [this message]
2026-02-06 14:50 ` [PATCH v3 2/9] pci: pwrctrl: slot: fix dev_err_probe() usage Neil Armstrong
2026-02-06 15:13   ` Bartosz Golaszewski
2026-02-06 14:50 ` [PATCH v3 3/9] pci: pwrctrl: rename pci-pwrctrl-slot as generic Neil Armstrong
2026-02-09 11:31   ` Manivannan Sadhasivam
2026-02-09 11:33   ` Manivannan Sadhasivam
2026-02-09 13:57     ` Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 4/9] pci: pwrctrl: generic: support for the UPD720201/UPD720202 USB 3.0 xHCI Host Controller Neil Armstrong
2026-02-09 11:30   ` Manivannan Sadhasivam
2026-02-09 14:00     ` Neil Armstrong
2026-02-09 14:49       ` Manivannan Sadhasivam
2026-02-09 14:59         ` Neil Armstrong
2026-02-10  8:00           ` Manivannan Sadhasivam
2026-02-10  9:01             ` Neil Armstrong
2026-02-10 11:03               ` Manivannan Sadhasivam
2026-02-10 12:25                 ` Dmitry Baryshkov
2026-02-06 14:50 ` [PATCH v3 5/9] arm64: defconfig: enable pci-pwrctrl-generic as module Neil Armstrong
2026-02-09 11:32   ` Manivannan Sadhasivam
2026-02-06 14:50 ` [PATCH v3 6/9] dt-binding: vendor-prefixes: document the Ayaneo brand Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 7/9] dt-bindings: arm: qcom: document the Ayaneo Pocket S2 Neil Armstrong
2026-02-06 23:16   ` Rob Herring (Arm)
2026-02-06 14:50 ` [PATCH v3 8/9] arm64: dts: qcom: sm8650: Add sound DAI prefix for DP Neil Armstrong
2026-02-06 14:50 ` [PATCH v3 9/9] arm64: dts: qcom: add basic devicetree for Ayaneo Pocket S2 gaming console Neil Armstrong
2026-02-06 21:35 ` [PATCH v3 0/9] arm64: dts: qcom: Add support for the Ayaneo Pocket S2 Bjorn Helgaas
2026-02-09  9:15   ` Neil Armstrong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8da06d06-db9f-446b-b1de-c5727d354db1@linaro.org \
    --to=neil.armstrong@linaro.org \
    --cc=andersson@kernel.org \
    --cc=bhelgaas@google.com \
    --cc=brgl@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=geert+renesas@glider.be \
    --cc=gregkh@linuxfoundation.org \
    --cc=konradybcio@kernel.org \
    --cc=krzk+dt@kernel.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=linux-renesas-soc@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=magnus.damm@gmail.com \
    --cc=mani@kernel.org \
    --cc=robh@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®