From: David Laight <David.Laight@ACULAB.COM>
To: 'Petko Manolov' <petko.manolov@konsulko.com>
Cc: "Paul E . McKenney" <paulmck@kernel.org>,
LKML <linux-kernel@vger.kernel.org>
Subject: RE: [RFC] WRITE_ONCE_INC() and friends
Date: Sun, 19 Apr 2020 21:37:10 +0000 [thread overview]
Message-ID: <8e5a0283ed76465aac19a2b97a27ff15@AcuMS.aculab.com> (raw)
In-Reply-To: <20200419182957.GA36919@carbon>
From: Petko Manolov
> Sent: 19 April 2020 19:30
>
> On 20-04-19 18:02:50, David Laight wrote:
> > From: Petko Manolov
> > > Sent: 19 April 2020 10:45
> > > Recently I started reading up on KCSAN and at some point I ran into stuff like:
> > >
> > > WRITE_ONCE(ssp->srcu_lock_nesting[idx], ssp->srcu_lock_nesting[idx] + 1);
> > > WRITE_ONCE(p->mm->numa_scan_seq, READ_ONCE(p->mm->numa_scan_seq) + 1);
> >
> > If all the accesses use READ/WRITE_ONCE() why not just mark the structure
> > field 'volatile'?
>
> This is a bit heavy. I guess you've read this one:
>
> https://lwn.net/Articles/233479/
I remember reading something similar before.
I also remember a very old gcc (2.95?) that did a readback
after every volatile write on sparc (to flush the store buffer).
That broke everything.
I suspect there is a lot more code that is attempting to be lockless
these days.
Ring buffers (one writer and one reader) are a typical example where
you don't need locks but do need to use a consistent value.
Now you may also need ordering between accesses - which I think needs
more than volatile.
> And no, i am not sure all accesses are through READ/WRITE_ONCE(). If, for
> example, all others are from withing spin_lock/unlock pairs then we _may_ not
> need READ/WRITE_ONCE().
The cost of volatile accesses is probably minimal unless the
code is written assuming the compiler will only access things once.
> I merely proposed the _INC() variant for better readability.
More like shorter code lines :-)
David
-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)
next prev parent reply other threads:[~2020-04-19 21:37 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-04-19 9:44 Petko Manolov
2020-04-19 18:02 ` David Laight
2020-04-19 18:29 ` Petko Manolov
2020-04-19 21:37 ` David Laight [this message]
2020-04-20 15:05 ` Paul E. McKenney
2020-04-20 16:32 ` Petko Manolov
2020-04-21 8:00 ` David Laight
2020-04-21 9:30 ` Petko Manolov
2020-04-20 22:57 ` Marco Elver
2020-04-20 23:12 ` Paul E. McKenney
2020-04-21 9:33 ` Marco Elver
2020-04-21 13:19 ` Paul E. McKenney
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=8e5a0283ed76465aac19a2b97a27ff15@AcuMS.aculab.com \
--to=david.laight@aculab.com \
--cc=linux-kernel@vger.kernel.org \
--cc=paulmck@kernel.org \
--cc=petko.manolov@konsulko.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®