From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754265AbYI0UH2 (ORCPT ); Sat, 27 Sep 2008 16:07:28 -0400 Received: (majordomo@vger.kernel.org) by vger.kernel.org id S1753297AbYI0UHR (ORCPT ); Sat, 27 Sep 2008 16:07:17 -0400 Received: from fg-out-1718.google.com ([72.14.220.153]:47191 "EHLO fg-out-1718.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753269AbYI0UHQ (ORCPT ); Sat, 27 Sep 2008 16:07:16 -0400 Message-ID: <8f3aa8d60809271307o1c306eccm5571670090218ab9@mail.gmail.com> Date: Sat, 27 Sep 2008 13:07:14 -0700 From: "Martin Bligh" To: "Steven Rostedt" Subject: Re: [PATCH v9] Unified trace buffer Cc: "Ingo Molnar" , LKML , "Thomas Gleixner" , "Peter Zijlstra" , "Andrew Morton" , prasad@linux.vnet.ibm.com, "Linus Torvalds" , "Mathieu Desnoyers" , "Frank Ch. Eigler" , "David Wilder" , hch@lst.de, "Martin Bligh" , "Christoph Hellwig" , "Masami Hiramatsu" , "Steven Rostedt" , "Arnaldo Carvalho de Melo" In-Reply-To: MIME-Version: 1.0 Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit Content-Disposition: inline References: <20080925185236.244343232@goodmis.org> <20080927183912.GA13685@elte.hu> <20080927194105.GF18619@elte.hu> Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org >> that's even worse i think :-/ And this isnt bikeshed-painting really, >> the RNGBF_ name hurts my eyes and RB_ is definitely confusing to read. >> (as the rbtree constants are in capitals as well and similarly named) >> >> RING_TYPE_PADDING >> >> or: >> >> RINGBUF_TYPE_PADDING >> >> yes, it's longer, but still, saner. > > I don't mind the extra typing, it is just a bit more difficult to keep in > the 80 character line limit. Would using tb_ (trace buffer) rather than rb_ help ?