mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dave Hansen <dave.hansen@intel.com>
To: Brent Spillner <spillner@acm.org>
Cc: bhelgaas@google.com, tglx@linutronix.de, mingo@redhat.com,
	bp@alien8.de, dave.hansen@linux.intel.com, x86@kernel.org,
	hpa@zytor.com, linux-pci@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH] arch:x86:pci:irq.c: Improve log message when IRQ cannot be identified
Date: Fri, 28 Jan 2022 13:36:53 -0800	[thread overview]
Message-ID: <8f820849-6940-4271-e678-1ae037cdfb64@intel.com> (raw)
In-Reply-To: <CAGwJgaNa2u8vmxsnaSdpSH+ZO0e2GCYObSwC+j03843gXQ_vwg@mail.gmail.com>

On 1/28/22 12:48, Brent Spillner wrote:
> It seems like the multiline string literal is your main pain point--- would
> 
> +#ifdef CONFIG_ACPI
> +                       if (acpi_noirq)
> +                               msg = "; consider removing acpi=noirq";
> +                       else
> +                               msg = "; recommend verifying UEFI/BIOS
> IRQ options";
> +#else
> +                       msg = "; recommend verifying UEFI/BIOS IRQ
> options or enabling ACPI";
> +#endif
> 
> be OK without going to IS_ENABLED()?  (Personally, I think the #ifdef
> style is more readable.)

I think that's _better_ than what was in the patch.  But, even with it,
I still think the #ifdef mess borders on unreadable.

But, if Bjorn likes it, then go for it. :)

  reply	other threads:[~2022-01-28 21:36 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-01-28 17:37 Brent Spillner
2022-01-28 18:00 ` Dave Hansen
2022-01-28 20:48   ` Brent Spillner
2022-01-28 21:36     ` Dave Hansen [this message]
2022-01-31 21:22       ` Bjorn Helgaas

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8f820849-6940-4271-e678-1ae037cdfb64@intel.com \
    --to=dave.hansen@intel.com \
    --cc=bhelgaas@google.com \
    --cc=bp@alien8.de \
    --cc=dave.hansen@linux.intel.com \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=spillner@acm.org \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®