From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1031356AbdAJTLw (ORCPT ); Tue, 10 Jan 2017 14:11:52 -0500 Received: from mail-wm0-f68.google.com ([74.125.82.68]:32859 "EHLO mail-wm0-f68.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756635AbdAJTKr (ORCPT ); Tue, 10 Jan 2017 14:10:47 -0500 Subject: Re: [PATCH v3 4/7] mtd: nand: raw: prefix conflicting names with nandc instead of nand To: Boris Brezillon , Richard Weinberger , linux-mtd@lists.infradead.org, Peter Pan References: <1479732328-18363-1-git-send-email-boris.brezillon@free-electrons.com> <1479732328-18363-5-git-send-email-boris.brezillon@free-electrons.com> Cc: David Woodhouse , Brian Norris , Cyrille Pitchen , linux-kernel@vger.kernel.org, Ezequiel Garcia , Kelvin Cheung From: Marek Vasut Message-ID: <8fb86bb7-425a-3897-2d1d-7277e94918ec@gmail.com> Date: Tue, 10 Jan 2017 20:08:23 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Icedove/45.4.0 MIME-Version: 1.0 In-Reply-To: <1479732328-18363-5-git-send-email-boris.brezillon@free-electrons.com> Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 11/21/2016 01:45 PM, Boris Brezillon wrote: > Some raw NAND function names conflict with names defined in nand.h. > Prefix all those functions with nandc (for nand chip) instead of nand so > we can include nand.h from rawnand.h > > Signed-off-by: Boris Brezillon Nit, nand and nandc is quite confusing, why not call it nand_chip in full? -- Best regards, Marek Vasut