From: <Tudor.Ambarus@microchip.com>
To: <boris.brezillon@collabora.com>, <marek.vasut@gmail.com>,
<vigneshr@ti.com>, <miquel.raynal@bootlin.com>, <richard@nod.at>,
<linux-mtd@lists.infradead.org>, <linux-kernel@vger.kernel.org>
Subject: Re: [RESEND PATCH v3 00/20] mtd: spi-nor: move manuf out of the core
Date: Wed, 28 Aug 2019 10:18:33 +0000 [thread overview]
Message-ID: <8fced5c4-4a22-8445-8838-ea61c416698c@microchip.com> (raw)
In-Reply-To: <20190826120821.16351-1-tudor.ambarus@microchip.com>
On 08/26/2019 03:08 PM, Tudor Ambarus - M18064 wrote:
> From: Tudor Ambarus <tudor.ambarus@microchip.com>
>
> v3:
> - Drop patches:
> "mtd: spi-nor: Move clear_sr_bp() to 'struct spi_nor_flash_parameter'"
> "mtd: spi-nor: Rework the disabling of block write protection"
> and replace them with the RFC patch:
> "mtd: spi-nor: Rework the disabling of block write protection"
> - rename spi_nor_legacy_init_params() to spi_nor_info_init_params()
> - rebase patches and send them all in a single patch set.
>
> v2:
> - addressed all the comments
> - all flash parameters and settings are now set in 'struct
> spi_nor_flash_parameter', for a clearer separation between the SPI NOR
> layer and the flash params.
>
> In order to test this, you'll have to merge v5.3-rc5 in spi-nor/next.
> This patch set depends on
> 'commit 834de5c1aa76 ("mtd: spi-nor: Fix the disabling of write protection at init")
>
> The scope of the "mtd: spi-nor: move manuf out of the core" batches,
> is to move all manufacturer specific code out of the spi-nor core.
>
> In the quest of removing the manufacturer specific code from the spi-nor
> core, we want to impose a timeline/priority on how the flash parameters
> are updated. As of now. the flash parameters initialization logic is as
> following:
>
> a/ default flash parameters init in spi_nor_init_params()
> b/ manufacturer specific flash parameters updates, split across entire
> spi-nor core code
> c/ flash parameters updates based on SFDP tables
> d/ post BFPT flash parameter updates
>
> With the "mtd: spi-nor: move manuf out of the core" batches, we want to
> impose the following sequence of calls:
>
> 1/ spi-nor core legacy flash parameters init:
> spi_nor_default_init_params()
>
> 2/ MFR-based manufacturer flash parameters init:
> nor->manufacturer->fixups->default_init()
>
> 3/ specific flash_info tweeks done when decisions can not be done just
> on MFR:
> nor->info->fixups->default_init()
>
> 4/ SFDP tables flash parameters init - SFDP knows better:
> spi_nor_sfdp_init_params()
>
> 5/ post SFDP tables flash parameters updates - in case manufacturers
> get the serial flash tables wrong or incomplete.
> nor->info->fixups->post_sfdp()
> The later can be extended to nor->manufacturer->fixups->post_sfdp()
> if needed.
>
> Setting of flash parameters will no longer be spread interleaved across
> the spi-nor core, there will be a clear separation on who and when will
> update the flash parameters.
>
> Tested on sst26vf064b with atmel-quadspi SPIMEM driver.
>
> Boris Brezillon (7):
> mtd: spi-nor: Add a default_init() fixup hook for gd25q256
> mtd: spi-nor: Create a ->set_4byte() method
> mtd: spi-nor: Rework the SPI NOR lock/unlock logic
> mtd: spi-nor: Add post_sfdp() hook to tweak flash config
> mtd: spi-nor: Add spansion_post_sfdp_fixups()
> mtd: spi-nor: Add a ->convert_addr() method
> mtd: spi-nor: Add the SPI_NOR_XSR_RDY flag
>
> Tudor Ambarus (13):
> mtd: spi-nor: Regroup flash parameter and settings
> mtd: spi-nor: Use nor->params
> mtd: spi-nor: Drop quad_enable() from 'struct spi-nor'
> mtd: spi-nor: Move erase_map to 'struct spi_nor_flash_parameter'
> mtd: spi-nor: Add default_init() hook to tweak flash parameters
> mtd: spi_nor: Move manufacturer quad_enable() in ->default_init()
> mtd: spi-nor: Split spi_nor_init_params()
> mtd: spi_nor: Add a ->setup() method
> mtd: spi-nor: Add s3an_post_sfdp_fixups()
> mtd: spi-nor: Bring flash params init together
> mtd: spi_nor: Introduce spi_nor_set_addr_width()
> mtd: spi-nor: Introduce spi_nor_get_flash_info()
> mtd: spi-nor: Rework the disabling of block write protection
>
> drivers/mtd/spi-nor/spi-nor.c | 1304 +++++++++++++++++++++++------------------
> include/linux/mtd/spi-nor.h | 298 +++++++---
> 2 files changed, 927 insertions(+), 675 deletions(-)
>
Addressed Boris's and Vingnesh's latest small updates.
All but last applied to https://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git,
spi-nor/next branch.
Thanks,
ta
prev parent reply other threads:[~2019-08-28 10:18 UTC|newest]
Thread overview: 50+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-08-26 12:08 Tudor.Ambarus
2019-08-26 12:08 ` [RESEND PATCH v3 01/20] mtd: spi-nor: Regroup flash parameter and settings Tudor.Ambarus
2019-08-27 4:21 ` Vignesh Raghavendra
2019-08-26 12:08 ` [RESEND PATCH v3 02/20] mtd: spi-nor: Use nor->params Tudor.Ambarus
2019-08-27 4:31 ` Vignesh Raghavendra
2019-08-26 12:08 ` [RESEND PATCH v3 03/20] mtd: spi-nor: Drop quad_enable() from 'struct spi-nor' Tudor.Ambarus
2019-08-27 4:47 ` Vignesh Raghavendra
2019-08-26 12:08 ` [RESEND PATCH v3 04/20] mtd: spi-nor: Move erase_map to 'struct spi_nor_flash_parameter' Tudor.Ambarus
2019-08-26 12:38 ` Boris Brezillon
2019-08-27 5:39 ` Vignesh Raghavendra
2019-08-26 12:08 ` [RESEND PATCH v3 05/20] mtd: spi-nor: Add default_init() hook to tweak flash parameters Tudor.Ambarus
2019-08-27 5:48 ` Vignesh Raghavendra
2019-08-26 12:08 ` [RESEND PATCH v3 06/20] mtd: spi-nor: Add a default_init() fixup hook for gd25q256 Tudor.Ambarus
2019-08-27 5:48 ` Vignesh Raghavendra
2019-08-26 12:08 ` [RESEND PATCH v3 07/20] mtd: spi_nor: Move manufacturer quad_enable() in ->default_init() Tudor.Ambarus
2019-08-27 5:54 ` Vignesh Raghavendra
2019-08-26 12:08 ` [RESEND PATCH v3 08/20] mtd: spi-nor: Split spi_nor_init_params() Tudor.Ambarus
2019-08-27 6:00 ` Vignesh Raghavendra
2019-08-27 7:01 ` Tudor.Ambarus
2019-08-26 12:08 ` [RESEND PATCH v3 09/20] mtd: spi-nor: Create a ->set_4byte() method Tudor.Ambarus
2019-08-27 6:07 ` Vignesh Raghavendra
2019-08-26 12:08 ` [RESEND PATCH v3 10/20] mtd: spi-nor: Rework the SPI NOR lock/unlock logic Tudor.Ambarus
2019-08-27 6:36 ` Vignesh Raghavendra
2019-08-27 6:58 ` Tudor.Ambarus
2019-08-26 12:08 ` [RESEND PATCH v3 11/20] mtd: spi-nor: Add post_sfdp() hook to tweak flash config Tudor.Ambarus
2019-08-27 7:08 ` Vignesh Raghavendra
2019-08-26 12:08 ` [RESEND PATCH v3 12/20] mtd: spi-nor: Add spansion_post_sfdp_fixups() Tudor.Ambarus
2019-08-27 7:10 ` Vignesh Raghavendra
2019-08-26 12:08 ` [RESEND PATCH v3 13/20] mtd: spi-nor: Add a ->convert_addr() method Tudor.Ambarus
2019-08-27 7:13 ` Vignesh Raghavendra
2019-08-26 12:08 ` [RESEND PATCH v3 14/20] mtd: spi_nor: Add a ->setup() method Tudor.Ambarus
2019-08-26 12:40 ` Boris Brezillon
2019-08-26 13:38 ` Schrempf Frieder
2019-08-26 14:02 ` Boris Brezillon
2019-08-26 14:37 ` Schrempf Frieder
2019-08-27 7:16 ` Vignesh Raghavendra
2019-08-26 12:09 ` [RESEND PATCH v3 15/20] mtd: spi-nor: Add s3an_post_sfdp_fixups() Tudor.Ambarus
2019-08-27 7:18 ` Vignesh Raghavendra
2019-08-26 12:09 ` [RESEND PATCH v3 16/20] mtd: spi-nor: Add the SPI_NOR_XSR_RDY flag Tudor.Ambarus
2019-08-27 7:48 ` Vignesh Raghavendra
2019-08-26 12:09 ` [RESEND PATCH v3 17/20] mtd: spi-nor: Bring flash params init together Tudor.Ambarus
2019-08-27 7:35 ` Vignesh Raghavendra
2019-08-26 12:09 ` [RESEND PATCH v3 18/20] mtd: spi_nor: Introduce spi_nor_set_addr_width() Tudor.Ambarus
2019-08-27 7:37 ` Vignesh Raghavendra
2019-08-26 12:09 ` [RESEND PATCH v3 19/20] mtd: spi-nor: Introduce spi_nor_get_flash_info() Tudor.Ambarus
2019-08-27 7:37 ` Vignesh Raghavendra
2019-08-26 12:09 ` [RESEND RFC PATCH v3 20/20] mtd: spi-nor: Rework the disabling of block write protection Tudor.Ambarus
2019-08-26 12:49 ` Boris Brezillon
2019-08-27 5:33 ` [RESEND PATCH v3 00/20] mtd: spi-nor: move manuf out of the core Vignesh Raghavendra
2019-08-28 10:18 ` Tudor.Ambarus [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=8fced5c4-4a22-8445-8838-ea61c416698c@microchip.com \
--to=tudor.ambarus@microchip.com \
--cc=boris.brezillon@collabora.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=marek.vasut@gmail.com \
--cc=miquel.raynal@bootlin.com \
--cc=richard@nod.at \
--cc=vigneshr@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome