mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Kefeng Wang <wangkefeng.wang@huawei.com>
To: Matthew Wilcox <willy@infradead.org>
Cc: Andrew Morton <akpm@linux-foundation.org>, <linux-mm@kvack.org>,
	<linux-kernel@vger.kernel.org>, <ying.huang@intel.com>,
	<david@redhat.com>, Zi Yan <ziy@nvidia.com>
Subject: Re: [PATCH -next 4/7] mm: convert xchg_page_access_time to xchg_folio_access_time()
Date: Wed, 11 Oct 2023 11:03:20 +0800	[thread overview]
Message-ID: <8fe8c652-b5c6-4e24-9847-7c3bb01279c0@huawei.com> (raw)
In-Reply-To: <ZSVDJPbt7Nz1xg7+@casper.infradead.org>



On 2023/10/10 20:27, Matthew Wilcox wrote:
> On Tue, Oct 10, 2023 at 02:45:41PM +0800, Kefeng Wang wrote:
>> Make xchg_page_access_time to take a folio, and rename it to
>> xchg_folio_access_time() since all callers with a folio.
> 
> You're doing this the hard way, which makes life hard for the reviewrs.
> 
> patch 1. Introduce folio->_last_cpupid
> patch 2: Add
> 
> static inline int folio_xchg_access_time(struct folio *folio, int time)
> {
> 	return xchg_page_access_time(&folio->page, time);
> }
> 
> patch 3-n: Convert callers
> Patch n+1: Remove xchg_page_access_time(), folding it into
> folio_xchg_access_time().

Ok, I will follow this way, thanks for your advise.
> 
> Similarly for page_cpupid_xchg_last / folio_cpupid_xchg_last().
> (why is this not called folio_xchg_last_cpupid?)

Fine with me, will update.

Thanks.

> 
> 

  reply	other threads:[~2023-10-11  3:03 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-10-10  6:45 [PATCH -next 0/7] mm: convert page cpupid functions to folios Kefeng Wang
2023-10-10  6:45 ` [PATCH -next 1/7] mm_types: add _last_cpupid into folio Kefeng Wang
2023-10-10  8:17   ` Huang, Ying
2023-10-10 11:10     ` Kefeng Wang
2023-10-10 12:33   ` Matthew Wilcox
2023-10-11  3:02     ` Kefeng Wang
2023-10-11  5:55       ` Huang, Ying
2023-10-11  8:05         ` Kefeng Wang
2023-10-10  6:45 ` [PATCH -next 2/7] mm: mprotect: use a folio in change_pte_range() Kefeng Wang
2023-10-10  6:45 ` [PATCH -next 3/7] mm: huge_memory: use a folio in change_huge_pmd() Kefeng Wang
2023-10-10  6:45 ` [PATCH -next 4/7] mm: convert xchg_page_access_time to xchg_folio_access_time() Kefeng Wang
2023-10-10 12:27   ` Matthew Wilcox
2023-10-11  3:03     ` Kefeng Wang [this message]
2023-10-10  6:45 ` [PATCH -next 5/7] mm: convert page_cpupid_last() to folio_cpupid_last() Kefeng Wang
2023-10-10  6:45 ` [PATCH -next 6/7] mm: make wp_page_reuse() and finish_mkwrite_fault() to take a folio Kefeng Wang
2023-10-10  6:45 ` [PATCH -next 7/7] mm: convert page_cpupid_xchg_last() to folio_cpupid_xchg_last() Kefeng Wang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8fe8c652-b5c6-4e24-9847-7c3bb01279c0@huawei.com \
    --to=wangkefeng.wang@huawei.com \
    --cc=akpm@linux-foundation.org \
    --cc=david@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=willy@infradead.org \
    --cc=ying.huang@intel.com \
    --cc=ziy@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®