From: Reinette Chatre <reinette.chatre@intel.com>
To: Haifeng Xu <haifeng.xu@shopee.com>
Cc: <fenghua.yu@intel.com>, <babu.moger@amd.com>,
<peternewman@google.com>, <x86@kernel.org>,
<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 1/2] x86/resctrl: Rename pseudo_lock_event.h to trace.h
Date: Fri, 23 Feb 2024 12:00:40 -0800 [thread overview]
Message-ID: <9055ee27-0860-4701-9ae9-801c25cf2aef@intel.com> (raw)
In-Reply-To: <20240221092101.90740-2-haifeng.xu@shopee.com>
Hi Haifeng,
On 2/21/2024 1:21 AM, Haifeng Xu wrote:
> Now only pseudo-lock part uses tracepoints to do event tracking, but
> other parts of resctrl may need new tracepoints. It is unnecessary to
> create separate header files and define CREATE_TRACE_POINTS in different
> c files which fragments the resctrl tracing.
>
> Therefore, the new tracepoints should be placed in the same header file,
> and the header file needs a more generic name.
Please do stick with imperative mood [1]. For example, something like:
"Give the resctrl tracepoint header file a generic name to support
its use for tracepoints that are not specific to pseudo-locking."
(Please feel free to improve.)
Reinette
[1] https://www.kernel.org/doc/html/latest/process/maintainer-tip.html#changelog
next prev parent reply other threads:[~2024-02-23 20:00 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-02-21 9:20 [PATCH v2 0/2] Track llc_occpuancy of RMIDs in limbo list Haifeng Xu
2024-02-21 9:21 ` [PATCH v2 1/2] x86/resctrl: Rename pseudo_lock_event.h to trace.h Haifeng Xu
2024-02-23 20:00 ` Reinette Chatre [this message]
2024-02-29 3:12 ` Haifeng Xu
2024-02-21 9:21 ` [PATCH v2 2/2] x86/resctrl: Add tracepoint for llc_occupancy tracking Haifeng Xu
2024-02-23 19:41 ` Reinette Chatre
2024-02-29 3:16 ` Haifeng Xu
2024-03-01 17:47 ` James Morse
2024-02-23 23:24 ` [PATCH v2 0/2] Track llc_occpuancy of RMIDs in limbo list Reinette Chatre
2024-02-29 3:13 ` Haifeng Xu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=9055ee27-0860-4701-9ae9-801c25cf2aef@intel.com \
--to=reinette.chatre@intel.com \
--cc=babu.moger@amd.com \
--cc=fenghua.yu@intel.com \
--cc=haifeng.xu@shopee.com \
--cc=linux-kernel@vger.kernel.org \
--cc=peternewman@google.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®