mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Vincent Mailhol <mailhol@kernel.org>
To: Alexei Starovoitov <alexei.starovoitov@gmail.com>
Cc: Vlastimil Babka <vbabka@suse.cz>,
	Shakeel Butt <shakeel.butt@linux.dev>,
	Sebastian Andrzej Siewior <bigeasy@linutronix.de>,
	Alexei Starovoitov <ast@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] locking/local_lock: fix shadowing in __local_lock_acquire()
Date: Thu, 25 Sep 2025 03:04:21 +0900	[thread overview]
Message-ID: <90cecd21-3ad2-4c21-a0d3-4b30a79d4eac@kernel.org> (raw)
In-Reply-To: <CAADnVQ+xGQGdR85R6EnX7Rrv+RqkrTfLjfdZOYJ4bPb9+Govyg@mail.gmail.com>

On 25/09/2025 at 02:07, Alexei Starovoitov wrote:
> On Wed, Sep 24, 2025 at 4:07 PM Vincent Mailhol <mailhol@kernel.org> wrote:
>>
>> On 24/09/2025 at 19:26, Vincent Mailhol wrote:
>>> On 24/09/2025 at 04:38, Alexei Starovoitov wrote:
>>>> On Tue, Sep 23, 2025 at 7:02 AM Vincent Mailhol <mailhol@kernel.org> wrote:
>>>>>
>>>>> The __local_lock_acquire() macro uses a local variable named 'l'. This
>>>>> being a common name, there is a risk of shadowing other variables.
>>>>>
>>>>> For example, it is currently shadowing the parameter 'l' of the:
>>>>>
>>>>>   class_##_name##_t class_##_name##_constructor(_type *l)
>>>>>
>>>>> function factory from linux/cleanup.h.
>>>>>
>>>>> Both sparse (with default options) and GCC (with W=2 option) warn
>>>>> about this shadowing.
>>>>>
>>>>> This is a bening warning, but because the issue appears in a header,
>>>>> it is spamming whoever is using it. So better to fix to remove some
>>>>> noise.
>>>>>
>>>>> Rename the variable from 'l' to '__lock' (with two underscore prefixes
>>>>> as suggested in the Linux kernel coding style [1]) in order to prevent
>>>>> the name collision.
>>>>
>>>> lockdep has __lock as a local variable.
>>>
>>> OK. I didn't saw this one.
>>>
>>> But there is a major difference between a shadowing in lockdep.c versus a
>>> shadowing in an header: the shadowing warning is local to lockdep.c and does not
>>> pollute the other users.
>>>
>>> My worry is only about the spam created by warnings in headers.
>>>
>>> Regardless, would renaming to __locked or __l instead of __lock help to address
>>> your concern?
>>
>> __locked was a bad suggestion. It could be named __local_lock (there is already
>> a __local_lock() function like macro, but function like macro does not conflict
>> with variable names).
>>
>> But now, my current preference goes to __ll (and also, to keep things
>> consistent, __tl for the trylock).
> 
> I think s/l/__l/ and s/tl/__tl/ is fine,
> but do it for all macros in that file,
> since renaming one is fishy. It doesn't fix what
> you're claiming to fix, hence the pushback.

OK. This was a fair pushback :)

I took your suggestion and renamed all instances in the file. I just sent the v2.

Thanks!


Yours sincerely,
Vincent Mailhol


      reply	other threads:[~2025-09-24 18:04 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-09-23 14:02 Vincent Mailhol
2025-09-23 19:38 ` Alexei Starovoitov
2025-09-24 10:26   ` Vincent Mailhol
2025-09-24 15:07     ` Vincent Mailhol
2025-09-24 17:07       ` Alexei Starovoitov
2025-09-24 18:04         ` Vincent Mailhol [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=90cecd21-3ad2-4c21-a0d3-4b30a79d4eac@kernel.org \
    --to=mailhol@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=alexei.starovoitov@gmail.com \
    --cc=ast@kernel.org \
    --cc=bigeasy@linutronix.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=shakeel.butt@linux.dev \
    --cc=vbabka@suse.cz \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®