From: Gabriele Monaco <gmonaco@redhat.com>
To: Nam Cao <namcao@linutronix.de>
Cc: Steven Rostedt <rostedt@goodmis.org>,
linux-trace-kernel@vger.kernel.org,
linux-kernel@vger.kernel.org, john.ogness@linutronix.de
Subject: Re: [PATCH v9 12/22] verification/rvgen: Restructure the classes to prepare for LTL inclusion
Date: Tue, 27 May 2025 11:32:35 +0200 [thread overview]
Message-ID: <91719ddbeca0e37617558687feb1191a69793dad.camel@redhat.com> (raw)
In-Reply-To: <20250527092734.BgoHvn6n@linutronix.de>
On Tue, 2025-05-27 at 11:27 +0200, Nam Cao wrote:
> On Tue, May 27, 2025 at 11:15:21AM +0200, Gabriele Monaco wrote:
> >
> >
> > On Mon, 2025-05-19 at 12:27 +0200, Nam Cao wrote:
> > > Both container generation and DA monitor generation is
> > > implemented in
> > > the
> > > class dot2k. That requires some ugly "if is_container ... else
> > > ...".
> > > If
> > > linear temporal logic support is added at the current state, the
> > > "if
> > > else"
> > > chain is longer and uglier.
> > >
> > > Furthermore, container generation is irrevelant to .dot files. It
> > > is
> > > therefore illogical to be implemented in class "dot2k".
> > >
> > > Clean it up, restructure the dot2k class into the following class
> > > hierarchy:
> > >
> > > (RVGenerator)
> > > /\
> > > / \
> > > / \
> > > / \
> > > / \
> > > (Container) (Monitor)
> > > /\
> > > / \
> > > / \
> > > / \
> > > (dot2k) [ltl2k] <- intended
> > >
> > > This allows a simple and clean integration of LTL.
> > >
> > > Reviewed-by: Gabriele Monaco <gmonaco@redhat.com>
> > > Signed-off-by: Nam Cao <namcao@linutronix.de>
> > > ---
> >
> > Steve,
> >
> > since this series is quite /meaty/ and it seems the later parts
> > require
> > a bit more discussion about tracepoints, could we start merging
> > until
> > here (1-12/22)?
> > I'd be tempted merging also 13 (actual LTL introduction) but
> > perhaps
> > keeping it together with the LTL monitors is cleaner.
>
> The x86 patches have been merged through tip tree. My plan is sending
> the
> next version without the merged x86 patches, and without the arm64
> patch -
> it can be sent separately. Then the whole series can be applied.
>
> I will do it after the merge window.
Alright, sounds good too.
Sorry for being pushy but I'm have a couple of other series kinda based
on this one and I'm getting a bit crazy maintaining all that ;)
Cheers,
Gabriele
>
> Best regards,
> Nam
next prev parent reply other threads:[~2025-05-27 9:32 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-19 10:27 [PATCH v9 00/22] RV: Linear temporal logic monitors for RT application Nam Cao
2025-05-19 10:27 ` [PATCH v9 01/22] rv: Add #undef TRACE_INCLUDE_FILE Nam Cao
2025-05-19 10:27 ` [PATCH v9 02/22] printk: Make vprintk_deferred() public Nam Cao
2025-05-19 10:27 ` [PATCH v9 03/22] panic: Add vpanic() Nam Cao
2025-05-19 10:27 ` [PATCH v9 04/22] rv: Let the reactors take care of buffers Nam Cao
2025-05-19 10:27 ` [PATCH v9 05/22] verification/dot2k: Make a separate dot2k_templates/Kconfig_container Nam Cao
2025-05-19 10:27 ` [PATCH v9 06/22] verification/dot2k: Remove __buff_to_string() Nam Cao
2025-05-19 10:27 ` [PATCH v9 07/22] verification/dot2k: Replace is_container() hack with subparsers Nam Cao
2025-05-19 10:27 ` [PATCH v9 08/22] rv: rename CONFIG_DA_MON_EVENTS to CONFIG_RV_MON_EVENTS Nam Cao
2025-05-19 10:27 ` [PATCH v9 09/22] verification/dot2k: Prepare the frontend for LTL inclusion Nam Cao
2025-05-19 10:27 ` [PATCH v9 10/22] Documentation/rv: Prepare monitor synthesis document " Nam Cao
2025-05-19 10:27 ` [PATCH v9 11/22] verification/rvgen: Restructure the templates files Nam Cao
2025-05-19 10:27 ` [PATCH v9 12/22] verification/rvgen: Restructure the classes to prepare for LTL inclusion Nam Cao
2025-05-27 9:15 ` Gabriele Monaco
2025-05-27 9:27 ` Nam Cao
2025-05-27 9:32 ` Gabriele Monaco [this message]
2025-05-27 14:39 ` Steven Rostedt
2025-05-19 10:27 ` [PATCH v9 13/22] rv: Add support for LTL monitors Nam Cao
2025-05-19 10:27 ` [PATCH v9 14/22] rv: Add rtapp container monitor Nam Cao
2025-05-19 10:27 ` [PATCH v9 15/22] x86/tracing, x86/mm: Remove redundant trace_pagefault_key Nam Cao
2025-05-19 10:27 ` [PATCH v9 16/22] x86/tracing, x86/mm: Move page fault tracepoints to generic Nam Cao
2025-05-19 10:27 ` [PATCH v9 17/22] arm64: mm: Add page fault trace points Nam Cao
2025-07-08 13:16 ` Will Deacon
2025-07-08 13:31 ` Nam Cao
2025-05-19 10:27 ` [PATCH v9 18/22] riscv: " Nam Cao
2025-05-19 10:27 ` [PATCH v9 19/22] rv: Add rtapp_pagefault monitor Nam Cao
2025-05-19 10:27 ` [PATCH v9 20/22] rv: Add rtapp_sleep monitor Nam Cao
2025-05-19 10:27 ` [PATCH v9 21/22] rv: Add documentation for rtapp monitor Nam Cao
2025-05-19 10:27 ` [PATCH v9 22/22] rv: Allow to configure the number of per-task monitor Nam Cao
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=91719ddbeca0e37617558687feb1191a69793dad.camel@redhat.com \
--to=gmonaco@redhat.com \
--cc=john.ogness@linutronix.de \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=namcao@linutronix.de \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®