From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id 01695C77B73 for ; Mon, 17 Apr 2023 01:51:15 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S229636AbjDQBvN (ORCPT ); Sun, 16 Apr 2023 21:51:13 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:38038 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S229461AbjDQBvM (ORCPT ); Sun, 16 Apr 2023 21:51:12 -0400 Received: from szxga02-in.huawei.com (szxga02-in.huawei.com [45.249.212.188]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 235B71995 for ; Sun, 16 Apr 2023 18:51:09 -0700 (PDT) Received: from dggpemm500001.china.huawei.com (unknown [172.30.72.53]) by szxga02-in.huawei.com (SkyGuard) with ESMTP id 4Q091m3GzbzL03l; Mon, 17 Apr 2023 09:48:28 +0800 (CST) Received: from [10.174.177.243] (10.174.177.243) by dggpemm500001.china.huawei.com (7.185.36.107) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256) id 15.1.2507.23; Mon, 17 Apr 2023 09:51:01 +0800 Message-ID: <91eded3b-0ad8-b092-bf17-7b34fd4ece65@huawei.com> Date: Mon, 17 Apr 2023 09:51:01 +0800 MIME-Version: 1.0 User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:102.0) Gecko/20100101 Thunderbird/102.5.1 Subject: Re: [PATCH] mm: rename reclaim_pages() to reclaim_folios() Content-Language: en-US To: Matthew Wilcox CC: Andrew Morton , , SeongJae Park , Hugh Dickins , References: <20230415092716.61970-1-wangkefeng.wang@huawei.com> From: Kefeng Wang In-Reply-To: Content-Type: text/plain; charset="UTF-8"; format=flowed Content-Transfer-Encoding: 7bit X-Originating-IP: [10.174.177.243] X-ClientProxiedBy: dggems704-chm.china.huawei.com (10.3.19.181) To dggpemm500001.china.huawei.com (7.185.36.107) X-CFilter-Loop: Reflected Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 2023/4/16 0:04, Matthew Wilcox wrote: > On Sat, Apr 15, 2023 at 05:27:16PM +0800, Kefeng Wang wrote: >> As commit a83f0551f496 ("mm/vmscan: convert reclaim_pages() to use >> a folio") changes the arg from page_list to folio_list, but not >> the defination, let's correct it and rename it to reclaim_folios too. > > I didn't bother. It's not inaccurate; we're reclaiming the pages > in the folios. OK, keep the name seems better, there is another similar issue in reclaim_clean_pages_from_list(), I will only unify the arg between definition and declaration.>