From: Felix Fietkau <nbd@nbd.name>
To: "Baligh GASMI" <gasmibal@gmail.com>,
"Toke Høiland-Jørgensen" <toke@redhat.com>
Cc: Johannes Berg <johannes@sipsolutions.net>,
"David S. Miller" <davem@davemloft.net>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
"open list:MAC80211" <linux-wireless@vger.kernel.org>,
"open list:NETWORKING [GENERAL]" <netdev@vger.kernel.org>,
open list <linux-kernel@vger.kernel.org>
Subject: Re: [RFC PATCH 1/1] mac80211: use AQL airtime for expected throughput.
Date: Wed, 25 May 2022 14:50:48 +0200 [thread overview]
Message-ID: <92ca6224-9232-2648-0123-7096aafa17fb@nbd.name> (raw)
In-Reply-To: <CALxDnQa8d8CGXz2Mxvsz5csLj3KuTDW=z65DSzHk5x1Vg+y-rw@mail.gmail.com>
On 25.05.22 14:14, Baligh GASMI wrote:
>> > Since the integration of AQL, packet TX airtime estimation is
>> > calculated and counted to be used for the dequeue limit.
>> >
>> > Use this estimated airtime to compute expected throughput for
>> > each station.
>> >
>> > It will be a generic mac80211 implementation. If the driver has
>> > get_expected_throughput implementation, it will be used instead.
>> >
>> > Useful for L2 routing protocols, like B.A.T.M.A.N.
>> >
>> > Signed-off-by: Baligh Gasmi <gasmibal@gmail.com>
>> > ---
>> > net/mac80211/driver-ops.h | 2 ++
>> > net/mac80211/sta_info.h | 2 ++
>> > net/mac80211/status.c | 22 ++++++++++++++++++++++
>> > net/mac80211/tx.c | 3 ++-
>> > 4 files changed, 28 insertions(+), 1 deletion(-)
>> >
>> > diff --git a/net/mac80211/driver-ops.h b/net/mac80211/driver-ops.h
>> > index 4e2fc1a08681..4331b79647fa 100644
>> > --- a/net/mac80211/driver-ops.h
>> > +++ b/net/mac80211/driver-ops.h
>> > @@ -1142,6 +1142,8 @@ static inline u32 drv_get_expected_throughput(struct ieee80211_local *local,
>> > trace_drv_get_expected_throughput(&sta->sta);
>> > if (local->ops->get_expected_throughput && sta->uploaded)
>> > ret = local->ops->get_expected_throughput(&local->hw, &sta->sta);
>> > + else
>> > + ret = ewma_avg_est_tp_read(&sta->status_stats.avg_est_tp);
>> > trace_drv_return_u32(local, ret);
>> >
>> > return ret;
>> > diff --git a/net/mac80211/sta_info.h b/net/mac80211/sta_info.h
>> > index 379fd367197f..fe60be4c671d 100644
>> > --- a/net/mac80211/sta_info.h
>> > +++ b/net/mac80211/sta_info.h
>> > @@ -123,6 +123,7 @@ enum ieee80211_sta_info_flags {
>> > #define HT_AGG_STATE_STOP_CB 7
>> > #define HT_AGG_STATE_SENT_ADDBA 8
>> >
>> > +DECLARE_EWMA(avg_est_tp, 8, 16)
>> > DECLARE_EWMA(avg_signal, 10, 8)
>> > enum ieee80211_agg_stop_reason {
>> > AGG_STOP_DECLINED,
>> > @@ -641,6 +642,7 @@ struct sta_info {
>> > s8 last_ack_signal;
>> > bool ack_signal_filled;
>> > struct ewma_avg_signal avg_ack_signal;
>> > + struct ewma_avg_est_tp avg_est_tp;
>> > } status_stats;
>> >
>> > /* Updated from TX path only, no locking requirements */
>> > diff --git a/net/mac80211/status.c b/net/mac80211/status.c
>> > index e81e8a5bb774..647ade3719f5 100644
>> > --- a/net/mac80211/status.c
>> > +++ b/net/mac80211/status.c
>> > @@ -1145,6 +1145,28 @@ void ieee80211_tx_status_ext(struct ieee80211_hw *hw,
>> > sta->status_stats.retry_failed++;
>> > sta->status_stats.retry_count += retry_count;
>> >
>> > + if (skb && tx_time_est) {
>>
>> Shouldn't this be conditioned on actually being used (i.e., existence of
>> get_expected_throughput op? Also maybe pull it out into its own function
>> to make it clear what it's doing...
>
> It's already the case I think, since the tx_time_est is not-zero only
> when actually an estimated time is set.
> A dedicated function seems good for me, for clarity, yes.
>
>>
>> > + /* max average packet size */
>> > + size_t pkt_size = skb->len > 1024 ? 1024 : skb->len;
>> > +
>> > + if (acked) {
>> > + /* ACK packet size */
>> > + pkt_size += 14;
>> > + /* SIFS x 2 */
>> > + tx_time_est += 2 * 2;
>> > + }
>> > +
>> > + /* Backoff average x retries */
>> > + tx_time_est += retry_count ? retry_count * 2 : 2;
>> > +
>> > + /* failed tx */
>> > + if (!acked && !noack_success)
>> > + pkt_size = 0;
>> > +
>> > + ewma_avg_est_tp_add(&sta->status_stats.avg_est_tp,
>> > + ((pkt_size * 8) * 1000) / tx_time_est);
>>
>> Could we avoid adding this division in the fast path?
>
> Maybe we can use the do_div() macro for optimization, I don't see how
> we can avoid it.
Here's one idea on how to make it less expensive and improve the average
of the throughput estimation at the same time:
In sta->status_stats add these fields:
u32 last_tp_update;
u32 pkt_size;
u32 tx_time_est;
And in this part of the code you do something like this:
u32 diff = ((u32)jiffies) - sta->status_stats.last_tp_update;
sta->status_stats.pkt_size += (pkt_size * 8) * 1000;
sta->status_stats.tx_time_est += tx_time_est;
if (diff > HZ / 10) {
ewma_avg_est_tp_add(&sta->status_stats.avg_est_tp,
sta->status_stats.pkt_size /
sta->status_stats.tx_time_est);
sta->status_stats.pkt_size = 0;
sta->status_stats.tx_time_est = 0;
}
This ensures that you will only get max. 1 update per 100ms interval.
Does that make sense?
- Felix
next prev parent reply other threads:[~2022-05-25 12:51 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-05-25 10:35 Baligh Gasmi
2022-05-25 11:02 ` Toke Høiland-Jørgensen
2022-05-25 12:14 ` Baligh GASMI
2022-05-25 12:50 ` Felix Fietkau [this message]
2022-05-25 13:37 ` Baligh GASMI
2022-05-25 17:54 ` Felix Fietkau
[not found] ` <CAA93jw4FnaCupm4uf4KOHXdLPntKKLq=5ncLLZOiiUvbmrSR-Q@mail.gmail.com>
2022-05-25 17:56 ` Felix Fietkau
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=92ca6224-9232-2648-0123-7096aafa17fb@nbd.name \
--to=nbd@nbd.name \
--cc=davem@davemloft.net \
--cc=gasmibal@gmail.com \
--cc=johannes@sipsolutions.net \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-wireless@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=toke@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®