From: Casey Schaufler <casey@schaufler-ca.com>
To: Paul Moore <paul@paul-moore.com>
Cc: linux-security-module@vger.kernel.org, jmorris@namei.org,
serge@hallyn.com, keescook@chromium.org,
john.johansen@canonical.com, penguin-kernel@i-love.sakura.ne.jp,
stephen.smalley.work@gmail.com, linux-kernel@vger.kernel.org,
selinux@vger.kernel.org, mic@digikod.net,
apparmor@lists.ubuntu.com, bpf@vger.kernel.org,
Casey Schaufler <casey@schaufler-ca.com>
Subject: Re: [PATCH v2 1/13] LSM: Add the lsmblob data structure.
Date: Wed, 4 Sep 2024 13:28:00 -0700 [thread overview]
Message-ID: <93952b9f-2e40-42fc-9a61-749b9c8ee306@schaufler-ca.com> (raw)
In-Reply-To: <CAHC9VhQ8QDAGc9BsxvPMi6=okwj+euLC+QXL1sgMsr8eHOcx2w@mail.gmail.com>
On 9/4/2024 1:00 PM, Paul Moore wrote:
> On Tue, Sep 3, 2024 at 8:53 PM Casey Schaufler <casey@schaufler-ca.com> wrote:
>> On 9/3/2024 5:18 PM, Paul Moore wrote:
>>> On Aug 29, 2024 Casey Schaufler <casey@schaufler-ca.com> wrote:
> ..
>
>>>> +/*
>>>> + * Data exported by the security modules
>>>> + */
>>>> +struct lsmblob {
>>>> + struct lsmblob_selinux selinux;
>>>> + struct lsmblob_smack smack;
>>>> + struct lsmblob_apparmor apparmor;
>>>> + struct lsmblob_bpf bpf;
>>>> + struct lsmblob_scaffold scaffold;
>>>> +};
>>> Warning, top shelf bikeshedding follows ...
>> Not unexpected. :)
>>
>>> I believe that historically when we've talked about the "LSM blob" we've
>>> usually been referring to the opaque buffers used to store LSM state that
>>> we attach to a number of kernel structs using the `void *security` field.
>>>
>>> At least that is what I think of when I read "struct lsmblob", and I'd
>>> like to get ahead of the potential confusion while we still can.
>>>
>>> Casey, I'm sure you're priority is simply getting this merged and you
>>> likely care very little about the name (as long as it isn't too horrible),
>> I would reject lsmlatefordinner out of hand.
> Fair enough :)
>
>>> but what about "lsm_ref"? Other ideas are most definitely welcome.
>> I'm not a fan of the underscore, and ref seems to imply memory management.
>> How about "struct lsmsecid", which is a nod to the past "u32 secid"?
>> Or, "struct lsmdata", "struct lsmid", "struct lsmattr".
>> I could live with "struct lsmref", I suppose, although it pulls me toward
>> "struct lsmreference", which is a bit long.
> For what it's worth, I do agree that "ref" is annoyingly similar to a
> reference counter, I don't love it here, but I'm having a hard time
> coming up with something appropriate.
>
> I also tend to like the underscore, at least in the struct name, as it
> matches well with the "lsm_ctx" struct we have as part of the UAPI.
> When we use the struct name in function names, feel free to drop the
> underscore, for example: "lsm_foo" -> "security_get_lsmfoo()".
>
> My first thought was for something like "lsmid" (ignoring the
> underscore debate), but we already have the LSM_ID_XXX defines which
> are something entirely different and I felt like we would be trading
> one source of confusion for another. There is a similar problem with
> the LSM_ATTR_XXX defines.
>
> We also already have a "lsm_ctx" struct which sort of rules out
> "lsmctx" for what are hopefully obvious reasons.
>
> I'd also like to avoid anything involving "secid" or "secctx" simply
> because the whole point of this struct is to move past the idea of a
> single integer or string representing all of the LSM properties for an
> entity.
>
> I can understand "lsm_data", but that is more ambiguous than I would like.
>
> What about "lsm_prop" or "lsm_cred"?
If we ever do the same sort of thing for the existing blobs we're
going to need to have lsm_cred for the cred blob, so I shan't use
it here. I can live with lsm_prop, which shouldn't confuse too many
developers. We can start saying "property" in place of secid, which
would be a good thing.
next prev parent reply other threads:[~2024-09-04 20:48 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20240830003411.16818-1-casey.ref@schaufler-ca.com>
2024-08-30 0:33 ` [PATCH v2 00/13] LSM: Move away from secids Casey Schaufler
2024-08-30 0:33 ` [PATCH v2 01/13] LSM: Add the lsmblob data structure Casey Schaufler
2024-09-04 0:18 ` [PATCH v2 1/13] " Paul Moore
2024-09-04 0:53 ` Casey Schaufler
2024-09-04 20:00 ` Paul Moore
2024-09-04 20:28 ` Casey Schaufler [this message]
2024-09-04 20:36 ` Paul Moore
2024-08-30 0:34 ` [PATCH v2 02/13] LSM: Use lsmblob in security_audit_rule_match Casey Schaufler
2024-08-30 22:48 ` kernel test robot
2024-08-30 0:34 ` [PATCH v2 03/13] LSM: Add lsmblob_to_secctx hook Casey Schaufler
2024-09-04 0:18 ` [PATCH v2 3/13] " Paul Moore
2024-09-04 1:15 ` Casey Schaufler
2024-08-30 0:34 ` [PATCH v2 04/13] Audit: maintain an lsmblob in audit_context Casey Schaufler
2024-09-04 0:18 ` [PATCH v2 4/13] " Paul Moore
2024-09-04 1:18 ` Casey Schaufler
2024-08-30 0:34 ` [PATCH v2 05/13] LSM: Use lsmblob in security_ipc_getsecid Casey Schaufler
2024-09-04 0:18 ` [PATCH v2 5/13] " Paul Moore
2024-09-04 1:24 ` Casey Schaufler
2024-08-30 0:34 ` [PATCH v2 06/13] Audit: Update shutdown LSM data Casey Schaufler
2024-08-30 0:34 ` [PATCH v2 07/13] LSM: Use lsmblob in security_current_getsecid Casey Schaufler
2024-08-30 0:34 ` [PATCH v2 08/13] LSM: Use lsmblob in security_inode_getsecid Casey Schaufler
2024-08-30 0:34 ` [PATCH v2 09/13] Audit: use an lsmblob in audit_names Casey Schaufler
2024-08-30 0:34 ` [PATCH v2 10/13] LSM: Create new security_cred_getlsmblob LSM hook Casey Schaufler
2024-08-30 15:26 ` kernel test robot
2024-08-30 15:26 ` kernel test robot
2024-08-30 0:34 ` [PATCH v2 11/13] Audit: Change context data from secid to lsmblob Casey Schaufler
2024-08-30 0:34 ` [PATCH v2 12/13] Netlabel: Use lsmblob for audit data Casey Schaufler
2024-08-30 0:34 ` [PATCH v2 13/13] LSM: Remove lsmblob scaffolding Casey Schaufler
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=93952b9f-2e40-42fc-9a61-749b9c8ee306@schaufler-ca.com \
--to=casey@schaufler-ca.com \
--cc=apparmor@lists.ubuntu.com \
--cc=bpf@vger.kernel.org \
--cc=jmorris@namei.org \
--cc=john.johansen@canonical.com \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-security-module@vger.kernel.org \
--cc=mic@digikod.net \
--cc=paul@paul-moore.com \
--cc=penguin-kernel@i-love.sakura.ne.jp \
--cc=selinux@vger.kernel.org \
--cc=serge@hallyn.com \
--cc=stephen.smalley.work@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®