From: Paolo Bonzini <pbonzini@redhat.com>
To: Vipin Sharma <vipinsh@google.com>,
seanjc@google.com, jmattson@google.com
Cc: dmatlack@google.com, kvm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v4 0/2] Add a helper to read GPR index and move INVPCID validation to a common place
Date: Thu, 11 Nov 2021 15:06:41 +0100 [thread overview]
Message-ID: <944f0aad-c262-7f33-c54e-9c55fedba553@redhat.com> (raw)
In-Reply-To: <20211109174426.2350547-1-vipinsh@google.com>
On 11/9/21 18:44, Vipin Sharma wrote:
> INVPCID, INVVPID, and INVEPT instructions retrieve the GPR index
> similarly to find the invalidation type. Patch 1 moves the shift and
> mask magic to a single place.
>
> INVPCID invalidation type check is same for both VMX and SVM. This
> instruction is not documented to verify the type before reading the
> operand from memory. So, moving the check to a common place in patch 2.
>
> v4:
> - Changed commit message of the patch 1
>
> v3:
> - https://lore.kernel.org/lkml/20211103205911.1253463-1-vipinsh@google.com/
> - Patch 2's commit message is more detailed now.
>
> v2:
> - https://lore.kernel.org/lkml/20211103183232.1213761-1-vipinsh@google.com/
> - Keeping the register read visible in the functions.
> - Removed INVPCID type check hardcoding and moved error condition to common
> function.
>
> v1: https://lore.kernel.org/lkml/20211011194615.2955791-1-vipinsh@google.com/
>
> Vipin Sharma (2):
> KVM: VMX: Add a helper function to retrieve the GPR index for INVPCID,
> INVVPID, and INVEPT
> KVM: Move INVPCID type check from vmx and svm to the common
> kvm_handle_invpcid()
>
> arch/x86/kvm/svm/svm.c | 5 -----
> arch/x86/kvm/vmx/nested.c | 10 ++++++----
> arch/x86/kvm/vmx/vmx.c | 9 +++------
> arch/x86/kvm/vmx/vmx.h | 5 +++++
> arch/x86/kvm/x86.c | 3 ++-
> 5 files changed, 16 insertions(+), 16 deletions(-)
>
Queued, thanks.
Paolo
prev parent reply other threads:[~2021-11-11 14:06 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-11-09 17:44 Vipin Sharma
2021-11-09 17:44 ` [PATCH v4 1/2] KVM: VMX: Add a helper function to retrieve the GPR index for INVPCID, INVVPID, and INVEPT Vipin Sharma
2021-11-09 17:44 ` [PATCH v4 2/2] KVM: Move INVPCID type check from vmx and svm to the common kvm_handle_invpcid() Vipin Sharma
2021-11-11 14:06 ` Paolo Bonzini [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=944f0aad-c262-7f33-c54e-9c55fedba553@redhat.com \
--to=pbonzini@redhat.com \
--cc=dmatlack@google.com \
--cc=jmattson@google.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=seanjc@google.com \
--cc=vipinsh@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®