Hi all, This patch improves the robustness and correctness of the HFS+ filesystem implementation by addressing issues in |btree.c| and |options.c|. *Changes in fs/hfsplus/btree.c:* * Removed unused |mod| variable. * Fixed potential out-of-bounds access in |clumptbl|. * Made clump size calculation more precise (0.8% explicitly). * Ensured clump size is properly aligned to block/node size. * Improved loop readability for exponent calculation. * Added a fallback to prevent invalid clump sizes. * Updated comment link to Apple's new OSS repository. *Changes in fs/hfsplus/options.c:* * Properly check the |"force"| option during remount. * Validate string lengths safely using |strnlen()|. * Ensure previous NLS mappings are unloaded before loading new ones. * Improve error messages for clarity. *Summary of Changes* **fs/hfsplus/btree.c   | 176 +++++++++++++++++++++++--------------------  fs/hfsplus/options.c | 120 ++++++++++++++---------------  2 files changed, 154 insertions(+), 142 deletions(-) Please find the patch attached Best Regards, Pranjal Prasad * *