From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id 7BEA6C4321E for ; Wed, 19 Jan 2022 18:29:44 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1356766AbiASS3n (ORCPT ); Wed, 19 Jan 2022 13:29:43 -0500 Received: from mxout02.lancloud.ru ([45.84.86.82]:60414 "EHLO mxout02.lancloud.ru" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1356737AbiASS3l (ORCPT ); Wed, 19 Jan 2022 13:29:41 -0500 Received: from LanCloud DKIM-Filter: OpenDKIM Filter v2.11.0 mxout02.lancloud.ru EFD8920BF006 Received: from LanCloud Received: from LanCloud Received: from LanCloud From: Sergey Shtylyov Subject: Re: [PATCH 1/2] platform: make platform_get_irq_optional() optional To: =?UTF-8?Q?Uwe_Kleine-K=c3=b6nig?= , "Geert Uytterhoeven" CC: Andrew Lunn , Ulf Hansson , Vignesh Raghavendra , KVM list , "Rafael J. Wysocki" , , "Linus Walleij" , Amit Kucheria , "ALSA Development Mailing List" , Jaroslav Kysela , Guenter Roeck , Thierry Reding , MTD Maling List , Linux I2C , Miquel Raynal , , linux-spi , Jiri Slaby , "David S. Miller" , Khuong Dinh , Florian Fainelli , Matthias Schiffer , Kamal Dasu , "Greg Kroah-Hartman" , Lee Jones , Bartosz Golaszewski , Daniel Lezcano , Kishon Vijay Abraham I , bcm-kernel-feedback-list , "open list:SERIAL DRIVERS" , Jakub Kicinski , Zhang Rui , , Linux PWM List , Robert Richter , "Saravanan Sekar" , Corey Minyard , Linux PM list , Liam Girdwood , "Mauro Carvalho Chehab" , John Garry , Peter Korsgaard , William Breathitt Gray , Mark Gross , Hans de Goede , Alex Williamson , "Mark Brown" , Borislav Petkov , Takashi Iwai , Matthias Brugger , , Andy Shevchenko , Benson Leung , Pengutronix Kernel Team , Linux ARM , , "Tony Luck" , Richard Weinberger , Mun Yew Tham , Eric Auger , netdev , "open list:GPIO SUBSYSTEM" , Cornelia Huck , "Linux MMC List" , Joakim Zhang , Linux Kernel Mailing List , Linux-Renesas , Vinod Koul , "James Morse" , Zha Qipeng , "Sebastian Reichel" , =?UTF-8?Q?Niklas_S=c3=b6derlund?= , , "Brian Norris" , Yoshihiro Shimoda References: <20220117092444.opoedfcf5k5u6otq@pengutronix.de> <20220117114923.d5vajgitxneec7j7@pengutronix.de> <20220117170609.yxaamvqdkivs56ju@pengutronix.de> <20220118090913.pjumkq4zf4iqtlha@pengutronix.de> <20220118120806.pbjsat4ulg3vnhsh@pengutronix.de> <20220118142945.6y3rmvzt44pjpr4z@pengutronix.de> <6370798a-7a7e-243d-99f9-09bf772ddbac@omp.ru> Organization: Open Mobile Platform Message-ID: <96ff907a-4ad2-5b2e-9bcc-09592d65a6df@omp.ru> Date: Wed, 19 Jan 2022 21:29:28 +0300 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.10.1 MIME-Version: 1.0 In-Reply-To: <6370798a-7a7e-243d-99f9-09bf772ddbac@omp.ru> Content-Type: text/plain; charset="windows-1252" Content-Language: en-US Content-Transfer-Encoding: 7bit X-Originating-IP: [192.168.11.198] X-ClientProxiedBy: LFEXT02.lancloud.ru (fd00:f066::142) To LFEX1907.lancloud.ru (fd00:f066::207) Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 1/19/22 7:12 PM, Sergey Shtylyov wrote: [...] >>> So there's still a need for two functions. >> >> Or a single function not emitting an error message together with the >> callers being responsible for calling dev_err(). >> >> So the options in my preference order (first is best) are: >> >> - Remove the printk from platform_get_irq() and remove >> platform_get_irq_optional(); > > Strong NAK here: > - dev_err() in our function saves a lot of (repeatable!) comments; s/comments/code/. Actually, I think I can accept the removal of dev_err_probe() in platform_get_irq() as this is not a common practice anyway (yet? :-))... > - we've already discussed that it's more optimal to check againt 0 than Against. :-) > against -ENXIO in the callers. And we also aim to be the error code agnostic in the callers... >> - Rename platform_get_irq_optional() to platform_get_irq_silently() > > NAK as well. We'd better off complaining about irq < 0 in this function. >> - Keep platform_get_irq_optional() as is > > NAK, it's suboptimal in the call sites. s/in/on/. [...] >> Best regards >> Uwe MBR, Sergey