From: Joe Perches <joe@perches.com>
To: Gary R Hook <ghook@amd.com>, "Hook, Gary" <Gary.Hook@amd.com>,
"herbert@gondor.apana.org.au" <herbert@gondor.apana.org.au>,
"corbet@lwn.net" <corbet@lwn.net>,
"linux-doc@vger.kernel.org" <linux-doc@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-crypto@vger.kernel.org" <linux-crypto@vger.kernel.org>,
"davem@davemloft.net" <davem@davemloft.net>
Subject: Re: [PATCH 0/3] Clean up crypto documentation
Date: Mon, 24 Jun 2019 13:29:42 -0700 [thread overview]
Message-ID: <977bc7c484ef55ff78de51d7555afcc3c3350b1e.camel@perches.com> (raw)
In-Reply-To: <d8b359ff-5891-7bb8-d292-9f10cca04f17@amd.com>
On Mon, 2019-06-24 at 20:06 +0000, Gary R Hook wrote:
Hi Gary.
> On 6/24/19 2:30 PM, Joe Perches wrote:
> > On Mon, 2019-06-24 at 19:07 +0000, Hook, Gary wrote:
> > > Tidy up the crypto documentation by filling in some variable
> > > descriptions, make some grammatical corrections, and enhance
> > > formatting.
> >
> > While this seems generally OK, please try not to make the
> > readability of the source _text_ less intelligible just
> > to enhance the output formatting of the html.
> >
> > e.g.:
> >
> > Unnecessary blank lines separating function descriptions
> > Removing space alignment from bullet point descriptions
>
> Apologies. I generally consider white space a Good Thing,
> but will take your note and not do that. The blank lines I
> added do not affect the output, so I should not have done
> that.
>
> Also, I turned sentences into bulleted lists here, so I'm not
> clear on whether that was a Bad Thing or not.
To me, using bulleted lists are not a bad thing at all
but are quite the opposite for humans to read.
> Seems more legible
> to me all the way around, but I clearly could be incorrect.
Not at all.
> I agree that mucking with alignment is a bad thing, and would not
> intentionally do so. That said, if you would please elaborate on
> any mistakes I've made?
>
> Finally, would you prefer a v2 of the patch set? Happy to do
> whatever is preferred, of course.
Whatever Jonathan decides is fine with me.
Mine was just a plea to avoid unnecessarily
making the source text harder to read as
that's what I mostly use.
I don't know if this extension is valid yet, but
I believe just using <function_name>() is more
readable as text than ``<function_name>`` or
:c:func:`<function_name>`
https://lore.kernel.org/lkml/20190425200125.12302-1-corbet@lwn.net/T/
I prefer the automatic approach over the manual
marking of functions as ideally sphinx formatting
should not overly impact the source text.
next prev parent reply other threads:[~2019-06-24 20:29 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-06-24 19:07 Hook, Gary
2019-06-24 19:07 ` [PATCH 1/3] crypto: doc - Add parameter documentation Hook, Gary
2019-06-24 19:07 ` [PATCH 2/3] crypto: doc - Describe the crypto engine Hook, Gary
2019-06-24 22:03 ` Eric Biggers
2019-06-25 13:05 ` Gary R Hook
2019-06-24 19:07 ` [PATCH 3/3] crypto: doc - Fix formatting of new crypto engine content Hook, Gary
2019-06-24 19:30 ` [PATCH 0/3] Clean up crypto documentation Joe Perches
2019-06-24 20:06 ` Gary R Hook
2019-06-24 20:29 ` Joe Perches [this message]
2019-06-24 20:37 ` Jonathan Corbet
2019-06-24 22:37 ` Joe Perches
2019-06-25 13:33 ` Gary R Hook
2019-06-25 13:52 ` Jonathan Corbet
2019-06-25 15:29 ` Gary R Hook
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=977bc7c484ef55ff78de51d7555afcc3c3350b1e.camel@perches.com \
--to=joe@perches.com \
--cc=Gary.Hook@amd.com \
--cc=corbet@lwn.net \
--cc=davem@davemloft.net \
--cc=ghook@amd.com \
--cc=herbert@gondor.apana.org.au \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®