From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751321AbdKTO0N convert rfc822-to-8bit (ORCPT ); Mon, 20 Nov 2017 09:26:13 -0500 Received: from smtp-out6.electric.net ([192.162.217.181]:60164 "EHLO smtp-out6.electric.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751151AbdKTO0L (ORCPT ); Mon, 20 Nov 2017 09:26:11 -0500 From: David Laight To: "'Rasmus Villemoes'" , "David S. Miller" CC: "netdev@vger.kernel.org" , "linux-kernel@vger.kernel.org" Subject: RE: [PATCH 3/7] net: core: eliminate dev_alloc_name{,_ns} code duplication Thread-Topic: [PATCH 3/7] net: core: eliminate dev_alloc_name{,_ns} code duplication Thread-Index: AQHTXAxoXiQZAuVF6k+FbrQBoiOs4KMdXsTA Date: Mon, 20 Nov 2017 14:26:27 +0000 Message-ID: <9845d969b0af4f7ca534144bc5d4872e@AcuMS.aculab.com> References: <20171112231511.4666-1-linux@rasmusvillemoes.dk> <20171112231511.4666-4-linux@rasmusvillemoes.dk> In-Reply-To: <20171112231511.4666-4-linux@rasmusvillemoes.dk> Accept-Language: en-GB, en-US Content-Language: en-US X-MS-Has-Attach: X-MS-TNEF-Correlator: x-ms-exchange-transport-fromentityheader: Hosted x-originating-ip: [10.202.99.200] Content-Type: text/plain; charset="Windows-1252" Content-Transfer-Encoding: 8BIT MIME-Version: 1.0 X-Outbound-IP: 156.67.243.126 X-Env-From: David.Laight@ACULAB.COM X-Proto: esmtps X-Revdns: X-HELO: AcuMS.aculab.com X-TLS: TLSv1.2:ECDHE-RSA-AES256-SHA384:256 X-Authenticated_ID: X-PolicySMART: 3396946, 3397078 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org From: Rasmus Villemoes > Sent: 12 November 2017 23:15 > dev_alloc_name contained a BUG_ON(), which I moved to dev_alloc_name_ns; > the only other caller of that already has the same BUG_ON. > > Signed-off-by: Rasmus Villemoes > --- > net/core/dev.c | 12 ++---------- > 1 file changed, 2 insertions(+), 10 deletions(-) > > diff --git a/net/core/dev.c b/net/core/dev.c > index 240ae6bc1097..1077bfe97bde 100644 > --- a/net/core/dev.c > +++ b/net/core/dev.c > @@ -1112,6 +1112,7 @@ static int dev_alloc_name_ns(struct net *net, > char buf[IFNAMSIZ]; > int ret; > > + BUG_ON(!net); > ret = __dev_alloc_name(net, name, buf); Just delete it. The NULL pointer dereference is as easy to debug as the BUG(). David