mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Lakshmi Ramasubramanian <nramas@linux.microsoft.com>
To: Mimi Zohar <zohar@linux.ibm.com>,
	bauerman@linux.ibm.com, robh@kernel.org,
	gregkh@linuxfoundation.org, james.morse@arm.com,
	catalin.marinas@arm.com, sashal@kernel.org, will@kernel.org,
	mpe@ellerman.id.au, benh@kernel.crashing.org, paulus@samba.org,
	robh+dt@kernel.org, frowand.list@gmail.com,
	vincenzo.frascino@arm.com, mark.rutland@arm.com,
	dmitry.kasatkin@gmail.com, jmorris@namei.org, serge@hallyn.com,
	pasha.tatashin@soleen.com, allison@lohutok.net,
	kstewart@linuxfoundation.org, takahiro.akashi@linaro.org,
	tglx@linutronix.de, masahiroy@kernel.org, bhsharma@redhat.com,
	mbrugger@suse.com, hsinyi@chromium.org, tao.li@vivo.com,
	christophe.leroy@c-s.fr
Cc: linux-integrity@vger.kernel.org, linux-kernel@vger.kernel.org,
	devicetree@vger.kernel.org, prsriva@linux.microsoft.com,
	balajib@linux.microsoft.com
Subject: Re: [PATCH v7 2/4] powerpc: Refactor kexec functions to move arch independent code to ima
Date: Tue, 20 Oct 2020 19:38:39 -0700	[thread overview]
Message-ID: <9a44d8aa-515d-fc97-74bd-7ae976dea35b@linux.microsoft.com> (raw)
In-Reply-To: <ecc13356983d5cff536c53c4da98a839ea9a0f19.camel@linux.ibm.com>

On 10/20/20 1:01 PM, Mimi Zohar wrote:
> On Wed, 2020-09-30 at 13:59 -0700, Lakshmi Ramasubramanian wrote:
>> The functions ima_get_kexec_buffer() and ima_free_kexec_buffer(),
>> that handle carrying forward the IMA measurement logs on kexec for
>> powerpc do not have architecture specific code, but they are currently
>> defined for powerpc only.
>>
>> Move ima_get_kexec_buffer() and ima_free_kexec_buffer() to IMA
>> subsystem. A later patch in this series will use these functions for
>> carrying forward the IMA measurement log for ARM64.
>>
>> With the above refactoring arch/powerpc/kexec/ima.c contains only
>> functions used when CONFIG_IMA_KEXEC is enabled. Update Makefile
>> in arch/powerpc/kexec to include arch/powerpc/kexec/ima.c only
>> when CONFIG_IMA_KEXEC is enabled.
>>
>> Move ima_dump_measurement_list() and ima_add_kexec_buffer() to
>> a new file namely ima_kexec_fdt.c in IMA. Update
>> security/integrity/ima/Makefile to include ima_kexec_fdt.c only
>> when CONFIG_IMA_KEXEC is enabled.
>>
>> Co-developed-by: Prakhar Srivastava <prsriva@linux.microsoft.com>
>> Signed-off-by: Prakhar Srivastava <prsriva@linux.microsoft.com>
>> Signed-off-by: Lakshmi Ramasubramanian <nramas@linux.microsoft.com>
> 
> The existing support for carrying the IMA measurement list across kexec
> is limited to powerpc.  This patch set is adding similar support for
> arm64, making as much of the existing code as generic as possible.
> However ima_dump_measurement_list() is already generic, but for some
> reason this patch moves it to ima_kexec_fdt.c.  ima_kexec_fdt.c should
> be limited to device tree specific code.

I wanted to split the functions defined under CONFIG_HAVE_IMA_KEXEC and 
CONFIG_IMA_KEXEC to separate files so that we can get rid of #ifdef in C 
file and instead conditionally compile the C files (using Makefile).

ima_dump_measurement_list() need to be defined only when 
CONFIG_IMA_KEXEC is defined. I moved it to ima_kexec_fdt.c

Instead of ima_kexec_fdt.c, where ima_dump_measurement_list() and 
ima_add_kexec_buffer() are defined, perhaps I can change the file name 
to "ima_kexec_buffer.c". Would that be better?

> 
> This patch is probably doing the right thing, but the way the patch is
> formatted it replaces parts of a function with a different function.
> With the changes suggested above and in 1/4,  the next version should
> be clearer.

Like I'd stated above, I wanted to remove "#ifdef" from the C files and 
hence had to move some functions. But the functionalities haven't been 
changed.

thanks,
  -lakshmi




  reply	other threads:[~2020-10-21  2:38 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-30 20:59 [PATCH v7 0/3] Carry forward IMA measurement log on kexec on ARM64 Lakshmi Ramasubramanian
2020-09-30 20:59 ` [PATCH v7 1/4] powerpc: Refactor kexec functions to move arch independent code to kernel Lakshmi Ramasubramanian
2020-10-20 20:00   ` Mimi Zohar
2020-10-21  2:25     ` Lakshmi Ramasubramanian
2020-10-21  3:17       ` Mimi Zohar
2020-10-21 16:58         ` Lakshmi Ramasubramanian
2020-10-23  3:46           ` Thiago Jung Bauermann
2020-10-26 18:36             ` Lakshmi Ramasubramanian
2020-09-30 20:59 ` [PATCH v7 2/4] powerpc: Refactor kexec functions to move arch independent code to ima Lakshmi Ramasubramanian
2020-10-20 20:01   ` Mimi Zohar
2020-10-21  2:38     ` Lakshmi Ramasubramanian [this message]
2020-10-21  3:50       ` Mimi Zohar
2020-10-21 16:20         ` Lakshmi Ramasubramanian
2020-09-30 20:59 ` [PATCH v7 3/4] arm64: Store IMA log information in kimage used for kexec Lakshmi Ramasubramanian
2020-09-30 20:59 ` [PATCH v7 4/4] arm64: Add IMA kexec buffer to DTB Lakshmi Ramasubramanian

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=9a44d8aa-515d-fc97-74bd-7ae976dea35b@linux.microsoft.com \
    --to=nramas@linux.microsoft.com \
    --cc=allison@lohutok.net \
    --cc=balajib@linux.microsoft.com \
    --cc=bauerman@linux.ibm.com \
    --cc=benh@kernel.crashing.org \
    --cc=bhsharma@redhat.com \
    --cc=catalin.marinas@arm.com \
    --cc=christophe.leroy@c-s.fr \
    --cc=devicetree@vger.kernel.org \
    --cc=dmitry.kasatkin@gmail.com \
    --cc=frowand.list@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hsinyi@chromium.org \
    --cc=james.morse@arm.com \
    --cc=jmorris@namei.org \
    --cc=kstewart@linuxfoundation.org \
    --cc=linux-integrity@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=masahiroy@kernel.org \
    --cc=mbrugger@suse.com \
    --cc=mpe@ellerman.id.au \
    --cc=pasha.tatashin@soleen.com \
    --cc=paulus@samba.org \
    --cc=prsriva@linux.microsoft.com \
    --cc=robh+dt@kernel.org \
    --cc=robh@kernel.org \
    --cc=sashal@kernel.org \
    --cc=serge@hallyn.com \
    --cc=takahiro.akashi@linaro.org \
    --cc=tao.li@vivo.com \
    --cc=tglx@linutronix.de \
    --cc=vincenzo.frascino@arm.com \
    --cc=will@kernel.org \
    --cc=zohar@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®