mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Marcos Paulo de Souza <mpdesouza@suse.com>
To: Petr Mladek <pmladek@suse.com>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Eric Biederman	 <ebiederm@xmission.com>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Len Brown <len.brown@intel.com>, Pavel Machek <pavel@ucw.cz>,
	Steven Rostedt	 <rostedt@goodmis.org>,
	John Ogness <john.ogness@linutronix.de>,
	Sergey Senozhatsky <senozhatsky@chromium.org>,
	Todd E Brandt <todd.e.brandt@linux.intel.com>,
	Jiri Slaby	 <jirislaby@kernel.org>,
	linux-kernel@vger.kernel.org, kexec@lists.infradead.org,
	 linux-pm@vger.kernel.org, linux-serial@vger.kernel.org
Subject: Re: [PATCH 0/5] printk: renaming some suspend/resume functions and one fix for unblanking
Date: Tue, 11 Mar 2025 11:41:14 -0300	[thread overview]
Message-ID: <9a8b7634b123e82c3eaf278a5944feafd91279cc.camel@suse.com> (raw)
In-Reply-To: <Z9AvKmM4Li57-E2E@pathway.suse.cz>

On Tue, 2025-03-11 at 13:40 +0100, Petr Mladek wrote:
> On Tue 2025-03-11 11:38:00, Petr Mladek wrote:
> > On Wed 2025-02-26 16:59:00, Marcos Paulo de Souza wrote:
> > > Hello, I've being working on some patches that help to clarify
> > > the suspend/resume
> > > of printk machinery. The last patch on this patchset address one
> > > issue regarding
> > > suspended consoles and blanking.
> > > 
> > > This is a part one patchset that I would like to see merged
> > > before I send more patches
> > > that will rework the suspend flag (a global suspend flag istead
> > > of per console) and
> > > the removal of CON_ENABLED flag later on (I've created a function
> > > that will forcibly)
> > > register the console instead of using this flag.
> > > 
> > > Please review!
> > > 
> > > Signed-off-by: Marcos Paulo de Souza <mpdesouza@suse.com>
> > 
> > Looks good to me. I could fix the typos when pushing.
> > 
> > Well, there is one more thing. It seems that the simple graphic
> > logger
> > was merged for 6.14-rc1. And the console_stop()/console_start() API
> > is used also in drivers/gpu/drm/clients/drm_log.c.
> > 
> > It is actually the code which motivated this rename, as already
> > pointed out by John, see
> > https://lore.kernel.org/lkml/ZyoNZfLT6tlVAWjO@pathway.suse.cz/
> > 
> > Well, I am going to update these two locations when pushing this
> > as well. Let's just get this change done.
> 
> And I did as mentioned above.
> 
> JFYI, the patcheset has been committed into printk/linux.git,
> branch for-6.15-console-suspend-api-cleanup.

Thanks to all reviewers and to you Petr for taking the patches and
adjusting the typos!

> 
> Best Regards,
> Petr


      reply	other threads:[~2025-03-11 14:41 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-26 19:59 Marcos Paulo de Souza
2025-02-26 19:59 ` [PATCH 1/5] printk: Rename suspend_console to console_suspend_all Marcos Paulo de Souza
2025-02-26 19:59 ` [PATCH 2/5] printk: Rename resume_console to console_resume_all Marcos Paulo de Souza
2025-02-26 19:59 ` [PATCH 3/5] printk: Rename console_stop to console_suspend Marcos Paulo de Souza
2025-02-26 19:59 ` [PATCH 4/5] printk: Rename console_start to console_resume Marcos Paulo de Souza
2025-02-27  6:30   ` Jiri Slaby
2025-02-26 19:59 ` [PATCH 5/5] printk: Check CON_SUSPEND when unblanking a console Marcos Paulo de Souza
2025-02-27 15:30 ` [PATCH 0/5] printk: renaming some suspend/resume functions and one fix for unblanking John Ogness
2025-03-11 10:37 ` Petr Mladek
2025-03-11 12:40   ` Petr Mladek
2025-03-11 14:41     ` Marcos Paulo de Souza [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=9a8b7634b123e82c3eaf278a5944feafd91279cc.camel@suse.com \
    --to=mpdesouza@suse.com \
    --cc=ebiederm@xmission.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jirislaby@kernel.org \
    --cc=john.ogness@linutronix.de \
    --cc=kexec@lists.infradead.org \
    --cc=len.brown@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=linux-serial@vger.kernel.org \
    --cc=pavel@ucw.cz \
    --cc=pmladek@suse.com \
    --cc=rafael@kernel.org \
    --cc=rostedt@goodmis.org \
    --cc=senozhatsky@chromium.org \
    --cc=todd.e.brandt@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®