mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Baolu Lu <baolu.lu@linux.intel.com>
To: "Tian, Kevin" <kevin.tian@intel.com>,
	Joerg Roedel <joro@8bytes.org>, Will Deacon <will@kernel.org>,
	Robin Murphy <robin.murphy@arm.com>,
	Jason Gunthorpe <jgg@ziepe.ca>,
	Jean-Philippe Brucker <jean-philippe@linaro.org>,
	Nicolin Chen <nicolinc@nvidia.com>
Cc: baolu.lu@linux.intel.com, "Liu, Yi L" <yi.l.liu@intel.com>,
	Jacob Pan <jacob.jun.pan@linux.intel.com>,
	"iommu@lists.linux.dev" <iommu@lists.linux.dev>,
	"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 06/12] iommu: Make dev->fault_param static
Date: Fri, 4 Aug 2023 13:34:53 +0800	[thread overview]
Message-ID: <9ae1fc82-d4d9-7050-b66f-b15184dc0278@linux.intel.com> (raw)
In-Reply-To: <BN9PR11MB5276214F6B8D4E4529C559EE8C09A@BN9PR11MB5276.namprd11.prod.outlook.com>

On 8/4/23 11:56 AM, Tian, Kevin wrote:
>> From: Baolu Lu <baolu.lu@linux.intel.com>
>> Sent: Friday, August 4, 2023 11:17 AM
>>
>> On 2023/8/3 16:08, Tian, Kevin wrote:
>>>> From: Lu Baolu <baolu.lu@linux.intel.com>
>>>> Sent: Thursday, July 27, 2023 1:49 PM
>>>>
>>>>
>>>>    	mutex_init(&param->lock);
>>>> +	param->fault_param = kzalloc(sizeof(*param->fault_param),
>>>> GFP_KERNEL);
>>>> +	if (!param->fault_param) {
>>>> +		kfree(param);
>>>> +		return -ENOMEM;
>>>> +	}
>>>> +	mutex_init(&param->fault_param->lock);
>>>> +	INIT_LIST_HEAD(&param->fault_param->faults);
>>>
>>> let's also move 'partial' from struct iopf_device_param into struct
>>> iommu_fault_param. That logic is not specific to sva.
>>>
>>> meanwhile probably iopf_device_param can be renamed to
>>> iopf_sva_param since all the remaining fields are only used by
>>> the sva handler.
>>>
>>> current naming (iommu_fault_param vs. iopf_device_param) is a
>>> bit confusing when reading related code.
>>
>> My understanding is that iommu_fault_param is for all kinds of iommu
>> faults. Currently they probably include recoverable IO page faults or
>> unrecoverable DMA faults.
>>
>> While, iopf_device_param is for the recoverable IO page faults. I agree
>> that this naming is not specific and even confusing. Perhaps renaming it
>> to something like iommu_iopf_param?
>>
> 
> or just iopf_param.

Okay.

Best regards,
baolu

  reply	other threads:[~2023-08-04  5:38 UTC|newest]

Thread overview: 70+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-07-27  5:48 [PATCH v2 00/12] iommu: Prepare to deliver page faults to user space Lu Baolu
2023-07-27  5:48 ` [PATCH v2 01/12] iommu: Move iommu fault data to linux/iommu.h Lu Baolu
2023-08-03  7:53   ` Tian, Kevin
2023-08-04  2:51     ` Baolu Lu
2023-08-09 16:58   ` Jason Gunthorpe
2023-07-27  5:48 ` [PATCH v2 02/12] iommu/arm-smmu-v3: Remove unrecoverable faults reporting Lu Baolu
2023-07-27  5:48 ` [PATCH v2 03/12] iommu: Remove unrecoverable fault data Lu Baolu
2023-08-03  7:54   ` Tian, Kevin
2023-08-04  2:58     ` Baolu Lu
2023-08-04  3:51       ` Tian, Kevin
2023-08-04  5:34         ` Baolu Lu
2023-08-08 18:39         ` Jason Gunthorpe
2023-08-09  0:01           ` Tian, Kevin
2023-08-09 14:05             ` Jason Gunthorpe
2023-08-09 16:59   ` Jason Gunthorpe
2023-08-10  2:27     ` Baolu Lu
2023-08-10 16:46       ` Jason Gunthorpe
2023-08-11  1:15         ` Baolu Lu
2023-08-11  4:17           ` Tian, Kevin
2023-07-27  5:48 ` [PATCH v2 04/12] iommu: Replace device fault handler with iommu_queue_iopf() Lu Baolu
2023-08-03  7:55   ` Tian, Kevin
2023-08-10 18:22   ` Jason Gunthorpe
2023-08-11  1:23     ` Baolu Lu
2023-08-10 18:33   ` Jason Gunthorpe
2023-08-11  1:25     ` Baolu Lu
2023-07-27  5:48 ` [PATCH v2 05/12] iommu: Change the return value of dev_iommu_get() Lu Baolu
2023-08-03  7:59   ` Tian, Kevin
2023-08-04  3:10     ` Baolu Lu
2023-08-04  3:55       ` Tian, Kevin
2023-08-04  5:33         ` Baolu Lu
2023-08-09 16:58   ` Jason Gunthorpe
2023-08-10  2:30     ` Baolu Lu
2023-07-27  5:48 ` [PATCH v2 06/12] iommu: Make dev->fault_param static Lu Baolu
2023-08-03  8:08   ` Tian, Kevin
2023-08-04  3:16     ` Baolu Lu
2023-08-04  3:56       ` Tian, Kevin
2023-08-04  5:34         ` Baolu Lu [this message]
2023-08-10 18:20   ` Jason Gunthorpe
2023-08-10 18:46     ` Jason Gunthorpe
2023-08-11  1:43       ` Baolu Lu
2023-07-27  5:48 ` [PATCH v2 07/12] iommu: Remove iommu_[un]register_device_fault_handler() Lu Baolu
2023-08-03  8:09   ` Tian, Kevin
2023-08-10 18:59   ` Jason Gunthorpe
2023-07-27  5:48 ` [PATCH v2 08/12] iommu: Prepare for separating SVA and IOPF Lu Baolu
2023-08-03  8:16   ` Tian, Kevin
2023-08-04  3:26     ` Baolu Lu
2023-08-08 18:43     ` Jason Gunthorpe
2023-08-09  0:02       ` Tian, Kevin
2023-08-09 10:40         ` Baolu Lu
2023-08-10  2:35           ` Tian, Kevin
2023-08-10 16:47             ` Jason Gunthorpe
2023-08-11  1:53               ` Baolu Lu
2023-08-11 13:27                 ` Jason Gunthorpe
2023-08-13 11:19                   ` Baolu Lu
2023-07-27  5:48 ` [PATCH v2 09/12] iommu: Move iopf_handler() to iommu-sva.c Lu Baolu
2023-08-03  8:21   ` Tian, Kevin
2023-08-04  3:28     ` Baolu Lu
2023-08-10 19:02   ` Jason Gunthorpe
2023-08-11  1:55     ` Baolu Lu
2023-07-27  5:48 ` [PATCH v2 10/12] iommu: Make iommu_queue_iopf() more generic Lu Baolu
2023-08-10 19:07   ` Jason Gunthorpe
2023-08-11  2:21     ` Baolu Lu
2023-08-11 13:29       ` Jason Gunthorpe
2023-08-12 23:18         ` Baolu Lu
2023-07-27  5:48 ` [PATCH v2 11/12] iommu: Separate SVA and IOPF in Makefile and Kconfig Lu Baolu
2023-08-10 19:09   ` Jason Gunthorpe
2023-07-27  5:48 ` [PATCH v2 12/12] iommu: Add helper to set iopf handler for domain Lu Baolu
2023-08-10 19:18   ` Jason Gunthorpe
2023-08-11  2:40     ` Baolu Lu
2023-08-11 17:14       ` Jason Gunthorpe

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=9ae1fc82-d4d9-7050-b66f-b15184dc0278@linux.intel.com \
    --to=baolu.lu@linux.intel.com \
    --cc=iommu@lists.linux.dev \
    --cc=jacob.jun.pan@linux.intel.com \
    --cc=jean-philippe@linaro.org \
    --cc=jgg@ziepe.ca \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nicolinc@nvidia.com \
    --cc=robin.murphy@arm.com \
    --cc=will@kernel.org \
    --cc=yi.l.liu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome