From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751732AbdISMoA (ORCPT ); Tue, 19 Sep 2017 08:44:00 -0400 Received: from mx1.redhat.com ([209.132.183.28]:50018 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751365AbdISMn6 (ORCPT ); Tue, 19 Sep 2017 08:43:58 -0400 DMARC-Filter: OpenDMARC Filter v1.3.2 mx1.redhat.com 92E7746213 Authentication-Results: ext-mx05.extmail.prod.ext.phx2.redhat.com; dmarc=none (p=none dis=none) header.from=redhat.com Authentication-Results: ext-mx05.extmail.prod.ext.phx2.redhat.com; spf=fail smtp.mailfrom=longman@redhat.com Subject: Re: [PATCH v6 2/2] block_dev: Rename bd_fsfreeze_mutex To: Christoph Hellwig Cc: Jens Axboe , Steven Rostedt , Ingo Molnar , linux-kernel@vger.kernel.org, linux-fsdevel@vger.kernel.org, linux-block@vger.kernel.org, linux-nilfs@vger.kernel.org, cluster-devel@redhat.com, Bart Van Assche References: <1505760831-7747-1-git-send-email-longman@redhat.com> <1505760831-7747-3-git-send-email-longman@redhat.com> <20170918234745.GA8600@infradead.org> From: Waiman Long Organization: Red Hat Message-ID: <9c144de1-72bc-50b8-b828-afe7a5d371aa@redhat.com> Date: Tue, 19 Sep 2017 08:43:54 -0400 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.2.0 MIME-Version: 1.0 In-Reply-To: <20170918234745.GA8600@infradead.org> Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Content-Language: en-US X-Greylist: Sender IP whitelisted, not delayed by milter-greylist-4.5.16 (mx1.redhat.com [10.5.110.29]); Tue, 19 Sep 2017 12:43:58 +0000 (UTC) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 09/18/2017 07:47 PM, Christoph Hellwig wrote: > Don't rename it to a way to long name. Either add a separate mutex > for your purpose (unless there is interaction between freezing and > blktrace, which I doubt), or properly comment the usage. I would agree with you if the long name causes the expressions hard to read. In this particular case, it is just the single parameter to the mutex_lock() and mutex_unlock() functions. There is no confusion and overly long lines. So I think it is OK. In fact, I got the opposite advices in the past that some people prefer long descriptive names than short and cryptic names. Cheers, Longman