From: Jason Yan <yanaijie@huawei.com>
To: <mpe@ellerman.id.au>, <linuxppc-dev@lists.ozlabs.org>,
<diana.craciun@nxp.com>, <christophe.leroy@c-s.fr>,
<benh@kernel.crashing.org>, <paulus@samba.org>,
<npiggin@gmail.com>, <keescook@chromium.org>,
<kernel-hardening@lists.openwall.com>
Cc: <linux-kernel@vger.kernel.org>, <wangkefeng.wang@huawei.com>,
<yebin10@huawei.com>, <thunder.leizhen@huawei.com>,
<jingxiangfeng@huawei.com>, <zhaohongjiang@huawei.com>,
<oss@buserror.net>
Subject: Re: [PATCH v7 00/12] implement KASLR for powerpc/fsl_booke/32
Date: Tue, 24 Sep 2019 13:52:46 +0800 [thread overview]
Message-ID: <9c2dd2a8-83f2-983c-383e-956e19a7803a@huawei.com> (raw)
In-Reply-To: <20190920094546.44948-1-yanaijie@huawei.com>
Hi Scott,
Can you test v7 to see if it works to load a kernel at a non-zero address?
Thanks,
On 2019/9/20 17:45, Jason Yan wrote:
> This series implements KASLR for powerpc/fsl_booke/32, as a security
> feature that deters exploit attempts relying on knowledge of the location
> of kernel internals.
>
> Since CONFIG_RELOCATABLE has already supported, what we need to do is
> map or copy kernel to a proper place and relocate. Freescale Book-E
> parts expect lowmem to be mapped by fixed TLB entries(TLB1). The TLB1
> entries are not suitable to map the kernel directly in a randomized
> region, so we chose to copy the kernel to a proper place and restart to
> relocate.
>
> Entropy is derived from the banner and timer base, which will change every
> build and boot. This not so much safe so additionally the bootloader may
> pass entropy via the /chosen/kaslr-seed node in device tree.
>
> We will use the first 512M of the low memory to randomize the kernel
> image. The memory will be split in 64M zones. We will use the lower 8
> bit of the entropy to decide the index of the 64M zone. Then we chose a
> 16K aligned offset inside the 64M zone to put the kernel in.
>
> KERNELBASE
>
> |--> 64M <--|
> | |
> +---------------+ +----------------+---------------+
> | |....| |kernel| | |
> +---------------+ +----------------+---------------+
> | |
> |-----> offset <-----|
>
> kernstart_virt_addr
>
> We also check if we will overlap with some areas like the dtb area, the
> initrd area or the crashkernel area. If we cannot find a proper area,
> kaslr will be disabled and boot from the original kernel.
>
> Changes since v6:
> - Rename create_tlb_entry() to create_kaslr_tlb_entry()
> - Remove MAS2_VAL since there is no more users.
> - Move kaslr_booke.c to arch/powerpc/mm/nohash.
> - Call flush_icache_range() after copying the kernel.
> - Warning if no kaslr-seed provided by the bootloader
> - Use the right physical address when checking if the new position will overlap with other regions.
> - Do not clear bss for the second pass because some global variables will not be initialized again
> - Use tabs instead of spaces between the mnemonic and the arguments(in fsl_booke_entry_mapping.S).
>
> Changes since v5:
> - Rename M_IF_NEEDED to MAS2_M_IF_NEEDED
> - Define some global variable as __ro_after_init
> - Replace kimage_vaddr with kernstart_virt_addr
> - Depend on RELOCATABLE, not select it
> - Modify the comment block below the SPDX tag
> - Remove some useless headers in kaslr_booke.c and move is_second_reloc
> declarationto mmu_decl.h
> - Remove DBG() and use pr_debug() and rewrite comment above get_boot_seed().
> - Add a patch to document the KASLR implementation.
> - Split a patch from patch #10 which exports kaslr offset in VMCOREINFO ELF notes.
> - Remove extra logic around finding nokaslr string in cmdline.
> - Make regions static global and __initdata
>
> Changes since v4:
> - Add Reviewed-by tag from Christophe
> - Remove an unnecessary cast
> - Remove unnecessary parenthesis
> - Fix checkpatch warning
>
> Changes since v3:
> - Add Reviewed-by and Tested-by tag from Diana
> - Change the comment in fsl_booke_entry_mapping.S to be consistent
> with the new code.
>
> Changes since v2:
> - Remove unnecessary #ifdef
> - Use SZ_64M instead of0x4000000
> - Call early_init_dt_scan_chosen() to init boot_command_line
> - Rename kaslr_second_init() to kaslr_late_init()
>
> Changes since v1:
> - Remove some useless 'extern' keyword.
> - Replace EXPORT_SYMBOL with EXPORT_SYMBOL_GPL
> - Improve some assembly code
> - Use memzero_explicit instead of memset
> - Use boot_command_line and remove early_command_line
> - Do not print kaslr offset if kaslr is disabled
>
> Jason Yan (12):
> powerpc: unify definition of M_IF_NEEDED
> powerpc: move memstart_addr and kernstart_addr to init-common.c
> powerpc: introduce kernstart_virt_addr to store the kernel base
> powerpc/fsl_booke/32: introduce create_kaslr_tlb_entry() helper
> powerpc/fsl_booke/32: introduce reloc_kernel_entry() helper
> powerpc/fsl_booke/32: implement KASLR infrastructure
> powerpc/fsl_booke/32: randomize the kernel image offset
> powerpc/fsl_booke/kaslr: clear the original kernel if randomized
> powerpc/fsl_booke/kaslr: support nokaslr cmdline parameter
> powerpc/fsl_booke/kaslr: dump out kernel offset information on panic
> powerpc/fsl_booke/kaslr: export offset in VMCOREINFO ELF notes
> powerpc/fsl_booke/32: Document KASLR implementation
>
> Documentation/powerpc/kaslr-booke32.rst | 42 ++
> arch/powerpc/Kconfig | 11 +
> arch/powerpc/include/asm/nohash/mmu-book3e.h | 11 +-
> arch/powerpc/include/asm/page.h | 7 +
> arch/powerpc/kernel/early_32.c | 5 +-
> arch/powerpc/kernel/exceptions-64e.S | 12 +-
> arch/powerpc/kernel/fsl_booke_entry_mapping.S | 25 +-
> arch/powerpc/kernel/head_fsl_booke.S | 61 ++-
> arch/powerpc/kernel/machine_kexec.c | 1 +
> arch/powerpc/kernel/misc_64.S | 7 +-
> arch/powerpc/kernel/setup-common.c | 20 +
> arch/powerpc/mm/init-common.c | 7 +
> arch/powerpc/mm/init_32.c | 5 -
> arch/powerpc/mm/init_64.c | 5 -
> arch/powerpc/mm/mmu_decl.h | 11 +
> arch/powerpc/mm/nohash/Makefile | 1 +
> arch/powerpc/mm/nohash/fsl_booke.c | 8 +-
> arch/powerpc/mm/nohash/kaslr_booke.c | 401 ++++++++++++++++++
> 18 files changed, 587 insertions(+), 53 deletions(-)
> create mode 100644 Documentation/powerpc/kaslr-booke32.rst
> create mode 100644 arch/powerpc/mm/nohash/kaslr_booke.c
>
next prev parent reply other threads:[~2019-09-24 5:53 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-09-20 9:45 Jason Yan
2019-09-20 9:45 ` [PATCH v7 01/12] powerpc: unify definition of M_IF_NEEDED Jason Yan
2019-09-20 9:45 ` [PATCH v7 02/12] powerpc: move memstart_addr and kernstart_addr to init-common.c Jason Yan
2019-09-20 9:45 ` [PATCH v7 03/12] powerpc: introduce kernstart_virt_addr to store the kernel base Jason Yan
2019-09-20 9:45 ` [PATCH v7 04/12] powerpc/fsl_booke/32: introduce create_kaslr_tlb_entry() helper Jason Yan
2019-09-20 9:45 ` [PATCH v7 05/12] powerpc/fsl_booke/32: introduce reloc_kernel_entry() helper Jason Yan
2019-09-20 9:45 ` [PATCH v7 06/12] powerpc/fsl_booke/32: implement KASLR infrastructure Jason Yan
2019-09-20 9:45 ` [PATCH v7 07/12] powerpc/fsl_booke/32: randomize the kernel image offset Jason Yan
2019-09-20 9:45 ` [PATCH v7 08/12] powerpc/fsl_booke/kaslr: clear the original kernel if randomized Jason Yan
2019-09-20 9:45 ` [PATCH v7 09/12] powerpc/fsl_booke/kaslr: support nokaslr cmdline parameter Jason Yan
2019-09-20 9:45 ` [PATCH v7 10/12] powerpc/fsl_booke/kaslr: dump out kernel offset information on panic Jason Yan
2019-09-20 9:45 ` [PATCH v7 11/12] powerpc/fsl_booke/kaslr: export offset in VMCOREINFO ELF notes Jason Yan
2019-09-20 9:45 ` [PATCH v7 12/12] powerpc/fsl_booke/32: Document KASLR implementation Jason Yan
2019-09-24 5:52 ` Jason Yan [this message]
2019-10-09 6:10 ` [PATCH v7 00/12] implement KASLR for powerpc/fsl_booke/32 Jason Yan
2019-10-09 7:13 ` Scott Wood
2019-10-09 8:41 ` Jason Yan
2019-10-09 18:46 ` Scott Wood
2019-10-21 3:34 ` Jason Yan
2019-10-22 23:22 ` Scott Wood
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=9c2dd2a8-83f2-983c-383e-956e19a7803a@huawei.com \
--to=yanaijie@huawei.com \
--cc=benh@kernel.crashing.org \
--cc=christophe.leroy@c-s.fr \
--cc=diana.craciun@nxp.com \
--cc=jingxiangfeng@huawei.com \
--cc=keescook@chromium.org \
--cc=kernel-hardening@lists.openwall.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linuxppc-dev@lists.ozlabs.org \
--cc=mpe@ellerman.id.au \
--cc=npiggin@gmail.com \
--cc=oss@buserror.net \
--cc=paulus@samba.org \
--cc=thunder.leizhen@huawei.com \
--cc=wangkefeng.wang@huawei.com \
--cc=yebin10@huawei.com \
--cc=zhaohongjiang@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®