From: "Edgecombe, Rick P" <rick.p.edgecombe@intel.com>
To: "pbonzini@redhat.com" <pbonzini@redhat.com>
Cc: "seanjc@google.com" <seanjc@google.com>,
"Huang, Kai" <kai.huang@intel.com>,
"sagis@google.com" <sagis@google.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"Zhao, Yan Y" <yan.y.zhao@intel.com>,
"Aktas, Erdem" <erdemaktas@google.com>,
"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
"dmatlack@google.com" <dmatlack@google.com>,
"Yamahata, Isaku" <isaku.yamahata@intel.com>,
"isaku.yamahata@gmail.com" <isaku.yamahata@gmail.com>
Subject: Re: [PATCH v2 09/15] KVM: x86/tdp_mmu: Support mirror root for TDP MMU
Date: Mon, 10 Jun 2024 00:08:56 +0000 [thread overview]
Message-ID: <9c5f7aae312325c0e880baf411f956d4cce3c6d1.camel@intel.com> (raw)
In-Reply-To: <CABgObfb1L4SLGLOPwUKTBusN9bVKACJp7cyvgL8LPhGz0QTNAA@mail.gmail.com>
On Sat, 2024-06-08 at 11:13 +0200, Paolo Bonzini wrote:
> > I was not loving the amount of indirection here in the patch, but thought it
> > centralized the logic a bit better. This way seems good, given that the
> > actual
> > logic is not that complex.
>
> My proposed implementation is a bit TDX-specific though... Something
> like this is more agnostic, and it exploits nicely the difference
> between fault->addr and fault->gfn:
>
> if (!kvm_gfn_direct_mask(kvm) ||
> (gpa_to_gfn(fault->addr) & kvm_gfn_direct_mask(kvm))
> root_hpa = vcpu->arch.mmu->root.hpa;
> else
> root_hpa = vcpu->arch.mmu->mirror_root_hpa;
> return root_to_sp(root_hpa);
Agreed that this is less TDX specific and it means that this part of the generic
MMU code doesn't need to know that the mirror/direct matches to private vs
shared. I don't love that it has such a complicated conditional for the normal
VM case, though. Just for readability.
The previous versions checked kvm_gfn_shared_mask() more readily in various open
coded spots. In this v2 we tried to reduce this and instead always rely on
the "private" concept to switch between the roots in the generic code. I think
it's arguably a little easier to understand if we stick to a single way of
deciding which root to use.
But I don't feel like any of these solutions discussed is perfectly clean. So
I'm ok taking the benefits you prefer. I guess doing bitwise operations when
possible is kind of the KVM way, haha. :)
next prev parent reply other threads:[~2024-06-10 0:09 UTC|newest]
Thread overview: 58+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-05-30 21:06 [PATCH v2 00/15] TDX MMU prep series part 1 Rick Edgecombe
2024-05-30 21:07 ` [PATCH v2 01/15] KVM: Add member to struct kvm_gfn_range for target alias Rick Edgecombe
2024-06-06 15:55 ` Paolo Bonzini
2024-06-06 16:06 ` Edgecombe, Rick P
2024-05-30 21:07 ` [PATCH v2 02/15] KVM: x86: Add a VM type define for TDX Rick Edgecombe
2024-05-30 21:07 ` [PATCH v2 03/15] KVM: x86/mmu: Add a mirrored pointer to struct kvm_mmu_page Rick Edgecombe
2024-06-06 16:04 ` Paolo Bonzini
2024-06-06 16:12 ` Edgecombe, Rick P
2024-05-30 21:07 ` [PATCH v2 04/15] KVM: x86/mmu: Add a new mirror_pt member for union kvm_mmu_page_role Rick Edgecombe
2024-06-06 16:06 ` Paolo Bonzini
2024-06-06 16:15 ` Edgecombe, Rick P
2024-05-30 21:07 ` [PATCH v2 05/15] KVM: x86/mmu: Make kvm_tdp_mmu_alloc_root() return void Rick Edgecombe
2024-06-06 16:10 ` Paolo Bonzini
2024-05-30 21:07 ` [PATCH v2 06/15] KVM: x86/mmu: Support GFN direct mask Rick Edgecombe
2024-06-07 7:59 ` Paolo Bonzini
2024-06-07 18:39 ` Edgecombe, Rick P
2024-06-08 8:52 ` Paolo Bonzini
2024-06-08 9:08 ` Paolo Bonzini
2024-06-09 23:25 ` Edgecombe, Rick P
2024-06-07 8:00 ` Paolo Bonzini
2024-05-30 21:07 ` [PATCH v2 07/15] KVM: x86/tdp_mmu: Extract root invalid check from tdx_mmu_next_root() Rick Edgecombe
2024-05-30 21:07 ` [PATCH v2 08/15] KVM: x86/tdp_mmu: Introduce KVM MMU root types to specify page table type Rick Edgecombe
2024-06-07 8:10 ` Paolo Bonzini
2024-06-07 20:06 ` Edgecombe, Rick P
2024-05-30 21:07 ` [PATCH v2 09/15] KVM: x86/tdp_mmu: Support mirror root for TDP MMU Rick Edgecombe
2024-05-30 21:57 ` Edgecombe, Rick P
2024-06-07 8:27 ` Paolo Bonzini
2024-06-07 8:46 ` Paolo Bonzini
2024-06-07 20:27 ` Edgecombe, Rick P
2024-06-08 9:13 ` Paolo Bonzini
2024-06-10 0:08 ` Edgecombe, Rick P [this message]
2024-06-10 9:23 ` Paolo Bonzini
2024-06-10 16:00 ` Edgecombe, Rick P
2024-05-30 21:07 ` [PATCH v2 10/15] KVM: x86/tdp_mmu: Reflect building mirror page tables Rick Edgecombe
2024-06-07 10:10 ` Paolo Bonzini
2024-06-07 20:52 ` Edgecombe, Rick P
2024-05-30 21:07 ` [PATCH v2 11/15] KVM: x86/tdp_mmu: Reflect tearing down " Rick Edgecombe
2024-06-07 11:37 ` Paolo Bonzini
2024-06-07 21:46 ` Edgecombe, Rick P
2024-06-08 9:25 ` Paolo Bonzini
2024-06-12 18:39 ` Isaku Yamahata
2024-06-14 23:11 ` Edgecombe, Rick P
2024-05-30 21:07 ` [PATCH v2 12/15] KVM: x86/tdp_mmu: Take root types for kvm_tdp_mmu_invalidate_all_roots() Rick Edgecombe
2024-05-30 21:07 ` [PATCH v2 13/15] KVM: x86/tdp_mmu: Make mmu notifier callbacks to check kvm_process Rick Edgecombe
2024-06-07 8:56 ` Paolo Bonzini
2024-06-07 22:12 ` Edgecombe, Rick P
2024-06-08 9:15 ` Paolo Bonzini
2024-06-10 1:06 ` Edgecombe, Rick P
2024-05-30 21:07 ` [PATCH v2 14/15] KVM: x86/tdp_mmu: Invalidate correct roots Rick Edgecombe
2024-06-07 9:03 ` Paolo Bonzini
2024-06-07 22:31 ` Edgecombe, Rick P
2024-05-30 21:07 ` [PATCH v2 15/15] KVM: x86/tdp_mmu: Add a helper function to walk down the TDP MMU Rick Edgecombe
2024-06-07 9:31 ` Paolo Bonzini
2024-06-07 23:39 ` Edgecombe, Rick P
2024-06-08 9:17 ` Paolo Bonzini
2024-06-12 18:56 ` Isaku Yamahata
2024-06-07 11:39 ` [PATCH v2 00/15] TDX MMU prep series part 1 Paolo Bonzini
2024-06-07 22:54 ` Edgecombe, Rick P
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=9c5f7aae312325c0e880baf411f956d4cce3c6d1.camel@intel.com \
--to=rick.p.edgecombe@intel.com \
--cc=dmatlack@google.com \
--cc=erdemaktas@google.com \
--cc=isaku.yamahata@gmail.com \
--cc=isaku.yamahata@intel.com \
--cc=kai.huang@intel.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=pbonzini@redhat.com \
--cc=sagis@google.com \
--cc=seanjc@google.com \
--cc=yan.y.zhao@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®