From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753880AbcHXHVj (ORCPT ); Wed, 24 Aug 2016 03:21:39 -0400 Received: from mail-pf0-f195.google.com ([209.85.192.195]:34684 "EHLO mail-pf0-f195.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753294AbcHXHVg (ORCPT ); Wed, 24 Aug 2016 03:21:36 -0400 Subject: Re: [PATCH v2 3/4] gpu: drm: exynos_hdmi: Use consolidated function on binding DDC DT property To: Andrzej Hajda , David Airlie References: <1472005524-3489-1-git-send-email-woogyom.kim@gmail.com> <1472005524-3489-4-git-send-email-woogyom.kim@gmail.com> Cc: Kukjin Kim , Krzysztof Kozlowski , devicetree@vger.kernel.org, linux-samsung-soc@vger.kernel.org, Seung-Woo Kim , linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org, Kyungmin Park , Rob Herring , linux-arm-kernel@lists.infradead.org From: Milo Kim Message-ID: <9d5bf0cd-44f1-2028-7831-6828e43984d1@gmail.com> Date: Wed, 24 Aug 2016 16:21:28 +0900 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.2.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi Andrzej, On 08/24/2016 02:55 PM, Andrzej Hajda wrote: > This is mistake introduced by other patch, of_node_put should be called on > np, after calling of_find_i2c_adapter_by_node. You can fix it in your > patch as well. > I think you can move of_find_i2c_adapter_by_node also to this function and > rename it to sth like hdmi_get_ddc_adapter, this way you will enclose > whole logic > of getting resource into one function. Agree, let me prepare next patch-set. Thanks! Best regards, Milo