From: "Boris Petkov" <petkovbb@googlemail.com>
To: "Roel Kluin" <12o3l@tiscali.nl>
Cc: "Bartlomiej Zolnierkiewicz" <bzolnier@gmail.com>,
linux-ide@vger.kernel.org, lkml <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 3/6] IDE: ide-cd: fix test unsigned var < 0
Date: Thu, 17 Apr 2008 11:12:30 +0200 [thread overview]
Message-ID: <9ea470500804170212md8ce430p42b3c1787ba95631@mail.gmail.com> (raw)
In-Reply-To: <4806C952.6030102@tiscali.nl>
On Thu, Apr 17, 2008 at 5:51 AM, Roel Kluin <12o3l@tiscali.nl> wrote:
> Bartlomiej Zolnierkiewicz wrote:
> > Hi,
> >
> > On Wednesday 16 April 2008, Roel Kluin wrote:
> >> Is this the right fix in this case?
> >
> > Yes, but it seems that 'valid' is only written to
> > so it may be as well removed completely.
> >
> > Care to update the patch?
> >
> > Thanks,
> > Bart
>
> how about this?
>
> Roel
>
> ---
> Clean up cdrom_analyze_sense_data()
>
>
> Signed-off-by: Roel Kluin <12o3l@tiscali.nl>
> ---
> diff --git a/drivers/ide/ide-cd.c b/drivers/ide/ide-cd.c
> index a60f5df..a5f3beb 100644
>
> --- a/drivers/ide/ide-cd.c
> +++ b/drivers/ide/ide-cd.c
> @@ -143,8 +143,6 @@ void cdrom_analyze_sense_data(ide_drive_t *drive,
> struct request_sense *sense)
> {
> unsigned long sector;
> - unsigned long bio_sectors;
> - unsigned long valid;
> struct cdrom_info *info = drive->driver_data;
>
> if (!cdrom_log_sense(drive, failed_command, sense))
> @@ -174,13 +172,9 @@ void cdrom_analyze_sense_data(ide_drive_t *drive,
> (sense->information[2] << 8) |
> (sense->information[3]);
>
> - bio_sectors = bio_sectors(failed_command->bio);
> - if (bio_sectors < 4)
> - bio_sectors = 4;
> if (drive->queue->hardsect_size == 2048)
> sector <<= 2; /* Device sector size is 2K */
> - sector &= ~(bio_sectors -1);
>
> - valid = (sector - failed_command->sector) << 9;
> + sector &= ~(max(bio_sectors(failed_command->bio) - 1, 3));
Well, i don't think that this "optimization" makes the code more readable.
Besides, gcc does this anyway. Poor are only those who have to stare at it for
a couple of minutes just to understand what it says. Still, i don't object to
it completely and the "valid"-var can go. I'd rather keep the "unsigned long
bio_sectors;" part and do something of the likes of:
bio_sectors = bio_sectors(failed_command->bio);
(remove the "if (bio_sectors < 4)"-test)
... and later...
sector &= ~(max(bio_sectors - 1, 3));
which is, IMO, more readable.
Roel, would you redo your patch please? Thanks.
--
Regards/Gruß,
Boris
next prev parent reply other threads:[~2008-04-17 9:31 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-04-16 2:06 Roel Kluin
2008-04-16 22:40 ` Bartlomiej Zolnierkiewicz
2008-04-17 3:51 ` Roel Kluin
2008-04-17 9:12 ` Boris Petkov [this message]
2008-04-17 11:04 ` Roel Kluin
2008-04-17 12:01 ` Boris Petkov
2008-04-27 18:32 ` Bartlomiej Zolnierkiewicz
2008-04-27 18:32 ` Bartlomiej Zolnierkiewicz
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=9ea470500804170212md8ce430p42b3c1787ba95631@mail.gmail.com \
--to=petkovbb@googlemail.com \
--cc=12o3l@tiscali.nl \
--cc=bzolnier@gmail.com \
--cc=linux-ide@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=petkovbb@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®