[PATCH] RISC-V: Fix PCI I/O port addressing for MMU-less configurations
2025-04-11 5:41 UTC (2+ messages)
[PATCH -v3 00/53] Simplify, reorganize and clean up the x86 text-patching code (alternative.c)
2025-04-11 5:40 UTC (46+ messages)
` [PATCH 01/53] x86/alternatives: Improve code-patching scalability by removing false sharing in poke_int3_handler()
` [PATCH 02/53] x86/alternatives: Document the text_poke_bp_batch() synchronization rules a bit more
` [PATCH 03/53] x86/alternatives: Rename 'struct bp_patching_desc' to 'struct int3_patching_desc'
` [PATCH 04/53] x86/alternatives: Rename 'bp_refs' to 'int3_refs'
` [PATCH 05/53] x86/alternatives: Rename 'text_poke_bp_batch()' to 'smp_text_poke_batch_process()'
` [PATCH 06/53] x86/alternatives: Rename 'text_poke_bp()' to 'smp_text_poke_single()'
` [PATCH 07/53] x86/alternatives: Rename 'poke_int3_handler()' to 'smp_text_poke_int3_handler()'
` [PATCH 08/53] x86/alternatives: Rename 'poking_mm' to 'text_poke_mm'
` [PATCH 09/53] x86/alternatives: Rename 'poking_addr' to 'text_poke_mm_addr'
` [PATCH 10/53] x86/alternatives: Rename 'bp_desc' to 'int3_desc'
` [PATCH 11/53] x86/alternatives: Remove duplicate 'text_poke_early()' prototype
` [PATCH 12/53] x86/alternatives: Update comments in int3_emulate_push()
` [PATCH 13/53] x86/alternatives: Remove the confusing, inaccurate & unnecessary 'temp_mm_state_t' abstraction
` [PATCH 14/53] x86/alternatives: Rename 'text_poke_flush()' to 'smp_text_poke_batch_flush()'
` [PATCH 15/53] x86/alternatives: Rename 'text_poke_finish()' to 'smp_text_poke_batch_finish()'
` [PATCH 16/53] x86/alternatives: Rename 'text_poke_queue()' to 'smp_text_poke_batch_add()'
` [PATCH 17/53] x86/alternatives: Rename 'text_poke_loc_init()' to 'text_poke_int3_loc_init()'
` [PATCH 18/53] x86/alternatives: Rename 'struct text_poke_loc' to 'struct smp_text_poke_loc'
` [PATCH 19/53] x86/alternatives: Rename 'struct int3_patching_desc' to 'struct text_poke_int3_vec'
` [PATCH 20/53] x86/alternatives: Rename 'int3_desc' to 'int3_vec'
` [PATCH 21/53] x86/alternatives: Add text_mutex) assert to smp_text_poke_batch_flush()
` [PATCH 22/53] x86/alternatives: Use non-inverted logic instead of 'tp_order_fail()'
` [PATCH 23/53] x86/alternatives: Remove the 'addr == NULL means forced-flush' hack from smp_text_poke_batch_finish()/smp_text_poke_batch_flush()/text_poke_addr_ordered()
` [PATCH 24/53] x86/alternatives: Simplify smp_text_poke_single() by using tp_vec and existing APIs
` [PATCH 25/53] x86/alternatives: Assert that smp_text_poke_int3_handler() can only ever handle 'tp_vec[]' based requests
` [PATCH 26/53] x86/alternatives: Assert input parameters in smp_text_poke_batch_process()
` [PATCH 27/53] x86/alternatives: Introduce 'struct smp_text_poke_array' and move tp_vec and tp_vec_nr to it
` [PATCH 28/53] x86/alternatives: Remove the tp_vec indirection
` [PATCH 29/53] x86/alternatives: Rename 'try_get_desc()' to 'try_get_text_poke_array()'
` [PATCH 30/53] x86/alternatives: Rename 'put_desc()' to 'put_text_poke_array()'
` [PATCH 31/53] x86/alternatives: Simplify try_get_text_poke_array()
` [PATCH 32/53] x86/alternatives: Simplify smp_text_poke_int3_handler()
` [PATCH 33/53] x86/alternatives: Simplify smp_text_poke_batch_process()
` [PATCH 34/53] x86/alternatives: Rename 'int3_refs' to 'text_poke_array_refs'
` [PATCH 35/53] x86/alternatives: Move the text_poke_array manipulation into text_poke_int3_loc_init() and rename it to __smp_text_poke_batch_add()
` [PATCH 36/53] x86/alternatives: Remove the mixed-patching restriction on smp_text_poke_single()
` [PATCH 37/53] x86/alternatives: Document 'smp_text_poke_single()'
` [PATCH 38/53] x86/alternatives: Add documentation for smp_text_poke_batch_add()
` [PATCH 39/53] x86/alternatives: Move text_poke_array completion from smp_text_poke_batch_finish() and smp_text_poke_batch_flush() to smp_text_poke_batch_process()
` [PATCH 40/53] x86/alternatives: Rename 'text_poke_sync()' to 'smp_text_poke_sync_each_cpu()'
` [PATCH 41/53] x86/alternatives: Simplify text_poke_addr_ordered()
` [PATCH 42/53] x86/alternatives: Constify text_poke_addr()
` [PATCH 43/53] x86/alternatives: Simplify and clean up patch_cmp()
` [PATCH 44/53] x86/alternatives: Standardize on 'tpl' local variable names for 'struct smp_text_poke_loc *'
` [PATCH 45/53] x86/alternatives: Rename 'TP_ARRAY_NR_ENTRIES_MAX' to 'TEXT_POKE_ARRAY_MAX'
[RESEND v2] mmc: mtk-sd: Add condition to enable 'single' burst type
2025-04-11 5:40 UTC
[PATCH V1] PCI: tegra194: Add support for PCIe RC & EP in Tegra234 Platforms
2025-04-11 5:40 UTC (3+ messages)
` [PATCH V2] PCI: dwc: tegra194: Broaden architecture dependency
[PATCH v6 00/14] kexec: introduce Kexec HandOver (KHO)
2025-04-11 5:37 UTC (15+ messages)
` [PATCH v6 01/14] memblock: add MEMBLOCK_RSRV_KERN flag
` [PATCH v6 02/14] memblock: Add support for scratch memory
` [PATCH v6 03/14] memblock: introduce memmap_init_kho_scratch()
` [PATCH v6 04/14] kexec: add Kexec HandOver (KHO) generation helpers
` [PATCH v6 05/14] kexec: add KHO parsing support
` [PATCH v6 06/14] kexec: enable KHO support for memory preservation
` [PATCH v6 07/14] kexec: add KHO support to kexec file loads
` [PATCH v6 08/14] kexec: add config option for KHO
` [PATCH v6 09/14] arm64: add KHO support
` [PATCH v6 10/14] x86/setup: use memblock_reserve_kern for memory used by kernel
` [PATCH v6 11/14] x86: add KHO support
` [PATCH v6 12/14] memblock: add KHO support for reserve_mem
` [PATCH v6 13/14] Documentation: add documentation for KHO
` [PATCH v6 14/14] Documentation: KHO: Add memblock bindings
[PATCH v3 0/2] New rcutorture candidate commits for 6.16
2025-04-11 5:36 UTC (7+ messages)
` [PATCH v3 1/2] rcutorture: Perform more frequent testing of ->gpwrap
` [v3,1/2] "
[PATCH RFC 0/6] Add support to read the restart reason from IMEM
2025-04-11 5:34 UTC (15+ messages)
` [PATCH RFC 1/6] dt-bindings: sram: qcom,imem: Document IPQ5424 compatible
` [PATCH RFC 2/6] arm64: dts: qcom: ipq5424: Add the IMEM node
` [PATCH RFC 3/6] dt-bindings: watchdog: Add Qualcomm restart reason binding
` [PATCH RFC 5/6] watchdog: qcom-wdt: add support to read the restart reason from IMEM
[PATCH v3 0/1] net/mlx5: Fix null-ptr-deref in TTC table creation
2025-04-11 5:34 UTC (3+ messages)
` [PATCH v3 1/1] net/mlx5: Fix null-ptr-deref in mlx5_create_{inner_,}ttc_table()
[PATCH net-next v6 00/12] Convert LAN78xx to PHYLINK
2025-04-11 5:33 UTC (3+ messages)
` [PATCH net-next v6 08/12] net: usb: lan78xx: Convert to PHYLINK for improved PHY and MAC management
[PATCH v4 0/4] mm/gup: Minor fix, cleanup and improvements
2025-04-11 5:32 UTC (4+ messages)
` [PATCH v4 1/4] mm/gup: fix wrongly calculated returned value in fault_in_safe_writeable()
[PATCH] usb: quirks: Add quirk to prefer vendor-specific configuration
2025-04-11 5:25 UTC (3+ messages)
[PATCH v1] perf lock: Add --duration-filter option
2025-04-11 5:24 UTC
[PATCH] Removing deprecated strncpy()
2025-04-11 5:22 UTC (2+ messages)
[PATCH v2 1/3] dt-bindings: accel: add device tree for AMD PKI accelerator
2025-04-11 5:17 UTC (5+ messages)
` [PATCH v2 2/3] accel/amdpk: add driver "
[PATCH net-next] net: ngbe: fix memory leak in ngbe_probe() error path
2025-04-11 5:14 UTC (3+ messages)
[PATCH] Removing deprecated strncpy()
2025-04-11 5:12 UTC (3+ messages)
` replacement of strncpy in ticp_node_get_linkname()
[PATCH] ASoC: wm_adsp: Use vmemdup_user() instead of open-coding
2025-04-11 5:06 UTC (2+ messages)
[PATCH] memcg: decouple memcg_hotplug_cpu_dead from stock_lock
2025-04-11 5:06 UTC (2+ messages)
[PATCH] media: Fix invalid link creation when source entity has 0 pads
2025-04-11 5:05 UTC (9+ messages)
[PATCH] drivers/base/memory: Avoid overhead from for_each_present_section_nr()
2025-04-11 5:04 UTC (6+ messages)
[PATCH v2 0/3] Restrict devmem for confidential VMs
2025-04-11 4:59 UTC (6+ messages)
` [PATCH v2 1/3] x86/devmem: Remove duplicate range_is_allowed() definition
` [PATCH v2 2/3] devmem: Block mmap access when read/write access is restricted
` [PATCH v2 3/3] x86/devmem: Restrict /dev/mem access for potentially unaccepted memory by default
[RFC PATCH 0/9] rv: Add monitors to validate task switch
2025-04-11 4:52 UTC (3+ messages)
` [RFC PATCH 7/9] rv: Retry when da monitor detects race conditions
[PATCH v6 00/11] Add R5F and C7xv device nodes
2025-04-11 4:50 UTC (16+ messages)
` [PATCH v6 06/11] arm64: dts: ti: k3-am62a7-sk: Enable IPC with remote processors
[PATCH] iommu/arm-smmu-v3: Allow stream table to have nodes with the same ID
2025-04-11 4:47 UTC
[PATCH] LoongArch: Enhance robust of kprobe
2025-04-11 4:46 UTC (4+ messages)
[RFC PATCH] net/smc: Consider using kfree_sensitive() to free cpu_addr
2025-04-11 4:44 UTC
[PATCHv4] platform/x86: ideapad-laptop: added support for some new buttons
2025-04-11 4:41 UTC (2+ messages)
[PATCH 6/7] PCI: cadence: Add callback functions for Root Port and EP controller
2025-04-11 4:26 UTC (3+ messages)
[PATCH 4/7] PCI: cadence: Add support for PCIe Endpoint HPA controllers
2025-04-11 4:23 UTC (3+ messages)
[PATCH 2/7] PCI: cadence: Add header support for PCIe next generation controllers
2025-04-11 4:16 UTC (3+ messages)
[PATCH 0/7] Enhance the PCIe controller driver
2025-04-11 4:10 UTC (5+ messages)
[PATCH V3] netfilter: netns nf_conntrack: per-netns net.netfilter.nf_conntrack_max sysctl
2025-04-11 4:09 UTC (2+ messages)
[PATCH v5 09/16] kexec: enable KHO support for memory preservation
2025-04-11 4:02 UTC (2+ messages)
[PATCH v3 0/5] tsm-mr: Unified Measurement Register ABI for TVMs
2025-04-11 4:01 UTC (4+ messages)
` [PATCH v3 1/5] tsm-mr: Add TVM Measurement Register support
[PATCH] iommu: Clear IOMMU DMA ops when detaching a device from its IOMMU group
2025-04-11 4:00 UTC (3+ messages)
[PATCH v7 0/6] bugfix some driver issues
2025-04-11 3:59 UTC (7+ messages)
` [PATCH v7 1/6] hisi_acc_vfio_pci: fix XQE dma address error
` [PATCH v7 2/6] hisi_acc_vfio_pci: add eq and aeq interruption restore
` [PATCH v7 3/6] hisi_acc_vfio_pci: bugfix cache write-back issue
` [PATCH v7 4/6] hisi_acc_vfio_pci: bugfix the problem of uninstalling driver
` [PATCH v7 5/6] hisi_acc_vfio_pci: bugfix live migration function without VF device driver
` [PATCH v7 6/6] hisi_acc_vfio_pci: update function return values
[PATCH] iommu: Clear iommu-dma ops on cleanup
2025-04-11 3:55 UTC (3+ messages)
[PATCH v6 0/6] usb: dwc3: qcom: Flatten dwc3 structure
2025-04-11 3:50 UTC (7+ messages)
` [PATCH v6 1/6] usb: dwc3: qcom: Snapshot driver for backwards compatibilty
` [PATCH v6 2/6] dt-bindings: usb: Introduce qcom,snps-dwc3
` [PATCH v6 3/6] usb: dwc3: core: Expose core driver as library
` [PATCH v6 4/6] usb: dwc3: core: Don't touch resets and clocks
` [PATCH v6 5/6] usb: dwc3: qcom: Don't rely on drvdata during probe
` [PATCH v6 6/6] usb: dwc3: qcom: Transition to flattened model
[PATCH v5 12/16] arm64: add KHO support
2025-04-11 3:47 UTC (2+ messages)
[PATCH 05/11] vt: update ucs_width.c using gen_ucs_width.py
2025-04-11 3:47 UTC (2+ messages)
[PATCH] btrfs: use BTRFS_PATH_AUTO_FREE in btrfs_truncate_inode_items()
2025-04-11 3:44 UTC
[PATCH 0/3] fbdev: Add deferred I/O support for contiguous kernel memory framebuffers
2025-04-11 3:40 UTC (6+ messages)
` [PATCH 1/3] mm: Export vmf_insert_mixed_mkwrite()
[PATCH v2] bus: mhi: host: don't free bhie tables during suspend/hibernation
2025-04-11 3:37 UTC (2+ messages)
[git pull] drm fixes for 6.15-rc2
2025-04-11 3:37 UTC (2+ messages)
[PATCH v10 00/11] arm64: support poll_idle()
2025-04-11 3:32 UTC (3+ messages)
` [PATCH v10 10/11] arm64: idle: export arch_cpu_idle()
[PATCH v1] ASoC: tas2781: Swap channel for SPI projects
2025-04-11 3:29 UTC
[GIT PULL] bcachefs fixes for 6.15-rc2
2025-04-11 3:27 UTC (2+ messages)
[PATCH] usb: common: usb-conn-gpio: use a unique names for usb connector devices
2025-04-11 3:27 UTC
[PATCH ath-next v2 0/2] wifi: ath12k: handle scan vdev consistently
2025-04-11 3:16 UTC (3+ messages)
` [PATCH ath-next v2 1/2] wifi: ath12k: handle scan link during vdev create
` [PATCH ath-next v2 2/2] wifi: ath12k: Use scan link ID 15 for all scan operations
[PATCH ath-next 0/2] wifi: ath12k: handle scan vdev consistently
2025-04-11 3:16 UTC (4+ messages)
` [PATCH ath-next 1/2] wifi: ath12k: handle scan link during vdev create
` [PATCH ath-next 2/2] wifi: ath12k: Use scan link ID 15 for all scan operations
[PATCH] mm: huge_memory: add folio_mark_accessed() when zapping file THP
2025-04-11 3:14 UTC (4+ messages)
[Patch v4 net-next 0/3] Add support for mdb offload failure notification
2025-04-11 3:13 UTC (3+ messages)
` [Patch v4 net-next 1/3] net: bridge: mcast: Add offload failed mdb flag
[PATCH] init: Update help for CONFIG_KERNEL_LZO
2025-04-11 3:13 UTC
[PATCH v7 2/3] mm/mempolicy: Prepare weighted interleave sysfs for memory hotplug
2025-04-11 3:11 UTC (3+ messages)
[PATCH net-next v25 00/23] Introducing OpenVPN Data Channel Offload
2025-04-11 3:07 UTC (9+ messages)
` [PATCH net-next v25 01/23] net: introduce OpenVPN Data Channel Offload (ovpn)
` [PATCH net-next v25 02/23] ovpn: add basic netlink support
` [PATCH net-next v25 04/23] ovpn: keep carrier always on for MP interfaces
` [PATCH net-next v25 07/23] ovpn: implement basic TX path (UDP)
[PATCH v2 00/15] Add MediaTek SoC DRM support for MT8196
2025-04-11 3:07 UTC (3+ messages)
` [PATCH v2 13/15] drm/mediatek: add ovlsys_adaptor "
[syzbot] [wireless?] divide error in mac80211_hwsim_link_info_changed (2)
2025-04-11 3:06 UTC
[PATCH v4 0/2] perf: Fujitsu: Add Uncore MAC/PCI PMU driver
2025-04-11 2:56 UTC (5+ messages)
` [PATCH v4 1/2] perf: Fujitsu: Add the Uncore MAC "
[PATCH v2 00/12] Enable jpeg enc & dec multi-hardwares for MT8196
2025-04-11 2:54 UTC (7+ messages)
` [PATCH v2 01/12] dt-bindings: mediatek: Add mediatek, mt8196-jpgdec compatible
` [PATCH v2 02/12] dt-bindings: mediatek: Add mediatek, mt8196-jpgenc compatible
[PATCH v3 0/7] Provides support for Trigger Generation Unit
2025-04-11 2:51 UTC (8+ messages)
` [PATCH v3 4/7] coresight-tgu: Add TGU decode support
` [PATCH v3 7/7] coresight-tgu: add reset node to initialize
[Bug Report] A compilation failure occurs when landlock and RANDSTRUCT are combined with GCC 14.2.0
2025-04-11 2:50 UTC (4+ messages)
[PATCH] LoongArch: Handle fp, lsx, lasx and lbt assembly symbols
2025-04-11 2:47 UTC (3+ messages)
[PATCH v2] RISC-V: vDSO: Wire up getrandom() vDSO implementation
2025-04-11 2:46 UTC
[PATCH] mmc: esdhc-imx: convert to modern PM_OPS
2025-04-11 2:45 UTC (2+ messages)
[PATCH] net: Move specific fragmented packet to slow_path instead of dropping it
2025-04-11 2:43 UTC (3+ messages)
` 答复: "
[PATCH v2] scsi: ufs: mcq: Add NULL check in ufshcd_mcq_abort()
2025-04-11 2:41 UTC (2+ messages)
[PATCH v4] fs/namespace: defer RCU sync for MNT_DETACH umount
2025-04-11 2:36 UTC (8+ messages)
[RFC PATCH] mm: huge_memory: add folio_mark_accessed() when zapping file THP
2025-04-11 2:32 UTC (8+ messages)
[PATCH 1/2] erofs: add __packed annotation to union(__le16..)
2025-04-11 2:28 UTC (5+ messages)
[PATCH 5.10.y] powerpc/rtas: Prevent Spectre v1 gadget construction in sys_rtas()
2025-04-11 2:26 UTC
[PATCH] accel/habanalabs:fix typos found in command_submission.c
2025-04-11 2:23 UTC
[PATCH net-next v4 0/2] tcp: add a new TW_PAWS drop reason
2025-04-11 2:20 UTC (2+ messages)
[PATCH net-next v3 0/2] trace: add tracepoint for tcp_sendmsg_locked()
2025-04-11 2:20 UTC (2+ messages)
[PATCH v2] usbnet: asix AX88772: leave the carrier control to phylink
2025-04-11 2:20 UTC (2+ messages)
[PATCH -next] drm/sched: Remove duplicate linux/atomic.h header
2025-04-11 2:17 UTC
[PATCH v3] mm: pcp: increase pcp->free_count threshold to trigger free_high
2025-04-11 2:16 UTC (2+ messages)
[PATCH v4 0/3] Driver for the Apple SPMI controller
2025-04-11 2:03 UTC (2+ messages)
[PATCH v9 drm-dp 0/9] Add HPD, getting EDID, colorbar features in DP function
2025-04-11 1:58 UTC (2+ messages)
[PATCH 0/2] TDX attestation support
2025-04-11 1:42 UTC (3+ messages)
[PATCH] usb: cdnsp: Fix issue with resuming from L1
2025-04-11 1:41 UTC (2+ messages)
[PATCH RFC v2 00/14] md: introduce a new lockless bitmap
2025-04-11 1:36 UTC (7+ messages)
[BUG] CAAM refcount warnings
2025-04-11 1:36 UTC (7+ messages)
` [PATCH] crypto: caam/qi - Fix drv_ctx refcount bug
` [PATCH] crypto: api - Allow delayed algorithm destruction
[PATCH 1/2] dt-bindings: riscv: starfive: add Orange Pi RV board compatible
2025-04-11 1:29 UTC (4+ messages)
` [PATCH 2/2] riscv: dts: starfive: add DT for Orange Pi RV
[PATCH v2] PM: EM: Fix potential division-by-zero error in em_compute_costs()
2025-04-11 1:28 UTC
[RFC][PATCH] panic: lib: Add TAINT for FAULT_INJECTION
2025-04-11 1:25 UTC (3+ messages)
[syzbot] [ntfs3?] BUG: unable to handle kernel NULL pointer dereference in generic_file_read_iter
2025-04-11 1:24 UTC (2+ messages)
` [PATCH] fs/ntfs3: Add missing direct_IO in ntfs_aops_cmpr
[PATCH 0/6] Add support for A523 Thermal system
2025-04-11 1:21 UTC (3+ messages)
` [PATCH 6/6] dt-bindings: thermal: sun8i: Add A523 THS0/1 controllers
[syzbot] [ntfs3?] BUG: unable to handle kernel NULL pointer dereference in generic_file_read_iter
2025-04-11 1:15 UTC
[PATCH] PM: EM: Fix potential division-by-zero error in em_compute_costs()
2025-04-11 1:14 UTC (3+ messages)
[PATCH 0/2] media: synopsys: hdmirx: Report frame drops
2025-04-11 1:13 UTC (5+ messages)
` [PATCH 1/2] media: synopsys: hdmirx: Renamed frame_idx to sequence
` [PATCH 2/2] media: synopsys: hdmirx: Count dropped frames
[PATCH 0/4] net: fix bugs and error handling in qinheng ch9200 driver and mii interface
2025-04-11 1:12 UTC (5+ messages)
` [PATCH 1/4] net: fix uninitialised access in mii_nway_restart()
[PATCH 0/7] soc: aspeed: lpc-snoop: Miscellaneous fixes
2025-04-11 1:08 UTC (2+ messages)
` [PATCH 7/7] soc: aspeed: lpc-snoop: Lift channel config to const structs
page: next (older) | prev (newer) | latest
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®