[PATCH v5 00/68] struct filename series
2026-01-14 4:32 UTC (39+ messages)
` [PATCH v5 01/68] init_mknod(): turn into a trivial wrapper for do_mknodat()
` [PATCH v5 02/68] init_mkdir(): turn into a trivial wrapper for do_mkdirat()
` [PATCH v5 03/68] init_symlink(): turn into a trivial wrapper for do_symlinkat()
` [PATCH v5 04/68] init_link(): turn into a trivial wrapper for do_linkat()
` [PATCH v5 05/68] allow to use CLASS() for struct filename *
` [PATCH v5 06/68] do_faccessat(): import pathname only once
` [PATCH v5 07/68] do_fchmodat(): "
` [PATCH v5 08/68] do_fchownat(): "
` [PATCH v5 09/68] do_utimes_path(): "
` [PATCH v5 10/68] chdir(2): "
` [PATCH v5 11/68] chroot(2): "
` [PATCH v5 12/68] user_statfs(): "
` [PATCH v5 13/68] do_sys_truncate(): "
` [PATCH v5 14/68] do_readlinkat(): "
` [PATCH v5 15/68] get rid of audit_reusename()
` [PATCH v5 17/68] getname_flags() massage, part 1
` [PATCH v5 18/68] getname_flags() massage, part 2
` [PATCH v5 19/68] struct filename: use names_cachep only for getname() and friends
` [PATCH v5 22/68] switch __getname_maybe_null() to CLASS(filename_flags)
` [PATCH v5 28/68] ksmbd_vfs_path_lookup(): vfs_path_parent_lookup() accepts ERR_PTR() as name
` [PATCH v5 29/68] ksmbd_vfs_rename(): "
` [PATCH v5 30/68] do_filp_open(): DTRT when getting ERR_PTR() as pathname
` [PATCH v5 31/68] rename do_filp_open() to do_file_open()
` [PATCH v5 32/68] do_sys_openat2(): get rid of useless check, switch to CLASS(filename)
` [PATCH v5 34/68] simplify the callers of do_open_execat()
` [PATCH v5 35/68] simplify the callers of alloc_bprm()
` [PATCH v5 36/68] execve: fold {compat_,}do_execve{,at}() into their sole callers
` [PATCH v5 37/68] do_execveat_common(): don't consume filename reference
` [PATCH v5 38/68] switch {alloc,free}_bprm() to CLASS()
` [PATCH v5 39/68] non-consuming variant of do_renameat2()
` [PATCH v5 40/68] non-consuming variant of do_linkat()
` [PATCH v5 41/68] non-consuming variant of do_symlinkat()
` [PATCH v5 42/68] non-consuming variant of do_mkdirat()
` [PATCH v5 43/68] non-consuming variant of do_mknodat()
` [PATCH v5 44/68] non-consuming variants of do_{unlinkat,rmdir}()
` [PATCH v5 45/68] file_[gs]etattr(2): switch to CLASS(filename_maybe_null)
` [PATCH v5 46/68] mount_setattr(2): don't mess with LOOKUP_EMPTY
` [PATCH v5 47/68] do_open_execat(): don't care about LOOKUP_EMPTY
[PATCH] arm64: dts: qcom: merge duplicate references to pmc8380_3_gpios
2026-01-14 4:30 UTC
[PATCH] alloc_tag: remove sysctl prefix from mem_profiling boot parameter
2026-01-14 4:29 UTC (2+ messages)
[tip:x86/cleanups] BUILD SUCCESS 8a4e92b3260ae7664d0531e1b42c38d336e7717a
2026-01-14 4:20 UTC
[PATCH linux-next] mm/madvise: prefer VMA lock for MADV_REMOVE
2026-01-14 4:19 UTC (3+ messages)
[PATCHv2 1/2] zsmalloc: use actual object size to detect spans
2026-01-14 4:17 UTC (2+ messages)
[PATCH v4 0/4] arm64: dts: qcom: Introduce Glymur SoC dtsi and Glymur CRD dts
2026-01-14 4:17 UTC (3+ messages)
` [PATCH v4 3/4] arm64: dts: qcom: Introduce Glymur base dtsi
linux-next: build warning after merge of the slab tree
2026-01-14 4:13 UTC
[PATCH bpf-next v1 00/10] bpf: Kernel functions with KF_IMPLICIT_ARGS
2026-01-14 4:08 UTC (11+ messages)
` [PATCH bpf-next v1 03/10] bpf: Verifier support for KF_IMPLICIT_ARGS
[PATCH] cpuhp: Expedite synchronize_rcu during CPU hotplug operations
2026-01-14 4:00 UTC (13+ messages)
[PATCH v9 00/13] cxl: ACPI PRM Address Translation Support and AMD Zen5 enablement
2026-01-14 3:59 UTC (21+ messages)
` [PATCH v9 01/13] cxl/region: Rename misleading variable name @hpa to @hpa_range
` [PATCH v9 02/13] cxl/region: Store root decoder in struct cxl_region
` [PATCH v9 03/13] cxl/region: Store HPA range "
` [PATCH v9 04/13] cxl: Simplify cxl_root_ops allocation and handling
` [PATCH v9 05/13] cxl/region: Separate region parameter setup and region construction
` [PATCH v9 06/13] cxl/region: Add @hpa_range argument to function cxl_calc_interleave_pos()
` [PATCH v9 07/13] cxl/region: Use region data to get the root decoder
` [PATCH v9 08/13] cxl: Introduce callback for HPA address ranges translation
` [PATCH v9 12/13] cxl/region: Factor out code into cxl_region_setup_poison()
` [PATCH v9 13/13] cxl: Disable HPA/SPA translation handlers for Normalized Addressing
[PATCH 0/2] arm64: dts: amlogic: s4: mmc clock fixups
2026-01-14 3:58 UTC (6+ messages)
` [PATCH 1/2] arm64: dts: amlogic: s4: assign mmc b clock to 24MHz
` 回复: "
` [PATCH 2/2] arm64: dts: amlogic: s4: fix mmc clock assignment
` 回复: "
[PATCH v7 0/6] PCI: endpoint: BAR subrange mapping support
2026-01-14 3:54 UTC (9+ messages)
` [PATCH v7 2/6] PCI: endpoint: Add "
` [PATCH v7 3/6] PCI: dwc: Allow glue drivers to return mutable EPC features
` [PATCH v7 5/6] PCI: dwc: ep: Support BAR subrange inbound mapping via Address Match Mode iATU
[PATCH v2 0/9] remoteproc: qcom_q6v5_wcss: add native ipq9574 support
2026-01-14 3:54 UTC (3+ messages)
[PATCH v7 0/4] Align atomic storage
2026-01-14 3:53 UTC (4+ messages)
` [PATCH v7 3/4] atomic: Add alignment check to instrumented atomic operations
[PATCH] KVM: VMX: Add quirk to allow L1 to set FREEZE_IN_SMM in vmcs12
2026-01-14 3:47 UTC (3+ messages)
[PATCH v3 00/14] Add support for handling PCIe M.2 Key E connectors in devicetree
2026-01-14 3:40 UTC (4+ messages)
` [PATCH v3 03/14] software node: Implement device_get_match_data fwnode callback
[PATCH net-next, v8] net: mana: Implement ndo_tx_timeout and serialize queue resets per port
2026-01-14 3:40 UTC (2+ messages)
[PATCH net-next v8 0/9] Add support for providers with large rx buffer
2026-01-14 3:36 UTC (3+ messages)
` [PATCH net-next v8 7/9] eth: bnxt: support qcfg provided rx page size
[PATCH bpf-next v9 00/11] bpf: fsession support
2026-01-14 3:35 UTC (30+ messages)
` [PATCH bpf-next v9 01/11] bpf: add "
` [PATCH bpf-next v9 02/11] bpf: use last 8-bits for the nr_args in trampoline
` [PATCH bpf-next v9 03/11] bpf: change prototype of bpf_session_{cookie,is_return}
` [PATCH bpf-next v9 04/11] bpf: support fsession for bpf_session_is_return
` [PATCH bpf-next v9 05/11] bpf: support fsession for bpf_session_cookie
` [PATCH bpf-next v9 06/11] bpf,x86: introduce emit_store_stack_imm64() for trampoline
` [PATCH bpf-next v9 07/11] bpf,x86: add fsession support for x86_64
` [PATCH bpf-next v9 08/11] libbpf: add fsession support
[PATCH v1] checkpatch: Warn about sign offs if there's an accidental patch separator
2026-01-14 3:33 UTC (10+ messages)
[PATCH RFC v2 00/20] slab: replace cpu (partial) slabs with sheaves
2026-01-14 3:31 UTC (3+ messages)
` [PATCH RFC v2 13/20] slab: simplify kmalloc_nolock()
[PATCH 07/11] Docs/admin-guide/mm/damon/lru_sort: document filter_young_pages
2026-01-14 3:25 UTC (2+ messages)
[PATCH 00/31] gpu: nova-core: firmware: Hopper/Blackwell support
2026-01-14 3:18 UTC (13+ messages)
` [PATCH 01/31] gpu: nova-core: print FB sizes, along with ranges
` [PATCH 04/31] nova-core: factor .fwsignature* selection into a new get_gsp_sigs_section()
` [PATCH 07/31] gpu: nova-core: set DMA mask width based on GPU architecture
` [PATCH 09/31] gpu: nova-core: factor out a section_name_eq() function
[PATCH v1 0/1] mm: Fix OOM killer and proc stats inaccuracy on large many-core systems
2026-01-14 3:18 UTC (3+ messages)
` [PATCH v1 1/1] "
[PATCH net-next v9 0/5] net: devmem: improve cpu cost of RX token management
2026-01-14 3:18 UTC (8+ messages)
` [PATCH net-next v9 3/5] net: devmem: implement autorelease "
[PATCH v3 0/4] Initial patch set for PURWA-IOT-EVK
2026-01-14 3:14 UTC (5+ messages)
` [PATCH v3 4/4] arm64: dts: qcom: Add base PURWA-IOT-EVK board
[RFC PATCH 0/5] md/raid1: introduce a new sync action to repair badblocks
2026-01-14 3:11 UTC (3+ messages)
` [RFC PATCH 5/5] md/raid1: introduce rectify "
[PATCH] KVM: VMX: Don't register posted interrupt wakeup handler if alloc_kvm_area() fails
2026-01-14 3:11 UTC (3+ messages)
[PATCH net-next] net: hv_netvsc: reject RSS hash key programming without RX indirection table
2026-01-14 3:10 UTC (2+ messages)
[PATCH v2 00/21] Runtime TDX Module update support
2026-01-14 3:08 UTC (5+ messages)
` [PATCH v2 07/21] coco/tdx-host: Expose P-SEAMLDR information via sysfs
` [PATCH v2 08/21] coco/tdx-host: Implement FW_UPLOAD sysfs ABI for TDX Module updates
[PATCH v2 00/13] Enable multi-cluster fetching for exfat_get_block
2026-01-14 3:07 UTC (6+ messages)
` [PATCH v2 10/13] exfat: support multi-cluster for exfat_map_cluster
[PATCH v8 0/3] media: qcom: camss: Add camss TPG support for multiple targets
2026-01-14 3:04 UTC (4+ messages)
` [PATCH v8 1/3] media: qcom: camss: Add common TPG support
[PATCH bpf-next v4 0/2] powerpc64/bpf: Inline helper in powerpc JIT
2026-01-14 3:04 UTC (2+ messages)
[PATCH v2 1/1] powerpc/eeh: fix recursive pci_lock_rescan_remove locking in EEH event handling
2026-01-14 3:04 UTC (2+ messages)
[PATCH v2] powerpc/pseries: Fix MSI-X allocation failure when quota is exceeded
2026-01-14 3:04 UTC (2+ messages)
[PATCH v5 0/7] powerpc: Implement masked user access
2026-01-14 3:04 UTC (2+ messages)
[syzbot] [gfs2?] INFO: task hung in writeback_iter (3)
2026-01-14 3:03 UTC (4+ messages)
` [RFC PATCH] fs/hfs: fix ABBA deadlock in hfs_mdb_commit
[REGRESSION] Unexpected section title false positive warnings on DOC: directive
2026-01-14 3:03 UTC (7+ messages)
[PATCH] net: qualcomm: ppe: Remove redundant include of dev_printk.h
2026-01-14 3:02 UTC (2+ messages)
[PATCH net-next v22 00/14] net: phy: Introduce PHY ports representation
2026-01-14 3:00 UTC (2+ messages)
[PATCH] net: sxgbe: fix typo in comment
2026-01-14 3:00 UTC (2+ messages)
[PATCH] KVM: TDX: Allow userspace to return errors to guest for MAPGPA
2026-01-14 2:59 UTC (2+ messages)
[PATCH] drm/rockchip: DRM_ROCKCHIP should depend on ARCH_ROCKCHIP
2026-01-14 2:58 UTC (2+ messages)
[PATCH 02/11] mm/damon/sysfs-schemes: support DAMOS_QUOTA_[IN]ACTIVE_MEM_BP
2026-01-14 2:57 UTC (3+ messages)
[PATCH] net: usb: r8152: fix transmit queue timeout
2026-01-14 2:56 UTC
[PATCH] hwmon: (dell-smm) Extend fan support to 5 fans
2026-01-14 2:54 UTC (2+ messages)
` [PATCH v2] "
[PATCH 03/11] Docs/mm/damon/design: document DAMOS_QUOTA_[IN]ACTIVE_MEM_BP
2026-01-14 2:51 UTC (2+ messages)
[PATCH v13 mm-new 00/16] khugepaged: mTHP support
2026-01-14 2:49 UTC (5+ messages)
` [PATCH v13 mm-new 05/16] khugepaged: introduce is_mthp_order helper
Deadlock in usb subsystem on shutdown, 6.18.3+
2026-01-14 2:45 UTC (2+ messages)
[PATCH 2/2] ksm: Optimize rmap_walk_ksm by passing a suitable address range
2026-01-14 2:40 UTC (2+ messages)
[PATCH 1/2] x86/crash: Use set_memory_p instead of __set_memory_prot
2026-01-14 2:36 UTC (5+ messages)
[PATCH v2] perf/x86/intel/uncore: Convert comma to semicolon
2026-01-14 2:36 UTC
[PATCH 1/1] nvdimm: allow exposing RAM carveouts as NVDIMM DIMM devices
2026-01-14 2:34 UTC (13+ messages)
[PATCH 0/2] riscv: dts: Add "b" ISA extension to existing devicetrees
2026-01-14 2:33 UTC (4+ messages)
` [PATCH 2/2] "
[PATCH net-next 00/11] net: fec: improve XDP copy mode and add AF_XDP zero-copy support
2026-01-14 2:32 UTC (4+ messages)
` [PATCH net-next 04/11] net: fec: add fec_build_skb() to build a skb
[PATCH V2 1/2] perf/x86/intel/uncore: Skip discovery table for offline dies
2026-01-14 2:31 UTC (2+ messages)
[tip:timers/vdso] BUILD SUCCESS WITH UNVERIFIED WARNING 576d8a7a985dde4f51a4561dddc0d8734494d3de
2026-01-14 2:28 UTC
[RFC PATCH 0/8] experimental struct filename followups
2026-01-14 2:28 UTC (4+ messages)
[PATCH] fs: make insert_inode_locked() wait for inode destruction
2026-01-14 2:26 UTC (2+ messages)
[PATCH v2 0/3] Replace wq users and add WQ_PERCPU to alloc_workqueue() users
2026-01-14 2:25 UTC (5+ messages)
` [PATCH v2 3/3] mm: add WQ_PERCPU to alloc_workqueue users
[REGRESSION] e1000e: RX stops after link down/up on Intel 8086:550a since v6.12.43 (fixed by suspend/resume)
2026-01-14 2:24 UTC (2+ messages)
[PATCH bpf-next v12 00/11] Improve the performance of BTF type lookups with binary search
2026-01-14 2:21 UTC (17+ messages)
` [PATCH bpf-next v12 03/11] tools/resolve_btfids: Support BTF sorting feature
` [PATCH bpf-next v12 04/11] libbpf: Optimize type lookup with binary search for sorted BTF
` [PATCH bpf-next v12 06/11] btf: Optimize type lookup with binary search
` [PATCH bpf-next v12 07/11] btf: Verify BTF sorting
` [PATCH bpf-next v12 10/11] libbpf: Optimize the performance of determine_ptr_size
[PATCH v2][next] virtio_net: Fix misalignment bug in struct virtnet_info
2026-01-14 2:16 UTC (5+ messages)
[PATCH] arch: arm64: set __nocfi on swsusp_arch_resume
2026-01-14 2:14 UTC (2+ messages)
[PATCH v4 00/11] riscv: spacemit: Add SpacemiT K3 SoC and K3 Pico-ITX board
2026-01-14 2:14 UTC (5+ messages)
[PATCH] ipmi: ipmb: initialise event handler read bytes
2026-01-14 2:10 UTC (3+ messages)
[PATCH v2 0/2] Add Apple Silicon SMC power driver
2026-01-14 2:10 UTC (3+ messages)
` [PATCH v2 1/2] power: supply: Add macsmc-power driver for Apple Silicon
[PATCH 0/3] dma-mapping: Improve atomic pool behaviour
2026-01-14 2:06 UTC (6+ messages)
` [PATCH 3/3] dma/pool: Avoid allocating redundant pools
[PATCH v6] PCI: loongson: Override PCIe bridge supported speeds for Loongson-3C6000 series
2026-01-14 2:05 UTC
[PATCH net-next v4 0/2] dsa: mxl-gsw1xx: Support R(G)MII slew rate configuration
2026-01-14 2:04 UTC (5+ messages)
` [PATCH net-next v4 1/2] dt-bindings: net: dsa: lantiq,gswip: add MaxLinear R(G)MII slew rate
hwmon: (dell-smm) Add Dell G15 5510 to fan control whitelist
2026-01-14 2:00 UTC (2+ messages)
` [PATCH] "
[PATCH net-next] tools/net/ynl: suppress jobserver warning in ynltool version detection
2026-01-14 2:00 UTC (2+ messages)
[PATCH 1/2] ARM: dts: broadcom: bcm2835-rpi: Move the firmware node down 1 level
2026-01-14 1:58 UTC (2+ messages)
` [PATCH 2/2] arm64: dts: broadcom: bcm2712-rpi: "
[PATCH v8 00/31] dyndbg: fix dynamic-debug regression in DRM
2026-01-14 1:57 UTC (32+ messages)
` [PATCH v8 01/31] dyndbg: factor ddebug_match_desc out from ddebug_change
` [PATCH v8 02/31] dyndbg: add stub macro for DECLARE_DYNDBG_CLASSMAP
` [PATCH v8 03/31] docs/dyndbg: update examples \012 to \n
` [PATCH v8 04/31] docs/dyndbg: explain flags parse 1st
` [PATCH v8 05/31] test-dyndbg: fixup CLASSMAP usage error
` [PATCH v8 06/31] dyndbg: reword "class unknown," to "class:_UNKNOWN_"
` [PATCH v8 07/31] dyndbg: make ddebug_class_param union members same size
` [PATCH v8 08/31] dyndbg: drop NUM_TYPE_ARRAY
` [PATCH v8 09/31] dyndbg: tweak pr_fmt to avoid expansion conflicts
` [PATCH v8 10/31] dyndbg: reduce verbose/debug clutter
` [PATCH v8 11/31] dyndbg: refactor param_set_dyndbg_classes and below
` [PATCH v8 12/31] dyndbg: tighten fn-sig of ddebug_apply_class_bitmap
` [PATCH v8 13/31] dyndbg: replace classmap list with a vector
` [PATCH v8 14/31] dyndbg: macrofy a 2-index for-loop pattern
` [PATCH v8 15/31] dyndbg,module: make proper substructs in _ddebug_info
` [PATCH v8 16/31] dyndbg: hoist classmap-filter-by-modname up to ddebug_add_module
` [PATCH v8 17/31] dyndbg: move mod_name down from struct ddebug_table to _ddebug_info
` [PATCH v8 18/31] dyndbg-API: remove DD_CLASS_TYPE_(DISJOINT|LEVEL)_NAMES and code
` [PATCH v8 19/31] selftests-dyndbg: add a dynamic_debug run_tests target
` [PATCH v8 20/31] dyndbg: change __dynamic_func_call_cls* macros into expressions
` [PATCH v8 21/31] dyndbg-API: replace DECLARE_DYNDBG_CLASSMAP
` [PATCH v8 22/31] dyndbg: detect class_id reservation conflicts
` [PATCH v8 23/31] dyndbg: check DYNAMIC_DEBUG_CLASSMAP_DEFINE args at compile-time
` [PATCH v8 24/31] dyndbg-test: change do_prints testpoint to accept a loopct
` [PATCH v8 25/31] dyndbg-API: promote DYNAMIC_DEBUG_CLASSMAP_PARAM to API
` [PATCH v8 26/31] dyndbg: treat comma as a token separator
` [PATCH v8 27/31] dyndbg: split multi-query strings with %
` [PATCH v8 28/31] selftests-dyndbg: add test_mod_submod
` [PATCH v8 29/31] dyndbg: resolve "protection" of class'd pr_debug
` [PATCH v8 30/31] dyndbg: add DYNAMIC_DEBUG_CLASSMAP_USE_(dd_class_name, offset)
` [PATCH v8 31/31] docs/dyndbg: add classmap info to howto
[PATCH] of: platform: Use default match table for /firmware
2026-01-14 1:51 UTC
[PATCH v2] media: mali-c55: Fix NULL dev stream alert for tpg/rsz/isp sub-device
2026-01-14 1:50 UTC
[pull-request] mlx5-next updates 2026-01-13
2026-01-14 1:50 UTC (2+ messages)
[PATCH v3 00/24] KVM: TDX huge page support for private memory
2026-01-14 1:48 UTC (10+ messages)
` [PATCH v3 01/24] x86/tdx: Enhance tdh_mem_page_aug() to support huge pages
[PATCH] mm/shmem, swap: fix race of truncate and swap entry split
2026-01-14 1:46 UTC (8+ messages)
[PATCH] rust: fix typo in bindings
2026-01-14 1:43 UTC (2+ messages)
[GIT PULL] clk: spacemit: Updates for v6.20
2026-01-14 1:43 UTC
linux-next: duplicate patch in the i2c-host tree
2026-01-14 1:43 UTC
[PATCH] arm64: kconfig: Make STRICT_KERNEL_RWX visable
2026-01-14 1:38 UTC
page: next (older) | prev (newer) | latest
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®